Results 1 to 12 of 12

Thread: Kali 2 and nvidia drivers

  1. #1
    Join Date
    2015-Jul
    Posts
    12

    Kali 2 and nvidia drivers

    Installed KAli 2 without any problems... pretty straightforward and quick...

    However i have had to re-install it 11 times in a day due the typical black-screen/hanging error that happens when u reboot after running:

    apt-get update
    apt-get dist-upgrade
    apt-get install -y linux-headers-$(uname -r)
    apt-get install nvidia-kernel-dkms

    IT seems when it gives me the warning aboutthe neauvau driver problem (as with akali 1) there is an additional warning about my particular nvidia graphics card not being supported but i am unsure as to whether this is a generic warning and i ok and proceed...

    After running these lines:

    sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
    update-grub
    reboot

    THe reboot just hangs before login........... this appears to be the standard effect everytime i run these lines. So i tried different options to test things out... when prompting me to install the nvidia drivers this time i said 'no' and proceeded... the system rebooted fine, i could see the graphics 'twitching' miliseconds prior to logging in (which was odd) but it was fine... when i ran: glxinfo | grep -i "direct rendering" i got a yes.... but when i tried to install a package later i was met with unmet dependencies affecting package installation recommnded installing nvidia-settings, etc. Tried that and failed. Anotehr interesting thing happened - my screen resolution was stretched on reboot with the 'no' option but i used xandr to recorrect. I thougth that was it but the unmet dependencies was still playing up. Eventually i just re-installed the system... updated but did not run apt-get install nvidia-kernel-dkms. I wanted to see if i was getting direct rendering of 3d without nvidia drivers/protocols being installed so i ran glxinfo | grep -i "direct rendering" and it said yes...

    At this stage i kinda gave up and decided to follow Blackmoreops http://www.blackmoreops.com/2015/02/...nvidia-driver/ guide that worked for my setup on kali 1.xx however this time when i get to aptitude install nvidia-xconfig thats when i had to quit as it seemed xconfig could not be summoned after installing.. any/all reboots lead to the same black/screen reboot crash.

    My nvidia graphics card is quite old.. even on windows there is limited support but it still functions well ... running lspci: NVIDIA Corporation G96 [GeForce 9400 GT]


    ANy and all help would be greatly appreciated.. i really do not want to have to keep re-installing this system especially after my dual boot with windows 10 was juiced...

  2. #2
    Join Date
    2015-Jul
    Posts
    12

    additional info

    Ok. NO dearth of responses then :/


    Additional information: [The warning]:

    ' This system has a graphics card which is no longer handled by the NVIDIA │
    │ driver (package nvidia-driver). You may wish to keep the package │
    │ installed - for instance to drive some other card - but the card with │
    │ the following chipset won't be usable: │
    │ │
    │ 02:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96 │
    │ [GeForce 9400 GT] [10de:0641] (rev a1) │
    │ │
    │ The above card requires either the non-free legacy NVIDIA driver │
    │ (package nvidia-legacy-340xx-driver) or the free Nouveau driver (package │
    │ xserver-xorg-video-nouveau). │
    │ │
    │ Before the Nouveau driver can be used you must remove NVIDIA │
    │ configuration from xorg.conf (and xorg.conf.d/).'



    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    The specific driver for my nvidia card can be retrieved via: http://uk.download.nvidia.com/XFree8..._64-340.96.run but i would like someone with intimate knowledge of kali 2 to best explain how i should go about installing this given the prior warnings on install. I mean do i have install this dirver manually first? Then install the dependencies manually/individually? Or is there an easier way to do this?

    MANy thanks....

  3. #3
    Join Date
    2015-Dec
    Posts
    3
    im going through this issue at the mo mate, will update once ive figured it out...

  4. #4
    Join Date
    2015-Dec
    Posts
    3

  5. #5
    Join Date
    2015-Jul
    Posts
    12
    Quote Originally Posted by turbominicooper View Post
    Yeah thanks for the link but as i'm fairly i was trying to figure out how to locate the folder (in my case Desktop).

    Actually it worked: except when i type in the command : init 3. WEll what exactly is supposed to happen? As far as i understand it runs the system at another level but is it a reboot and if so if kali desktop doesnt start back up how are you supposed input the final scripts in the instructions? In anycase - i restarted without init 3 to see if the setup for my proprietary driver would work and it did.. all i had to do was locate where i down-loaded it (downloads), transfer to desktop then enter the following commands: cd \Desktop, chmod u+x NVIDIA-Linux-x86_64-352.55.run, ./NVIDIA-Linux-x86_64-352.55.run.

    That all worked which is great but of course (as the guide warns): 3. The installer complains if X server is started, so go in runlevel 3init 3): I did that but it seemed to hang on reboot... should i have waited a bit longer? or is there a command (e.g., ctrl+alt+del) to bring up the bash? If this works then i will have solved this problem so thank you...

  6. #6
    Join Date
    2015-Jul
    Posts
    12
    yes.. xserver needs to be killed at stage 3 for sure

  7. #7
    Join Date
    2015-Jul
    Posts
    12
    Ok. I was still having trouble with the init 3 command for some reason but found that ctrl+alt+F2 gets there and i can Init 3 from there.. Check level with 'runlevel' .. Confirmed and then i could install from there... however, on the first attempt i got the nouveaue warning so i disabled that and re-tried.... on the second attempt it seemed to be going well then it threw up this warning:

    ERROR: Kernel configuration is invalid."; \
    echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
    echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it.";

    Been looking in various forums but havent found anything promising/solid yet.... seems i'm getting closer but i am stumped here.. so definitely need help at this stage...

  8. #8
    Join Date
    2015-Jul
    Posts
    12
    ERROR: Kernel configuration is invalid."; \
    echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
    echo >&2 " Run 'make oldconfig && make prepare

  9. #9
    Join Date
    2015-Jul
    Posts
    12
    Problem Solved for NVIDIA proprietary drivers (older ones at least):

    Find your specific driver at: http://www.nvidia.co.uk/Download/index.aspx?lang=en-uk and save to Desktop.

    Commands followed:

    apt-get update
    apt-get dist-upgrade
    apt-get install -y linux-headers-$(uname -r)

    DO NOT: apt-get install nvidia-kernel-dkms (this will prevent you from installing your specific driver that is not covered in the generic nvidia package)

    Then run: sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
    update-grub
    reboot

    - The proprietary driver wont install without this nouveau being killed so do that now...

    Type: CTRL+ALT+F2 and at the prompt type 'init 3'. Check status with 'runlevel' command (it should say 3 or something like 5 3.

    Locate the .run/exe file on Desktop with cd \Desktop and execut with chmod u+x [file name as on desktop]

    Install should work fine now....


    The only problem now (and its bugging me a little) is that every time i install a package (whatever package) it is asking me whether i want to uninstall the driver i have installed and re-install the generic package! I always click no and i double checked with nvidia-settings (having to install it and doing the same thing with that - i.e., saying no to uninstalling my proprietary driver) which confirms that my driver is installed and recognized. It seems to work fine... but i dont understand why apt-get install [package x, y, z] would cause nvidia uninstall to initiate....

    Also, every package installs successfully despite warnings that it hasn't... pulseaudio controllers, transmission, etc... but i suspect the final warning is that the specific driver for my nvidia card wasnt uninstalled and that was all...
    Last edited by Fushikkles; 2016-01-04 at 20:17.

  10. #10
    Join Date
    2015-Jul
    Posts
    12
    IT works but this is the warning i keep getting with any package installs or uninstalls.. i just have to keep saying no which is a nuisance:

    ERROR: Please run 'nvidia-installer --uninstall' manually or delete it.
    dpkg: error processing package nvidia-installer-cleanup (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    nvidia-installer-cleanup

  11. #11
    Join Date
    2017-Jan
    Posts
    1

    Question Help please

    Quote Originally Posted by Fushikkles View Post
    Problem Solved for NVIDIA proprietary drivers (older ones at least):

    Find your specific driver at: http://www.nvidia.co.uk/Download/index.aspx?lang=en-uk and save to Desktop.

    Commands followed:

    apt-get update
    apt-get dist-upgrade
    apt-get install -y linux-headers-$(uname -r)

    DO NOT: apt-get install nvidia-kernel-dkms (this will prevent you from installing your specific driver that is not covered in the generic nvidia package)

    Then run: sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub
    update-grub
    reboot

    - The proprietary driver wont install without this nouveau being killed so do that now...

    Type: CTRL+ALT+F2 and at the prompt type 'init 3'. Check status with 'runlevel' command (it should say 3 or something like 5 3.

    Locate the .run/exe file on Desktop with cd \Desktop and execut with chmod u+x [file name as on desktop]

    Install should work fine now....


    The only problem now (and its bugging me a little) is that every time i install a package (whatever package) it is asking me whether i want to uninstall the driver i have installed and re-install the generic package! I always click no and i double checked with nvidia-settings (having to install it and doing the same thing with that - i.e., saying no to uninstalling my proprietary driver) which confirms that my driver is installed and recognized. It seems to work fine... but i dont understand why apt-get install [package x, y, z] would cause nvidia uninstall to initiate....

    Also, every package installs successfully despite warnings that it hasn't... pulseaudio controllers, transmission, etc... but i suspect the final warning is that the specific driver for my nvidia card wasnt uninstalled and that was all...
    So, I did everething and get error after instalation downloaded nvidia driver:

    1.jpg
    and
    2.jpg

    Can someone help me please?

  12. #12
    Join Date
    2013-Oct
    Posts
    18
    Hey guys,
    This is my uname -v:
    Code:
    #1 SMP Debian 4.6.4-1kali1 (2016-07-21)
    I am following the guide and I can't continue from here:
    Code:
    root@kali:~# apt-get install -y linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package linux-headers-4.6.0-kali1-amd64
    E: Couldn't find any package by glob 'linux-headers-4.6.0-kali1-amd64'
    E: Couldn't find any package by regex 'linux-headers-4.6.0-kali1-amd64'
    Any advice how to continue?
    Thanks

Similar Threads

  1. Replies: 1
    Last Post: 2016-09-24, 07:25
  2. [HOW TO] Install Nvidia Drivers on Kali 2.0 x86
    By Kalibruz in forum How-To Archive
    Replies: 0
    Last Post: 2015-10-04, 01:18
  3. Nvidia Kali Sana Drivers
    By wifiuk in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2015-09-28, 07:10
  4. Nvidia Drivers for Kali not working (conflicting drivers)?
    By in10se in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-09-25, 18:59
  5. Install NVIDIA Drivers on Kali
    By Algierd in forum General Archive
    Replies: 0
    Last Post: 2013-12-16, 22:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •