Results 1 to 9 of 9

Thread: Apt-get install oclhashcat does not install latest version (Unable to run)

  1. #1
    Join Date
    2015-Dec
    Posts
    9

    Apt-get install oclhashcat does not install latest version (Unable to run)

    I am running Kali Linux 2.0 with sources.list properly written with correct repositories.
    However when I install oclhashcat, it just installs the older version 1.36 and not newest 2.01, hence not allowing me to run.

    I have already ran apt-get update and upgrade and dist-upgrade beforehand so all should be well

    Code:
    root@kali:~# apt-get install oclhashcat
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    oclhashcat is already the newest version.
    The following package was automatically installed and is no longer required:
      guile-2.0-libs
    Use 'apt-get autoremove' to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@kali:~# oclhashcat
    
    
    ERROR: This copy of oclHashcat is outdated. Get a more recent version.
    
    root@kali:~#
    Was just wondering why from official repositories it does not updates to newest version?

  2. #2
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Not sure why it's not the newest. I'd guess none of the maintainers have got to it yet. You could request it in the Kali Linux bug tracker.

    If you run an NVIDIA chip-set, you could use the .deb I make. Otherwise, you could always install manually from their site and just add your own bash completions (which is essentially what my deb does)

    https://forums.kali.org/showthread.p...ll=1#post35240
    chown -R us ./base

  3. #3
    Join Date
    2015-Dec
    Posts
    9
    Hey thanks for the reply staticn0de!! I couldnt make it work so i in the end downloaded the zip file directly from hashcat and run the .bin straight from there.
    Btw I didnt get it to work though now it was a different problem, "segmentation fault"?

    Is it due to my AMD APP SDK installed? I was wondering how to deal w it as I need it for my pyrit to run too I cant just uninstall it?

  4. #4
    Join Date
    2016-Jan
    Posts
    3
    Hi,
    I'm a complete noob to Linux and just downloaded Kali. I am also trying to get hashcat to work but get the same out of date message. I downloaded the zip file for hashcat but have no idea what to do with the contents of the zip. What do I do?

  5. #5
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Quote Originally Posted by titmy View Post
    Hey thanks for the reply staticn0de!! I couldnt make it work so i in the end downloaded the zip file directly from hashcat and run the .bin straight from there.
    Btw I didnt get it to work though now it was a different problem, "segmentation fault"?

    Is it due to my AMD APP SDK installed? I was wondering how to deal w it as I need it for my pyrit to run too I cant just uninstall it?


    What is segfaulting? Pyrit or oclhashcat? Post command output and what you have installed so far with the guides you used.
    chown -R us ./base

  6. #6
    Join Date
    2014-Apr
    Location
    Down Under
    Posts
    315
    Quote Originally Posted by jakemp1 View Post
    Hi,
    I'm a complete noob to Linux and just downloaded Kali. I am also trying to get hashcat to work but get the same out of date message. I downloaded the zip file for hashcat but have no idea what to do with the contents of the zip. What do I do?
    Unzip it and run the .bin file
    chown -R us ./base

  7. #7
    Join Date
    2016-Jan
    Posts
    3
    I saw online that I need to run
    Code:
    chmod +x file.bin
    ./file.bin
    I downloaded oclHashcat v2.01 and tried that on the oclHashcat64.bin file and I got this error
    Code:
    ./oclHashcat64.bin: error whileloading shared libraries: libOpenCL.so.1: cannot open shared object file: No such file or directory
    Did I do something wrong?

  8. #8
    Join Date
    2014-Dec
    Location
    Poland
    Posts
    27
    u have to install OpenCL libraries.

  9. #9
    Join Date
    2016-Jan
    Posts
    3
    I cannot seem to find where to download the libraries from. I looked at this wiki and none of them seemed to work when I ran apt-get install. http://wiki.tiker.net/OpenCLHowTo#Debian

Similar Threads

  1. Help me to install nvidia cuda and pyrit and oclhashcat
    By su6z3r0 in forum General Archive
    Replies: 1
    Last Post: 2016-06-29, 21:54
  2. Replies: 12
    Last Post: 2015-11-12, 21:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •