Results 1 to 17 of 17

Thread: Nethunter 3.0 - ldconfig not found

  1. #1
    Join Date
    2013-Mar
    Posts
    42

    Nethunter 3.0 - ldconfig not found

    Hi,

    i installed Nethunter 3.0 on my Nexus 7 2013 Deb (LTE-Version) with the new Linux Installer from scratch. Used the Android Version 6.0.1.
    If i want to add a MetaPackage "kali-linux-wireless" for example i recieve this error message in the terminal:

    Code:
    dpkg: warning: 'ldconfig' not found in PATH or not executable
    dpgk: error: 1 expected program not found in PATH or not executeable
    NOTE: root´s PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    The installation failed!

    Any hints ?
    Thanks

  2. #2
    Join Date
    2015-Nov
    Posts
    9
    Hello BeNe,

    There is a workaround that should solve this issue:

    Open the terminal app, click the menu on top-right (3 dots), go to preferences, then find the option called: Verify PATH entries and uncheck it.

    Let me now if it fixed the problem.

  3. #3
    Join Date
    2013-Mar
    Posts
    42
    Hi jmingov,

    yes that fixed the problem!

    Thanks!

  4. #4
    Join Date
    2016-Mar
    Posts
    29

    help please

    I have always that message
    root@kali:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up postgresql-9.4 (9.4.6-0+deb8u1) ...
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-03-13 17:01:44 UTC [2310-1] FATAL: could not create shared memory segment: Function not implemented 2016-03-13 17:01:44 UTC [2310-2] DETAIL:[FAILed system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing package postgresql-9.4 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    postgresql-9.4
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~#

  5. #5
    Join Date
    2015-Nov
    Posts
    24
    Quote Originally Posted by root1234 View Post
    I have always that message
    root@kali:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up postgresql-9.4 (9.4.6-0+deb8u1) ...
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-03-13 17:01:44 UTC [2310-1] FATAL: could not create shared memory segment: Function not implemented 2016-03-13 17:01:44 UTC [2310-2] DETAIL:[FAILed system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing package postgresql-9.4 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    postgresql-9.4
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~#
    Hi there , try
    apt-get install postgresql-9.4
    and then copy and show me the errors log.
    cause postgresql-9.4 package conflict with the old one has been installed

  6. #6
    Join Date
    2016-Mar
    Posts
    29
    # apt-get install postgresql-9.4
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    postgresql-9.4 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up postgresql-9.4 (9.4.6-0+deb8u1) ...
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-04-01 19:19:26 UTC [21861-1] FATAL: could not create shared memory segment: Function not implemented 2016-04-01 19:19:26 UTC [21861-2] DETAI[FAILiled system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing package postgresql-9.4 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    postgresql-9.4

    E: Sub-process /usr/bin/dpkg returned an error code (1)

  7. #7
    Join Date
    2016-Mar
    Posts
    29
    # service postgresql start
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-04-01 15:06:57 UTC [31454-1] FATAL: could not create shared memory segment: Function not implemented 2016-04-01 15:06:57 UTC [31454-2] DETAI[FAILiled system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!

  8. #8
    Join Date
    2015-Nov
    Posts
    24
    Quote Originally Posted by root1234 View Post
    # service postgresql start
    [....]....] The PostgreSQL server failed to start. Please check the log output: 2016-04-01 15:06:57 UTC [31454-1] FATAL: could not create shared memory segment: Function not implemented 2016-04-01 15:06:57 UTC [31454-2] DETAI[FAILiled system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!
    Remove postgresql-9.4 and reinstall :
    apt-get remove postgresql-9.4
    Then reinstall :
    apt-get install postgresql-9.4
    Result will be:
    [ ok ] Starting PostgreSQL 9.4 database server: main
    Before add Metapackages :
    apt-get update
    Last edited by Duane; 2016-04-02 at 05:10. Reason: More info.

  9. #9
    Join Date
    2016-Mar
    Posts
    29
    OK I reinstalled it But when I installed it again I get
    root@kali:~# apt-get install postgresql-9.4
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following package was automatically installed and is no longer required:
    python-pexpect
    Use 'apt-get autoremove' to remove it.
    Suggested packages:
    oidentd ident-server
    The following NEW packages will be installed:
    postgresql-9.4
    0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
    Need to get 0 B/3231 kB of archives.
    After this operation, 15.9 MB of additional disk space will be used.Selecting previously unselected package postgresql-9.4.
    (Reading database ... 156553 files and directories currently installed.)
    Preparing to unpack .../postgresql-9.4_9.4.6-0+deb8u1_armhf.deb ...
    Unpacking postgresql-9.4 (9.4.6-0+deb8u1) ...
    Processing triggers for postgresql-common (165) ...
    supported-versions: WARNING! Unknown distribution: kali
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2.0
    Building PostgreSQL dictionaries from installed myspell/hunspell packages...
    Removing obsolete dictionary files:
    Setting up postgresql-9.4 (9.4.6-0+deb8u1) ...
    update-alternatives: using /usr/share/postgresql/9.4/man/man1/postmaster.1.gz to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto mode
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-04-03 02:31:14 UTC [4363-1] FATAL: could not create shared memory segment: Function not implemented 2016-04-03 02:31:14 UTC [4363-2] DETAIL:[FAILed system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing package postgresql-9.4 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    postgresql-9.4

  10. #10
    Join Date
    2016-Mar
    Posts
    29
    root@kali:~# apt-get remove postgresql-9.4
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following package was automatically installed and is no longer required:
    python-pexpect
    Use 'apt-get autoremove' to remove it.
    The following packages will be REMOVED:
    armitage kali-linux-nethunter mana-toolkit metasploit-framework postgresql
    postgresql-9.4 set
    0 upgraded, 0 newly installed, 7 to remove and 3 not upgraded.
    1 not fully installed or removed.
    After this operation, 242 MB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 171335 files and directories currently installed.)
    Removing kali-linux-nethunter (2.42) ...
    Removing set (6.5.8-0kali1) ...
    dpkg: warning: while removing set, directory '/usr/share/set/src/logs' not empty so not removed
    dpkg: warning: while removing set, directory '/usr/share/set/src/html' not empty so not removed
    Removing mana-toolkit (0~20150707-0kali2) ...
    Site 000-mana-toolkit disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site accounts.google disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site apple disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site blackberry disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site facebook disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site gmail.com disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site google disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site secure-redirect disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Site windows disabled.
    To activate the new configuration, you need to run:
    service apache2 reload
    Enabling site 000-default.
    To activate the new configuration, you need to run:
    service apache2 reload
    Removing armitage (20150812-1kali1) ...
    Removing metasploit-framework (4.11.5-2016010401-0kali1~r1u1) ...
    dpkg: warning: while removing metasploit-framework, directory '/usr/share/metasploit-framework/config' not empty so not removed
    Removing postgresql (9.4+165) ...
    Removing postgresql-9.4 (9.4.6-0+deb8u1) ...
    [ ok ] Stopping PostgreSQL 9.4 database server: main.
    Processing triggers for man-db (2.7.0.2-5) ...
    Processing triggers for postgresql-common (165) ...
    supported-versions: WARNING! Unknown distribution: kali
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2.0
    Building PostgreSQL dictionaries from installed myspell/hunspell packages...
    Removing obsolete dictionary files:

    root@kali:~#

  11. #11
    Join Date
    2015-Nov
    Posts
    24
    Hey Root1234
    I think you should flash Kali nethunter again .
    Boot into recovery mode and install Nethunter from your SDcard.

  12. #12
    Join Date
    2016-Mar
    Posts
    29
    Yeah thanks. that what I did exactly .I find out that the nethunter is not working smoothly on android v 6.0.1 and android 6.0.0 and androidbv 6.1.1 and more but only on the (nexus 6 ). so I flashed a new rom 5.1.1 now it's working just fine.
    Last edited by root1234; 2016-04-07 at 09:39.

  13. #13
    Join Date
    2016-Mar
    Posts
    29
    Duane said
    Thanks for been helpful

  14. #14
    Join Date
    2016-Mar
    Posts
    29
    I was having the android 5.1.1 before I have flashed the phone in to 6.0.1 . The android v 5.1.1 was having a problem on my phone the phone shutdown when the battery is 30 that's way I flashed a new ram on it.

  15. #15
    Join Date
    2015-Nov
    Posts
    24

    Custom ROM for Nexus 6

    Quote Originally Posted by root1234 View Post
    I was having the android 5.1.1 before I have flashed the phone in to 6.0.1 . The android v 5.1.1 was having a problem on my phone the phone shutdown when the battery is 30 that's way I flashed a new ram on it.
    If your phone is Nexus 6 - I recommend to use this ROM . Nethunter is working good with it.

    http://www.mediafire.com/download/tt..._r9_Stable.zip

    Install this custom ROM same way you install Nethunter

  16. #16
    Join Date
    2016-Mar
    Posts
    29
    Averting works great now
    But still having that
    :~# service apache2 start
    [....] Starting web server: apache2AH00112: Warning: DocumentRoot [/usr/share/mana-toolkit/www/facebook] does not exist
    AH00557: apache2: apr_sockaddr_info_get() failed for WRT54G
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
    . ok
    :~#
    and when I run msfconsole I get that output
    ~# msfconsole
    [-] Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
    could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?
    [*] Starting the MeTasploit Framework console...\

  17. #17
    Join Date
    2016-Nov
    Posts
    1
    Quote Originally Posted by jmingov View Post
    Hello BeNe,

    There is a workaround that should solve this issue:

    Open the terminal app, click the menu on top-right (3 dots), go to preferences, then find the option called: Verify PATH entries and uncheck it.

    Let me now if it fixed the problem.
    Hello jmingov,

    Thank you so much. Your "workaround" fixed my update problem in Nethunter.

    zzzzzz

Similar Threads

  1. Issues found when launching Mana from NetHunter app menu
    By s0b31t in forum NetHunter General Questions
    Replies: 0
    Last Post: 2015-09-27, 20:34
  2. Replies: 1
    Last Post: 2015-05-08, 02:13
  3. ldconfig: /usr/lib/libssl.so.0.9.8 is not a symbolic link FIX
    By Nik@S_DaRk in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-01-06, 11:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •