Results 1 to 3 of 3

Thread: Issue with the upgrade of metasploit-framework

  1. #1
    Join Date
    2015-Dec
    Posts
    3

    Issue with the upgrade of metasploit-framework

    Hi,

    I'm running Kali 2 (32bit) on a Virtual Box VM with MAC OS X as Host. After running apt-get update and apt-get dist-upgrade I can have all packages upgraded with only one exception, metasploit-framework:

    ------------
    Err http://http.kali.org/kali/ sana/main metasploit-framework i386 4.11.5-2015121501-0kali1~r1u1
    404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...~r1u1_i386.deb 404 Not Found

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    -------------

    this is what I have in my sources file:

    root@kali:~# cat /etc/apt/sources.list
    #
    deb http://http.kali.org/kali sana main non-free contrib
    deb http://security.kali.org/kali-security sana/updates main contrib non-free

    Any hints appreciated,

    thanks,
    Filippo

  2. #2
    Join Date
    2015-Oct
    Posts
    37
    You're missing source repositories. Add these to your sources.list

    deb-src http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

  3. #3
    Join Date
    2015-Dec
    Posts
    3
    Quote Originally Posted by aephlux View Post
    You're missing source repositories. Add these to your sources.list

    deb-src http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free
    thanks a lot, now it is working. It's kind of weird though, because my understanding was that these deb-src repositories are optional and I initially removed them in order to keep the storage needs to a minimum!

Similar Threads

  1. apt-get upgrade stuck in loop downloading metasploit-framework
    By digitallachance in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-07-14, 08:37
  2. Can't Update Metasploit Framework
    By Vandercast in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2017-05-26, 17:53
  3. Metasploit-framework wont start after dist-upgrade?
    By jacke4123 in forum General Archive
    Replies: 1
    Last Post: 2015-10-31, 20:41
  4. Replies: 3
    Last Post: 2015-03-31, 14:50
  5. Metasploit Framework won't update!
    By murdoc in forum General Archive
    Replies: 1
    Last Post: 2014-11-03, 09:39

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •