Hi all

I am relatively new to using any linux os and I have installed Kali to run alongside windows.

I partitioned my drive and installed kali using a live usb in the free space I made for it.

I pretty much followed a tutorial on youtube, as well as many others, just to make sure I was doing it right.

However, before installing, windows 10 would boot in legacy or UEFI. The only way I could get the Kali USB to boot was to disable secure-boot, which meant switching from UEFI to legacy in bios.

After installing kali, I rebooted my system and It came up with the grub loader for kali. There is no option for windows, only kali or kali advanced. So I tried os-prober in terminal and it said 'No volume groups found'.
I tried updating the grub loader as well but it said the same thing after finding the files etc.

I can boot into windows 10 again by going into BIOS and switching back to UEFI from legacy. However, this is the only way I can switch between OS's.

If anyone can help me with a reason why/a way to fix it I would be very grateful as I am new to this stuff and have no clue