Results 1 to 2 of 2

Thread: How to connect a Kali 2.0 VMWare image to a Cisco AnyConnect VPN on the host

  1. #1
    Join Date

    How to connect a Kali 2.0 VMWare image to a Cisco AnyConnect VPN on the host

    HI Guys,

    I've been banging my head around this issue for around a week now and if at all possible would greatly appreciate
    some divine intervention (I'm sure I've missed something somewhere ...)

    Firstly, this is my setup :

    - Running VMWare wrokstation 12
    - Host is Windows 10
    - Have double checked firewall settings (Nortons 360) on host and it (seems to me at least) that there is no block on VM based communications.
    - Kali Linux 2.0 running as a VM
    - Connecting to a VPN using Cisco AnyConnect Client 3.1.06073 on the host
    - Across the VPN there are numerous subnets of interest where I'd love to utilize the power of Kali ...

    The issue I'm having is that I can't get the Kali Linux VM to be able to use the VPN device.

    I have tried a number of different combinations (which I'll describe next) but with no luck :

    - Set up a new VMWare adapter to use direct bridging to the VPN device.
    Presented this to Kali as eth1 and added the route. No go.

    - Attempted to use NAT to communicate with the device.
    Again, presented this to Kali as eth1 and no go.

    At this stage I'm still assuming that this is possible somehow but I would appreciate any inputs / guidance
    on how I could possibly make this work.

    Many Thanks,


  2. #2
    Join Date
    Hi All,

    After a bit of fiddling around, I worked out what this was so thought I'd share the experience ... .

    The issue would seem to be in the way that VMWare workstation manages it's virtual networks.
    When I run my VMs, I'm in the habit of creating a bridged VNIC and then any other types I might need after that.
    In this case, I created a 2nd VNIC for NAT.

    When this didn't work, I tried other various combinations, deleted what did not work, tried again, etc.

    When debugging this, I had a look in the VMs configuration file - in this case, kali.vmx, and found much to my
    surprise some of configs I thought I had deleted were still there!

    Seeing all this etc., I decided to re-install (create a new VM) and this time JUST specify a NAT connection and
    no others.

    Bingo! It all worked and the NAT routing through the VPN now worked correctly.

    The morals of this story are :

    1. If you need any VPN type work, stick with just a simple single NAT VNIC to the VM.
    2. To be careful with how VMWare Workstation manages it's configs, esp. if you are
    trying out different combinations of settings (in desperation) as I was.

    Hope this proves useful to anyone else out there who comes across this.



Similar Threads

  1. Replies: 0
    Last Post: 2022-01-26, 16:22
  2. How to make Kali Linux connect through a host
    By Smartbingari in forum General Archive
    Replies: 0
    Last Post: 2015-10-25, 14:53
  3. Cannot install Cisco Anyconnect on Kali 2.0 ?
    By sainete in forum General Archive
    Replies: 0
    Last Post: 2015-10-13, 21:30
  4. Replies: 5
    Last Post: 2015-08-15, 05:41

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts