Results 1 to 3 of 3

Thread: wlan0 getting killed everytime I try to change channels

  1. #1
    Join Date
    2016-Jan
    Posts
    3

    wlan0 getting killed everytime I try to change channels

    Hello my friends,

    I came up with a problem, since I think the last update but I might be wrong.
    Everytime I put my wlan0 interface in monitor mode and I try to switch channels after it gets killed and I can't do anything with it until I reboot.

    I use kali Linux in a vmware station and I use an Asus AC56 Wi-fi USB adapter. I know that there was some driver issues with that model but it was working fine since I probably did something wrong or since the last update.

    -Monitor mode works (until I try to change channel).
    -Injection works (until it tries to change channel).
    -Airmon-ng works (until I try to change channel).
    -I already had Aireplay to work fine and I even got an handshake with it.
    -I can change channels when I'm in managed mode and I can also access the internet and select my network normally when I use it in managed mode.
    -I can get a wireshark capture in monitor mode until I try to change channels.

    My chipset is :
    WI1 chip1: Broadcom BCM4352 (2.4 GHz)
    WI2 chip1: Broadcom BCM43217 (5GHz)

    I'm only working on 2.4GHz channels for now. I had it to work with the driver provided on this page : https://wikidevi.com/wiki/ASUS_USB-AC56


    I don't think this is a driver issue since it already worked when I was trying it before.
    So to do it quick when I input :
    Code:
    iwconfig wlan0 mode monitor
    It works fine. when I put in
    Code:
    iwconfig wlan0
    it says that my card is in monitor mode and the normal interface info.

    But after that when I do :
    Code:
    iwconfig wlan0 channel 6
    the only output that I have is :
    Code:
    Killed
    and after that everything that has to do with interfaces (iwconfig, ifconfig) doesn't work and freezes my terminal when I try to do something with it.
    I try
    Code:
    airmon-ng check kill
    but it doesn't make any difference. I also tried to change channel with airmon-ng and it also says that the interface gets killed.

    Anybody knows where it could come from (the thing I don't get is that it was working before so I probably did something wrong...) ?
    Any help would be greatly appreciated. Thanks!

  2. #2
    Join Date
    2013-Sep
    Posts
    14
    I am not sure but I have the same issue when launching wifite.
    The only way to get the network up again is to start the networkmanager found in /etc/init.d

    Something is definitely wrong with Kali Rolling editition. I can't believe that Kali has issues with networking since it's used for pentesting 80% of the time and networking is like the heartbeat.

  3. #3
    Join Date
    2014-Dec
    Location
    Poland
    Posts
    27
    I was testing today rolling... it was a big mistake to install it. I made a fresh install from virtual box. When i connect awus036h, the led is starting blinking, in manager i see WiFi networks but can't connect, when im puting it in monitor mode it doesn't find any network.

Similar Threads

  1. Replies: 0
    Last Post: 2016-09-04, 12:12
  2. libobasis4.2 error everytime I try to use apt-get
    By MrOddBall in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2014-06-22, 07:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •