Hello my friends,

I came up with a problem, since I think the last update but I might be wrong.
Everytime I put my wlan0 interface in monitor mode and I try to switch channels after it gets killed and I can't do anything with it until I reboot.

I use kali Linux in a vmware station and I use an Asus AC56 Wi-fi USB adapter. I know that there was some driver issues with that model but it was working fine since I probably did something wrong or since the last update.

-Monitor mode works (until I try to change channel).
-Injection works (until it tries to change channel).
-Airmon-ng works (until I try to change channel).
-I already had Aireplay to work fine and I even got an handshake with it.
-I can change channels when I'm in managed mode and I can also access the internet and select my network normally when I use it in managed mode.
-I can get a wireshark capture in monitor mode until I try to change channels.

My chipset is :
WI1 chip1: Broadcom BCM4352 (2.4 GHz)
WI2 chip1: Broadcom BCM43217 (5GHz)

I'm only working on 2.4GHz channels for now. I had it to work with the driver provided on this page : https://wikidevi.com/wiki/ASUS_USB-AC56

I don't think this is a driver issue since it already worked when I was trying it before.
So to do it quick when I input :
iwconfig wlan0 mode monitor
It works fine. when I put in
iwconfig wlan0
it says that my card is in monitor mode and the normal interface info.

But after that when I do :
iwconfig wlan0 channel 6
the only output that I have is :
and after that everything that has to do with interfaces (iwconfig, ifconfig) doesn't work and freezes my terminal when I try to do something with it.
I try
airmon-ng check kill
but it doesn't make any difference. I also tried to change channel with airmon-ng and it also says that the interface gets killed.

Anybody knows where it could come from (the thing I don't get is that it was working before so I probably did something wrong...) ?
Any help would be greatly appreciated. Thanks!