Results 1 to 5 of 5

Thread: Driver for Intel Skylake Integrated Graphics fails to load

  1. #1
    Join Date
    2016-Jan
    Posts
    2

    Driver for Intel Skylake Integrated Graphics fails to load

    Driver for Intel Skylake Integrated Graphics fails to load


    I am trying to install bumblebee along with the nvidia propietary drivers on an ASUSK501UX that has Skylake integrated graphics and an nvidia gtx950m. From what I have read, this set up requires kernel version 4.3 or higher and at least Mesa 11. So I first installed kernel 4.3.0 (along with the headers) from the kali-rolling repos and then installed
    Code:
    libgl1-mesa-glx
    from the same repos. Afterwords, I installed bumblebee with
    Code:
    apt-get install bumblebee-nvidia primus
    and proceeded to test optirun after a reboot. However,
    Code:
    optirun glxgears
    gives me the following error message:
    Code:
    [intel_init_bufmgr:1068] Error initializing buffer manager.
    libGL error: failed to create dri screen
    libGL error: failed to load driver: i965
    I assumed this meant that the driver was not installed, so I installed
    Code:
    i965-va-driver
    . The same error message appeared. Based on the gl version string shown in the output of glxinfo, I believe my system is not utilizing mesa 11. However, I do not know how to rectify this. Two more things: nouveau did not work with my set up after installing and I had to blacklist it via GRUB to get to the desktop. Also, I added i915.preliminary_hw_support=1 to my boot parameters.

    Any help would be much appreciated in getting bumblebee to work with my setup. I am running Kali 2.0 which was installed via a USB. Also, it seems that there is a bug post on this topic.

    Some relevant logs and other things can be found here.

  2. #2
    Join Date
    2016-Jan
    Location
    Russia
    Posts
    6
    Linux-Kernel (even 4.4) doesn't yet support SkyLake

    p.s. If you can do this, you will be a hero
    Last edited by Edelweiss; 2016-01-19 at 21:55.
    Atlas H168 Laptop
    Intel Core i7 6700HQ [SkyLake] [3.5 x 4]
    8 GB RAM 1600 DDR3L
    Nvidia GeForce 940M 2048 GDDR3
    Intel HD530 [SkyLake Graphics]

  3. #3
    Join Date
    2016-Jan
    Posts
    2
    Quote Originally Posted by Edelweiss View Post
    Linux-Kernel (even 4.4) doesn't yet support SkyLake

    p.s. If you can do this, you will be a hero
    So, is it just Kali that doesn't support Skylake, or is it all distros? I had read some things online where people got it to work with Arch and Mint, although looking back it seems that their success was somewhat random. Also, one of the contributors to bumblebee on GitHub told me that Skylake is working with kernel version >=4.3 and mesa 11.

  4. #4
    Join Date
    2016-Jan
    Location
    Russia
    Posts
    6
    Yes, it's problem with all distros. I have Ubuntu 16.04 (beta) and Kernel 4.4.0.999 (Beta) - doesn't work.
    Yes, Kernel 4.3+ support SkyLake, but only the architecture. Still there is a problem with the latest processors (such as 6700HQ).
    Last edited by Edelweiss; 2016-01-20 at 07:41.

  5. #5
    Join Date
    2016-Jan
    Posts
    19
    I have a yoga 900 which has the new i7 in it and my graphics along with many other drivers work great. However it took some modifications. It might be useful to use a kernel config from a different OS. If you want to see how I got all of my stuff working, check out my thread "New Yoga 900 install issues"

Similar Threads

  1. Kali Linux with Intel Skylake graphics doens't boot
    By xpboy7 in forum Installing Archive
    Replies: 3
    Last Post: 2016-01-23, 00:09
  2. intel graphics driver issue?
    By elidd1 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-12-25, 21:24
  3. Replies: 0
    Last Post: 2014-12-06, 06:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •