having latest MM version and downloading the appropriate kali here will work... i don't see why not, it works