Results 1 to 4 of 4

Thread: Problems with apt-get upgrade in kali 2.0

  1. #1
    Join Date

    Angry Problems with apt-get upgrade in kali 2.0

    Hello guys,

    Please i just did a fresh install of Kali 2.0 and am having problems with apt-get upgrade..
    even after the errors i did apt-get update --fix-missing still the same
    please anyone knows how to fix this will really appreciate... am new..thanks

    i get this errors:

    root@kali:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be upgraded:
    fuse libfuse2 webshells
    3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 14.4 kB/220 kB of archives.
    After this operation, 26.6 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    Get:1 sana/main webshells all 1.1-0kali0 [14.4 kB]
    Fetched 14.4 kB in 4s (3,399 B/s)
    E: Failed to fetch Hash Sum mismatch

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

  2. #2
    Join Date
    Are you using the correct repositories? I've just done a fresh install and apt-get upgrade is working just fine for me.

    deb kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src kali-rolling main contrib non-free


  3. #3
    Join Date
    running python rtupdate hooks for python3.5...
    dpkg-query: package 'rhythmbox-plugins' is not installed
    Use dpkg --info (= dpkg-deb --info) to examine archive files,
    and dpkg --contents (= dpkg-deb --contents) to list their contents.
    Traceback (most recent call last):
    File "/usr/bin/py3clean", line 210, in <module>
    File "/usr/bin/py3clean", line 196, in main
    pfiles = set(dpf.from_package(options.package))
    File "/usr/share/python3/debpython/", line 53, in from_package
    raise Exception("cannot get content of %s" % package_name)
    Exception: cannot get content of rhythmbox-plugins
    error running python rtupdate hook rhythmbox-plugins
    dpkg: error processing package python3 (--configure):

  4. #4
    Join Date
    i am reinstall rhythmbox . and it is fine too .and finished install . but when i login in . there is no sound at all

Similar Threads

  1. Upgrade problems
    By PingTimeout in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2023-01-05, 08:33
  2. Problems when tried to upgrade Kali Linux Live USB
    By Vitomir in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2021-01-04, 22:16
  3. Problems with gqrx after upgrade
    By suduma in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-01-29, 14:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts