Results 1 to 4 of 4

Thread: Nethunter 3.0 Nexus 6 PATH and External WiFi Issues

  1. #1
    Join Date
    2016-Jan
    Posts
    3

    Nethunter 3.0 Nexus 6 PATH and External WiFi Issues

    I'm having some issues with Nethunter 3.0.1 on a Nexus 6 running Android Marshmallow in the Kali Terminal. I've got a TPLINK TL-WN722N and an Alfa AWUS036NH that are detected when i check lsusb, but I cannot bring up either using ifconfig (i get an error saying no such device), or are detected when I run iwconfig. Also, for some reason /sbin is not being registered as being in my PATH, even after checking ~/.profile and adding it to the PATH section, however if I add a custom command in Nethunter to export PATH=$PATH:/sbin, it works. I'm not sure why its an issue, but seems like something that shouldn't happen.

    Any help/suggestions?


    Thanks!

    -Geoff

  2. #2
    Join Date
    2016-Jan
    Posts
    3
    here's my dmesg output from disconnecting and reconnecting
    982.141804] platform qcom,smp2pgpio-rdbg-1-out.28: Driver smp2pgpio requests probe deferral
    [ 1021.641688] usb 3-1: USB disconnect, device number 12
    [ 1021.880555] msm-dwc3 f9200000.ssusb: DWC3 in low power mode
    [ 1029.236755] otg_oc_handler: rt_stat = 0x40
    [ 1029.252852] msm-dwc3 f9200000.ssusb: DWC3 exited from low power mode
    [ 1029.275428] msm-dwc3 f9200000.ssusb: DWC3 in low power mode
    [ 1029.517764] msm-dwc3 f9200000.ssusb: DWC3 exited from low power mode
    [ 1029.626399] msm_dwc3_irq: IRQ outside LPM
    [ 1029.745437] usb 3-1: new high-speed USB device number 13 using xhci-hcd
    [ 1029.777062] usb 3-1: New USB device found, idVendor=0cf3, idProduct=9271
    [ 1029.777115] usb 3-1: New USB device strings: Mfr=16, Product=32, SerialNumber=48
    [ 1029.777159] usb 3-1: Product: USB2.0 WLAN
    [ 1029.777199] usb 3-1: Manufacturer: ATHEROS
    [ 1029.777239] usb 3-1: SerialNumber: 12345
    [ 1029.788765] gpiochip_find_base: found new base at 559
    [ 1029.791035] gpiochip_add: registered GPIOs 559 to 590 on device: rdbg
    [ 1029.793531] platform qcom,smp2pgpio-rdbg-1-in.26: Driver smp2pgpio requests probe deferral
    [ 1029.796217] gpiochip_find_base: found new base at 559
    [ 1029.797972] gpiochip_add: registered GPIOs 559 to 590 on device: rdbg
    [ 1029.798580] platform qcom,smp2pgpio-rdbg-1-out.28: Driver smp2pgpio requests probe deferral

  3. #3
    Join Date
    2016-Jan
    Posts
    3
    Anyone have suggestions? if this has been addressed before, I apologize but I have not found a solution and I'd like to use all the features of net hunter. Can someone help me out?

  4. #4
    Join Date
    2015-Nov
    Posts
    24
    Open custom command - Add command -
    label:
    Monitor mode
    command:
    ifconfig wlan1 up && airmon-ng start wlan1
    send to : Kali
    Exec mode : Background
    Leave
    Run at boot -
    Then tap on Update.
    When start run custom command and Monitor mode - tap RUN

Similar Threads

  1. Installed netHunter 3.0 on Nexus 6. External Wifi card not recognized
    By blinear224 in forum NetHunter General Questions
    Replies: 5
    Last Post: 2018-04-05, 14:15
  2. NetHunter 3.0 Nexus 7 2013 (5.1.1) - External Wifi powers off
    By ThatOneDude in forum NetHunter General Questions
    Replies: 0
    Last Post: 2016-04-24, 10:45
  3. Nethunter 1.1.0 on nexus 4 dont detect my external wifi
    By jonathanxx1 in forum NetHunter General Questions
    Replies: 5
    Last Post: 2015-03-29, 16:45

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •