Results 1 to 17 of 17

Thread: Alfa AWUS036H Problem. wierd interface name and error log for monitor mode

  1. #1
    Join Date
    2015-Dec
    Location
    Germany
    Posts
    33

    Alfa AWUS036H Problem. wierd interface name and error log for monitor mode

    Hello fellows!

    I puchased a Alfa AWUS036H. I read very good stuff about it and many people recommended it. First i bought a TPLInk WN722. Works like a charm like out of the box plug & play.

    If i type ifconfig i get this :

    wlx00c0ca82fdfa <---this is my card

    If i try to get it into monitor mode i get :

    ERROR adding monitor mode interface: command failed: Invalid argumen (-22 ).
    Possible to change the name or is it maybe a drive rproblem ? i didnt use the install CD


    EDIT: if i kill NetworkManager i wont be able to see the card in ifconfig. If i start it again i can see.
    Last edited by HaraldGer123; 2016-01-27 at 11:40.

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    784
    What's in the output of dmesg when you plug in the Alfa? Anything strange there, or in /var/log?

    I have the same model card, and I get it into monitor mode successfully as follows:
    airmon-ng check kill (to kill interfering processes)
    airmon-ng start wlan1

  3. #3
    Join Date
    2015-Dec
    Location
    Germany
    Posts
    33
    i got this

    Code:
    [  932.562703] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
    [  932.563153] ieee80211 phy1: hwaddr 00:c0:ca:82:fd:fa, RTL8187vB (default) V1 + rtl8225z2, rfkill mask 2
    [  932.572467] rtl8187: Customer ID is 0xFF
    [  932.572987] rtl8187: wireless switch is on
    [  932.581532] rtl8187 1-2:1.0 wlx00c0ca82fdfa: renamed from wlan0
    [  932.613939] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca82fdfa: link is not ready
    [  934.470345] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca82fdfa: link is not ready
    [  934.521143] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca82fdfa: link is not ready
    [  936.266298] wlx00c0ca82fdfa: authenticate with 00:1b:2f:f5:7a:80
    [  936.446748] wlx00c0ca82fdfa: direct probe to 00:1b:2f:f5:7a:80 (try 1/3)
    [  936.649375] wlx00c0ca82fdfa: send auth to 00:1b:2f:f5:7a:80 (try 2/3)
    [  936.652138] wlx00c0ca82fdfa: authenticated
    [  936.652482] rtl8187 1-2:1.0 wlx00c0ca82fdfa: disabling HT/VHT due to WEP/TKIP use
    [  936.652491] rtl8187 1-2:1.0 wlx00c0ca82fdfa: disabling HT as WMM/QoS is not supported by the AP
    [  936.652495] rtl8187 1-2:1.0 wlx00c0ca82fdfa: disabling VHT as WMM/QoS is not supported by the AP
    [  936.653606] wlx00c0ca82fdfa: associate with 00:1b:2f:f5:7a:80 (try 1/3)
    [  936.656347] wlx00c0ca82fdfa: RX AssocResp from 00:1b:2f:f5:7a:80 (capab=0x431 status=0 aid=4)
    [  936.656971] wlx00c0ca82fdfa: associated
    [  936.657033] IPv6: ADDRCONF(NETDEV_CHANGE): wlx00c0ca82fdfa: link becomes ready
    

  4. #4
    Join Date
    2015-Dec
    Location
    Germany
    Posts
    33
    airmon-ng output

    If i kill Networkmanager i also cannot see the wlan stick in ifconfig.
    If i activate Networkmanager again, and try monitor ( obviously ) i got problems, like ERROR adding monitor mode interface: command failed: Invalid argument (-22)

    Code:
    Code:
    root@kali:~# NetworkManager 
    root@kali:~# airmon-ng start wlx00c0ca82fdfa
    
    Found 3 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    
      PID Name
     2728 NetworkManager
     2732 wpa_supplicant
     2734 dhclient
    
    PHY	Interface	Driver		Chipset
    
    phy0	wlx00c0ca82fdfa	rtl8187		Realtek Semiconductor Corp. RTL8187
    
    
    ERROR adding monitor mode interface: command failed: Invalid argument (-22)
    root@kali:~#
    Code:
    root@kali:~# airmon-ng check kill
    
    Killing these processes:
    
      PID Name
     1351 wpa_supplicant
    
    root@kali:~# kill 1351
    bash: kill: (1351) - No such process
    root@kali:~# airmon-ng
    
    PHY	Interface	Driver		Chipset
    
    phy0	wlx00c0ca82fdfa	rtl8187		Realtek Semiconductor Corp. RTL8187
    
    root@kali:~# airmon-ng start wlx00c0c0ca82fdfa
    
    
    PHY	Interface	Driver		Chipset
    
    phy0	wlx00c0ca82fdfa	rtl8187		Realtek Semiconductor Corp. RTL8187
    
    root@kali:~#
    x

    I can connect to my home WLAN. So why is the name so strange? This is my second card, i used first TPLink722n, and if i plug this one in, everything works fine, interface name is wlan0 etc. so how it should be.

    After plug in

    Code:
     1913.351192] r8169 0000:09:00.0 eth0: link down
    [ 1947.646271] usb 1-2: USB disconnect, device number 9
    [ 1948.734660] usb 1-2: new high-speed USB device number 10 using xhci_hcd
    [ 1948.869076] usb 1-2: New USB device found, idVendor=0bda, idProduct=8187
    [ 1948.869082] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 1948.869086] usb 1-2: Product: RTL8187_Wireless
    [ 1948.869090] usb 1-2: Manufacturer: Manufacturer_Realtek_RTL8187_
    [ 1948.869092] usb 1-2: SerialNumber: 00C0CA82FDFA
    [ 1948.984424] ieee80211 phy3: Selected rate control algorithm 'minstrel_ht'
    [ 1948.984834] ieee80211 phy3: hwaddr 00:c0:ca:82:fd:fa, RTL8187vB (default) V1 + rtl8225z2, rfkill mask 2
    [ 1948.993693] rtl8187: Customer ID is 0xFF
    [ 1948.994093] rtl8187: wireless switch is on
    [ 1948.999417] rtl8187 1-2:1.0 wlx00c0ca82fdfa: renamed from wlan0
    [ 1949.028958] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca82fdfa: link is not ready
    [ 1950.859188] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca82fdfa: link is not ready
    [ 1950.908624] IPv6: ADDRCONF(NETDEV_UP): wlx00c0ca82fdfa: link is not ready
    Last edited by HaraldGer123; 2016-01-27 at 17:13.

  5. #5
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    784
    That is really odd. The card's name seems to match its MAC address...haven't seen that before.

  6. #6
    Join Date
    2015-Dec
    Location
    Germany
    Posts
    33
    Yes its the MAC Adress... im clueless, is there possible to delete everything about and try "new" plug and play

  7. #7
    Join Date
    2015-Dec
    Location
    Germany
    Posts
    33
    Problem solved

    i added the entry in etc/udev

    # USB device ALFA-AWUS036H 0x0bda:0x8187 (rtl8187)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:c0:ca:82:fd:fa", ATTR{type}=="1", NAME="wlan1"



    after this i was able to monitor "wlan1" otherwise with that strange adress iam no be able to take it into monitor

  8. #8
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    784
    Glad you got it fixed I guess the device wasn't properly defined for some reason.

  9. #9
    Join Date
    2016-Mar
    Posts
    1
    Hello, i have same problem, and i have follow ur solution that add entry at etc/udav.conf with my own hwaddr but still cannot change to wlan1.. please help me..

  10. #10
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    784
    asran90, do you have the same model wi-fi card? If not, this solution may not work.

  11. #11
    Join Date
    2016-May
    Posts
    4
    I'm having a similar issue and would appreciate the help on exactly what I would have to type into terminal to define my usb network adapter. This is the exact message I get after running the command 'sudo airmon-ng check kill' and then attempting to enable my adapter into monitor mode

    sudo airmon-ng start wlx9cefd5ff4e37

    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!

    PID Name
    7035 avahi-daemon
    7036 avahi-daemon

    PHY Interface Driver Chipset

    phy0 wlp2s0 ath9k Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
    phy1 wlx9cefd5ff4e37 rt2800usb Ralink Technology, Corp. RT5372


    ERROR adding monitor mode interface: command failed: Invalid argument (-22)

    Something else I'd like to add in case someone tells me to kill the additional processes is that even after killing them, 2 new processes get added to the error message each and every time.

  12. #12
    Join Date
    2016-May
    Posts
    1
    Hello all , i've same problem , but i've find a solution !
    check in "
    Code:
    /lib/udev/rules.d
    "
    i have i file named 73-special-net-names.rules , edit this :

    # Use MAC based names for network interfaces which are directly or indirectly
    # on USB and have an universally administered (stable) MAC address (second bit
    # is 0).
    ACTION=="add", SUBSYSTEM=="net", SUBSYSTEMS=="usb", NAME=="", ATTR{address}=="?[014589cd]:*", IMPORT{builtin}#="net_id", NAME="$env{ID_NET_NAME_MAC}"
    just comment the line with the # like this :

    # Use MAC based names for network interfaces which are directly or indirectly
    # on USB and have an universally administered (stable) MAC address (second bit
    # is 0).
    #ACTION=="add", SUBSYSTEM=="net", SUBSYSTEMS=="usb", NAME=="", ATTR{address}=="?[014589cd]:*", IMPORT{builtin}#="net_id", NAME="$env{ID_NET_NAME_MAC}"
    Unplug and Plug your wireless card , problem solved .

    Enjoy

    Sorry but .. you've been know , i'm not english

    Bye bye ^^
    Last edited by KonarGoL23; 2016-05-20 at 15:15.

  13. #13
    Join Date
    2016-May
    Posts
    4
    I checked both directories listed above for any .rules files, but only found some in the /lib/udev/rules.d. The problem is that the file listed above as well as others that were suggested for editing this information were no where to be found so I created a .rules file and typed the corresponding information for my USB network adapter.

    # USB Device PANDA-PAU06 0x148f:0x5372 (rt5372)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="9c:ef:d5:ff:4e:37", ATTR{type}=="1", NAME="wlan1"

    When I used ifconfig in terminal it did show that there was a name change and using airmon I was able to enable monitor mode on the network adapter, but when doing the basic packet injection test I did not have successful results. The command wash -i wlan1mon also did not work.
    What exactly did I wrong and how can I get this usb network adapter working like my built in one.

  14. #14
    Join Date
    2016-May
    Posts
    4
    I've been researching and still haven't found a solution. The usb network adapter I'm using is one of the most popular ones sold and is compatible with promiscuous mode, which is one of the reasons I got it. I'm running all of this on Ubuntu not Kali. Does anyone know what I would have to further add to get this thing to work properly?

  15. #15
    Join Date
    2016-Jan
    Posts
    99
    Quote Originally Posted by BNBkali View Post
    # USB Device PANDA-PAU06 0x148f:0x5372 (rt5372)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="9c:ef:d5:ff:4e:37", ATTR{type}=="1", NAME="wlan1"

    When I used ifconfig in terminal it did show that there was a name change and using airmon I was able to enable monitor mode on the network adapter, but when doing the basic packet injection test I did not have successful results. The command wash -i wlan1mon also did not work.
    What exactly did I wrong and how can I get this usb network adapter working like my built in one.
    well.. Panda wireless is not exactly AWUS036H

  16. #16
    Join Date
    2016-May
    Posts
    4
    Different adapter with the exact same issue as the OP. I obviously replaced all of the information to fit my needs and found some success, but still not what it should be.

  17. #17
    Join Date
    2016-May
    Posts
    5
    This is definicely an issue that I've seen on many forums with Kali 2016.1. This needs to be addressed by the Kali devs since the best suggestion for a usb adapter isn't working with this new rolling release! It worked on previous versions!
    I have the AWUS036NH with the EXACT same issue with no solution. This is beyond frustrating.
    I even tried to post a question about it but it was removed because I broke a rule and the forum gods frowned upon me.

Similar Threads

  1. Replies: 2
    Last Post: 2015-09-09, 20:10
  2. Can't get alfa awus036h in monitor mode
    By rafltdcpa in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-11-05, 23:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •