Results 1 to 4 of 4

Thread: Problems with gqrx after upgrade

  1. #1
    Join Date
    2015-Jul
    Posts
    7

    Unhappy Problems with gqrx after upgrade

    Im trying to run gqrx after changing over the repos to Kali rolling and performing dist-upgrade and removing pybombs im still having issues which im hoping a kali or linux guru will be able to help me get this figured out.

    Code:
    # gqrx
    gqrx: error while loading shared libraries: libicuuc.so.48: cannot open shared object file: No such file or directory
    So I search for the missing file

    Code:
    # find -name '*libicuuc.so*'
    ./opt/google/earth/free/libicuuc.so.50
    find: ‘./proc/24533’: No such file or directory
    ./usr/lib/i386-linux-gnu/libicuuc.so.55.1
    ./usr/lib/i386-linux-gnu/libicuuc.so.55
    ./usr/lib/4kstogram/libicuuc.so.54
    ./usr/lib/x86_64-linux-gnu/libicuuc.so.55.1
    ./usr/lib/x86_64-linux-gnu/libicuuc.so.52
    ./usr/lib/x86_64-linux-gnu/libicuuc.so
    ./usr/lib/x86_64-linux-gnu/libicuuc.so.55
    ./usr/lib/x86_64-linux-gnu/libicuuc.so.52.1
    Hmm no .48 to be found anywhere.. starting to think it was either compiled against the wrong version or something on my system is messed up.. prob the latter

    Similiar error in gnuradio with dsd

    Code:
    Traceback (most recent call last):
      File "/root/dsd_grc.py", line 33, in <module>
        import osmosdr
      File "/usr/local/src/lib/python2.7/dist-packages/osmosdr/__init__.py", line 26, in <module>
        from osmosdr_swig import *
      File "/usr/local/src/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py", line 26, in <module>
        _osmosdr_swig = swig_import_helper()
      File "/usr/local/src/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py", line 22, in swig_import_helper
        _mod = imp.load_module('_osmosdr_swig', fp, pathname, description)
    ImportError: libicuuc.so.48: cannot open shared object file: No such file or directory
    What gets interesting is when I run the following

    Code:
    # dpkg -L gr-osmosdr
    /.
    /usr
    /usr/bin
    /usr/bin/osmocom_fft
    /usr/bin/osmocom_spectrum_sense
    /usr/bin/osmocom_siggen_nogui
    /usr/bin/osmocom_siggen
    /usr/include
    /usr/include/osmosdr
    /usr/include/osmosdr/time_spec.h
    /usr/include/osmosdr/ranges.h
    /usr/include/osmosdr/api.h
    /usr/include/osmosdr/pimpl.h
    /usr/include/osmosdr/swig
    /usr/include/osmosdr/swig/osmosdr_swig_doc.i
    /usr/include/osmosdr/swig/osmosdr_swig.i
    /usr/include/osmosdr/sink.h
    /usr/include/osmosdr/device.h
    /usr/include/osmosdr/source.h
    /usr/lib
    /usr/lib/x86_64-linux-gnu
    /usr/lib/x86_64-linux-gnu/pkgconfig
    /usr/lib/x86_64-linux-gnu/pkgconfig/gnuradio-osmosdr.pc
    /usr/lib/python2.7
    /usr/lib/python2.7/dist-packages
    /usr/lib/python2.7/dist-packages/osmosdr
    /usr/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py
    /usr/lib/python2.7/dist-packages/osmosdr/_osmosdr_swig.so
    /usr/lib/python2.7/dist-packages/osmosdr/osmocom_siggen_base.py
    /usr/lib/python2.7/dist-packages/osmosdr/__init__.py
    /usr/share
    /usr/share/gnuradio
    /usr/share/gnuradio/grc
    /usr/share/gnuradio/grc/blocks
    /usr/share/gnuradio/grc/blocks/osmosdr_sink.xml
    /usr/share/gnuradio/grc/blocks/rtlsdr_source.xml
    /usr/share/gnuradio/grc/blocks/osmosdr_source.xml
    /usr/share/doc
    /usr/share/doc/gr-osmosdr
    /usr/share/doc/gr-osmosdr/changelog.Debian.gz
    /usr/share/doc/gr-osmosdr/copyright
    /usr/share/man
    /usr/share/man/man1
    /usr/share/man/man1/osmocom_siggen_nogui.1.gz
    /usr/share/man/man1/osmocom_fft.1.gz
    /usr/share/man/man1/osmocom_siggen.1.gz
    /usr/share/man/man1/osmocom_spectrum_sense.1.gz
    /usr/lib/x86_64-linux-gnu/libgnuradio-osmosdr.so
    So im getting an error from the kali repo installed gqrx and gnuradio from something I or pybombs must have changed.

    Posting my env im pretty sure thats where the problem is but im no longer 100% what needs to be in the environment or what doesn't anymore.

    Code:
    # env
    XDG_VTNR=2
    SSH_AGENT_PID=4924
    XDG_SESSION_ID=3
    TERM=xterm-256color
    SHELL=/bin/bash
    XDG_MENU_PREFIX=gnome-
    VTE_VERSION=4201
    XDG_SESSION_COOKIE=9a24d0a4a7785ee396a3c2b3551ec498-1453954680.183328-1566678185
    QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
    GJS_DEBUG_OUTPUT=stderr
    WINDOWID=33574680
    GJS_DEBUG_TOPICS=JS ERROR;JS LOG
    GTK_MODULES=gail:atk-bridge
    USER=root
    LD_LIBRARY_PATH=/usr/local/src/lib/:/usr/local/src/lib64/:
    LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
    QT_ACCESSIBILITY=1
    SSH_AUTH_SOCK=/run/user/0/keyring/ssh
    SESSION_MANAGER=local/zifnMObo:@/tmp/.ICE-unix/4866,unix/zifnMObo:/tmp/.ICE-unix/4866
    USERNAME=root
    PATH=/usr/local/src/bin/:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/lib64/qt4/bin/
    DESKTOP_SESSION=default
    XDG_SESSION_TYPE=x11
    PWD=/root
    LANG=en_US.UTF-8
    GDM_LANG=en_US.UTF-8
    GDMSESSION=default
    SHLVL=1
    XDG_SEAT=seat0
    HOME=/root
    GNOME_DESKTOP_SESSION_ID=this-is-deprecated
    PYTHONPATH=/usr/local/src/python/:/usr/local/src/lib/python2.6/site-packages/:/usr/local/src/lib64/python2.6/site-packages/:/usr/local/src/lib/python2.6/dist-packages/:/usr/local/src/lib64/python2.6/dist-packages/:/usr/local/src/lib/python2.7/site-packages/:/usr/local/src/lib64/python2.7/site-packages/:/usr/local/src/lib/python2.7/dist-packages/:/usr/local/src/lib64/python2.7/dist-packages/:/usr/local/src/python/:/usr/local/src/lib/python2.6/site-packages/:/usr/local/src/lib64/python2.6/site-packages/:/usr/local/src/lib/python2.6/dist-packages/:/usr/local/src/lib64/python2.6/dist-packages/:/usr/local/src/lib/python2.7/site-packages/:/usr/local/src/lib64/python2.7/site-packages/:/usr/local/src/lib/python2.7/dist-packages/:/usr/local/src/lib64/python2.7/dist-packages/
    XDG_SESSION_DESKTOP=default
    LOGNAME=root
    XDG_DATA_DIRS=/usr/share/gnome:/usr/local/share/:/usr/share/
    DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/0/bus
    PKG_CONFIG_PATH=/usr/local/src/lib/pkgconfig/:/usr/local/src/lib64/pkgconfig/:
    WINDOWPATH=2
    XDG_RUNTIME_DIR=/run/user/0
    DISPLAY=:0
    XDG_CURRENT_DESKTOP=GNOME
    XAUTHORITY=/run/user/0/gdm/Xauthority
    _=/usr/bin/env
    Some questions that I had about Kali that may help in troubleshooting are the following:

    Does Kali point to python in the src dir by default?

    Is the LD_Library_Path an environmental variable by default and does it also point to src?

    Is it just old versions of the software that needs to be updated and nothing wrong with my system?

    I thank you in advance for any replies or suggestions!

  2. #2
    Join Date
    2016-Jan
    Posts
    14
    I can't replicate your problem with an updated fresh install.

    Code:
    root@kali:~# ldd /usr/bin/gqrx | grep libicuuc
    	libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007f0a585eb000)
    Code:
    root@kali:~# apt-cache show gqrx
    Package: gqrx
    Source: gqrx (2.3.0-0kali3)
    Version: 2.3.0-0kali3+b2
    Architecture: amd64
    Maintainer: Devon Kearns <dookie@kali.org>
    Installed-Size: 1397
    Depends: gnuradio, gr-osmosdr, hackrf, rtl-sdr, uhd-host, uhd-images, libboost-program-options1.58.0, libboost-system1.58.0, libc6 (>= 2.14), libgcc1 (>= 1:4.0), libgnuradio-analog3.7.9, libgnuradio-blocks3.7.9, libgnuradio-fft3.7.9, libgnuradio-filter3.7.9, libgnuradio-osmosdr0.1.4, libgnuradio-pmt3.7.9, libgnuradio-runtime3.7.9, libpulse0 (>= 0.99.1), libqt4-network (>= 4:4.5.3), libqt4-svg (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.1), libstdc++6 (>= 5.2), libvolk1.1
    Homepage: http://gqrx.dk/
    Priority: extra
    Section: comm
    Filename: pool/main/g/gqrx/gqrx_2.3.0-0kali3+b2_amd64.deb
    Size: 431210
    SHA256: 11f22233f3f81508ba6b587f266668c8be6cd277c33bb5eb8c2bd04973673cab
    SHA1: 2ae644dc4dbfb2f07e932b66406d92bfbe602f22
    MD5sum: 23a61afc8e57d3ae051ff0482ed2ab92

  3. #3
    Join Date
    2015-Jul
    Posts
    7
    Quote Originally Posted by Fuzzer View Post
    I can't replicate your problem with an updated fresh install.

    Code:
    root@kali:~# ldd /usr/bin/gqrx | grep libicuuc
    	libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007f0a585eb000)
    Code:
    root@kali:~# apt-cache show gqrx
    Package: gqrx
    Source: gqrx (2.3.0-0kali3)
    Version: 2.3.0-0kali3+b2
    Architecture: amd64
    Maintainer: Devon Kearns <dookie@kali.org>
    Installed-Size: 1397
    Depends: gnuradio, gr-osmosdr, hackrf, rtl-sdr, uhd-host, uhd-images, libboost-program-options1.58.0, libboost-system1.58.0, libc6 (>= 2.14), libgcc1 (>= 1:4.0), libgnuradio-analog3.7.9, libgnuradio-blocks3.7.9, libgnuradio-fft3.7.9, libgnuradio-filter3.7.9, libgnuradio-osmosdr0.1.4, libgnuradio-pmt3.7.9, libgnuradio-runtime3.7.9, libpulse0 (>= 0.99.1), libqt4-network (>= 4:4.5.3), libqt4-svg (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.1), libstdc++6 (>= 5.2), libvolk1.1
    Homepage: http://gqrx.dk/
    Priority: extra
    Section: comm
    Filename: pool/main/g/gqrx/gqrx_2.3.0-0kali3+b2_amd64.deb
    Size: 431210
    SHA256: 11f22233f3f81508ba6b587f266668c8be6cd277c33bb5eb8c2bd04973673cab
    SHA1: 2ae644dc4dbfb2f07e932b66406d92bfbe602f22
    MD5sum: 23a61afc8e57d3ae051ff0482ed2ab92
    Thanks for the reply helps a lot ill keep troubleshooting at first thought it was my environment now im starting to think theres some other link to an older gqrx

    Code:
    # ldd /usr/bin/gqrx | grep libicuuc
    	libicuuc.so.48 => not found
    Thanks again!
    Last edited by suduma; 2016-01-29 at 01:34. Reason: Add ldd output remove env request add thanks

  4. #4
    Join Date
    2016-Jan
    Posts
    14
    Check the package version. Is it identical to my output?

Similar Threads

  1. Telive Tetra GQRX
    By wabbit in forum General Archive
    Replies: 0
    Last Post: 2016-09-26, 15:30
  2. Problems with apt-get upgrade in kali 2.0
    By ab0kixxl in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-01-26, 08:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •