Results 1 to 3 of 3

Thread: WiFi cannot find networks after stopping monitor mode

  1. #1

    WiFi cannot find networks after stopping monitor mode

    I'm a bit of a noob here but I am trying to figure this out.
    I'm using Kali 2.0 on amd-64 and I'm using it live from a USB with persistence.

    When I start Kali I can easily browse the internet by selecting my home network from the list of available networks, putting in the password and everything is good. After I start up airmon-ng on my interface (wlan0) everything works as it should and I am able to do everything I need. When I try to stop monitor mode it seems my interface name rolls to wlan1 and the hardware address seems to move up 1 number as well (60:36:dd:47:fa:81 => 60:36:dd:47:fa:82). I tried restarting the NetworkManager service but when I go to see the list of available wifi networks it says "No network found." I tried another step which was to disable the network interface by using ifconfig wlan0 down and then back up but it says it cannot find the interface and I try to use wlan1 and nothing happens. I checked and I am 100% certain that wlan1 is in managed mode, not monitor mode. If I reboot everything works well again and I can get to the internet, it's just annoying that if I am trying something in monitor mode and then I am doing something wrong I can't just stop monitor mode and connect back to the internet to troubleshoot my issue.

  2. #2
    Join Date
    2016-Jan
    Location
    Netherlands
    Posts
    7
    Hey there macmachine87

    Try use this command:"service start networkmanager'

  3. #3
    Join Date
    2013-Jul
    Posts
    844
    Unfortunately using airmon-ng check kill:

    1. Does not tell you what linux commands you are using as airmon-ng is a bash script evoking linux commands on your Operating System.

    2. No method was offered to restore the processes stopped thru airmon-ng.

    3. To find the actual commands you have to open the airmon-ng script and find the commands in the lines of code.

    4. And when you actually try and restore these functions, a full restoration of all wifi functions does not occur.

    Go to this thread.

    https://forums.kali.org/showthread.p...NetworkManager


    MTeams
    Last edited by mmusket33; 2016-02-01 at 12:36.

Similar Threads

  1. pci-Wifi unable to find networks after update
    By elidd1 in forum General Archive
    Replies: 1
    Last Post: 2016-12-16, 13:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •