Results 1 to 8 of 8

Thread: New to kali and rtl8188cus problems

  1. #1
    Join Date
    2016-Feb
    Posts
    1

    New to kali and rtl8188cus problems

    Hi,

    I wanted to give kali a try bought a new sd card, put the image on the sd and tryed some tutorials and everytime problems over problems

    First of all
    Airmon-ng says:
    Null enx0013ef74022e ????? Realtek Semiconductor Corp.. RTL8122CUS 802.11n WLAN Adapter

    It is renamed from wlan0 to enx...
    Hmmm makes it more complicated to type sth but ok... But driver???

    Lsmod output says:

    8192cu used by 0...

    What can i do here to get it work?

    By the way... /etc/udev/rules.d/ is empty??

    I wanted to rename it back to wlan0...cause enxblabla is just a littlebit toooo long to work with.

    Greetz cs

  2. #2
    Join Date
    2015-Aug
    Posts
    8
    I am essentially experiencing the same thing here with my TP-Link TL-WN722N (AR9271 ) on my Pi 1 / Kali 2.1 box.
    root@kali:/lib/udev/rules.d# airmon-ng start wlx14cc20188e90


    PHY Interface Driver Chipset

    phy0 wlx14cc20188e90 ath9k_htc Atheros Communications, Inc. AR9271 802.11n


    ERROR adding monitor mode interface: command failed: Invalid argument (-22)

  3. #3
    Join Date
    2016-Feb
    Location
    Alaska
    Posts
    2
    I am having the exact same issue using the RTL8122CUS.

    I tried to update the firmware but no joy.

  4. #4
    Join Date
    2013-Jul
    Posts
    41
    I too am having exact same issue, with enabling monitor mode and extra long Wifi device name.

    Their seems to be multiple threads with others experiencing the same .

    These threads address the issue, Haven't had time to go through them. Let me know if they work for you.

    http://raspberrypi.stackexchange.com...ifi-usb-dongle


    http://raspberrypi.stackexchange.com...sb-on-raspbian - This thread states the kernel needs reconfigured, then recompiled. If we were to use said kernel in Kali, would that cause any issues?

    I have 4 USB Wi-Fi adapters , all Realtek chip set based , needless to say I need a workaround.
    Last edited by hightech316; 2016-03-08 at 17:52.

  5. #5
    Join Date
    2016-Mar
    Posts
    2
    Did you find a fix for it yet?
    Having the exact same problem with the wn722n

  6. #6
    Join Date
    2015-May
    Posts
    9
    I'm facing the exact same problem on my RPi Zero.
    I'm using a TL-WN722N and a Edimax EW-7811Un.
    The TL-WN722N is supposed to connect me to internet or be used with wifite and the the EW-7811Un to prvide me remote access to my RPi.

    Code:
    dmesg | grep enx74da3865e7b6
    and
    Code:
    dmesg | grep wlxc04a00087c3a
    show:

    [ 18.347502] rtl8192cu 1-1.2:1.0 enx74da3865e7b6: renamed from wlan0
    [ 22.322180] ath9k_htc 1-1.1:1.0 wlxc04a00087c3a: renamed from wlan0

    On wifite I get "null" for my Edimax.

    Code:
    lsmod | grep rtl8192cu
    shows nothing.

    Code:
    modprobe rtl8192cu
    gives:

    Code:
    modprobe: FATAL: Module rtl8192cu not found in directory /lib/modules/4.1.19+
    TL-WN722N works fine btw.

    Code:
    lshw -C network
      *-usb:0
           description: Wireless interface
           product: USB2.0 WLAN
           vendor: ATHEROS
           physical id: 1
           bus info: usb@1:1.1
           logical name: wlxc04a00087c3a
           version: 1.08
           serial: 12345
           capabilities: usb-2.00 ethernet physical wireless
           configuration: broadcast=yes driver=ath9k_htc driverversion=4.1.19+ firmware=1.3 ip=192.168.0.103 link=yes maxpower=500mA multicast=yes speed=480Mbit/s wireless=IEEE 802.11bgn
      *-usb:1 DISABLED
           description: Wireless interface
           product: 802.11n WLAN Adapter
           vendor: Realtek
           physical id: 2
           bus info: usb@1:1.2
           logical name: enx74da3865e7b6
           version: 2.00
           serial: 00e04c000001
           capabilities: usb-2.00 ethernet physical wireless
           configuration: broadcast=yes driver=rtl8192cu maxpower=500mA multicast=yes speed=480Mbit/s wireless=unassociated
    My Edimax usb:1 DISABLED !!! Which I've enabled it with
    Code:
    ifconfig enx74da3865e7b6 up
    Last edited by bahador_b_92; 2016-03-13 at 16:07.

  7. #7
    Join Date
    2015-May
    Posts
    9
    I just noticed that based on https://wikidevi.com/wiki/Edimax_EW-7811Un the driver that should be used is rtl8192cu. However it seems that kernel uses 8192cu driver. I'm going to mess with driver updating and blacklisting and I will post the results here.

  8. #8
    Join Date
    2015-May
    Posts
    9
    Okay, I found a tutorial on how to do the driver thing on http://askubuntu.com/questions/24623...l8192cu-driver but the problem is I didn't find the linux headers for my 4.1.19+ armel kernel to even start updating the driver... End of stroy...

Similar Threads

  1. kali VPN problems
    By kaliconn4 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-12-06, 03:41
  2. Replies: 5
    Last Post: 2016-03-07, 19:35
  3. Replies: 5
    Last Post: 2015-06-30, 06:58
  4. Replies: 1
    Last Post: 2015-06-28, 20:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •