Results 1 to 3 of 3

Thread: Nethunter 3.0 - TWRP loading removing operating system - Nexus 7 - 6.0.1

  1. #1
    Join Date
    2015-Sep
    Posts
    8

    Nethunter 3.0 - TWRP loading removing operating system - Nexus 7 - 6.0.1

    Edit: This should really be in the Installing Nethunter fourm, could an admin please move it. Many thanks.

    I was wondering if anyone could anyone could point out where i'm going wrong with my new Kali Nethunter 3.0 install.

    I start of by installing a fresh ROM on Marshmallow 6.0.1 from Google:
    >fastboot erase boot
    >fastboot erase cache
    >fastboot erase recovery
    >fastboot erase system
    >fastboot erase userdata
    >fastboot oem unlock
    >fastboot flash bootloader bootloader.img
    >fastboot reboot-bootloader
    >fastboot flash recovery recovery.img
    >fastboot flash boot boot.img
    >fastboot flash system system.img
    >fastboot flash cache cache.img
    >fastboot flash userdata userdata.img
    >fastboot reboot

    I let the device load up and it boots up, i put in my email and set up the device, enable MTP, USB debugging, drag the Nethunter install into the device. Then i reboot into bootloader and flash the latest TWRP recovery image.

    > adb reboot-bootloader
    > fastboot flash recovery twrp-2.8.7.0-flo.img

    Then i root the device (I use auto chainfire, but i have also tried the Nexus Root Toolkit). It boots up and I test it with an app from the store. Root is working.

    I boot back into bootloader and choose recovery. TWRP loads.... and instantly wipes the entire device. I press install to look and it says there is no system space left, my nethunter file that i previously dragged in isn't in there. I select reboot from the menu and it says that there is no OS installed. I boot back into bootloader and try again. Repeated 5 times now, can anybody help?
    Last edited by Greenwolf; 2016-02-05 at 02:42.

  2. #2
    Join Date
    2015-Sep
    Posts
    8
    Ok little update, it seems that its not actually wiping the entire device, the problem is that TWRP is pointing at a still used multi rom, even though the multirom has been deleted, it is still taking up around half of the storage on the device.

    So now i need to figure out how to delete this ghost partition on the nexus 7 and figure out how to get TWRP to point to the normal installation.

  3. #3
    Join Date
    2015-Sep
    Posts
    8
    Fix: Reinstalled Multirom, it booted me into custom TWRP and I could access the Nethunter zip from there, looks like its installed although it got stuck on 90% checking for kali chroot and i had to hard restart the device. It booted up however and seems to be working.

Similar Threads

  1. Replies: 5
    Last Post: 2016-05-10, 17:37
  2. Intall NetHunter on Nexus 6 - which TWRP image
    By adlercm1 in forum Installing NetHunter
    Replies: 7
    Last Post: 2015-05-16, 17:42
  3. Operating system missing
    By jefti in forum Installing Archive
    Replies: 0
    Last Post: 2014-10-16, 21:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •