Results 1 to 1 of 1

Thread: Can't Install D-Link DWA-182 Driver

  1. #1
    Join Date
    2016-Feb
    Posts
    1

    Question Can't Install D-Link DWA-182 Driver

    Greetings.

    I'm fairly new to linux and having some trouble getting my wireless to work.
    It is a D-link DWA-182 ver. C1 Dongle.

    Im on the newest rolling release of Kali having just installed two days ago and have done apt-get update, apt-get upgrade and apt-get dist-upgrade, none of which were needed as 0 packages were installed.

    uname -a gives me:

    Linux Helix 4.3.0-kali1-amd64 #1 SMP Debian 4.3.3-5kali4 (2016-01-13) x86_64 GNU/Linux
    The adapter shows up in lsusb as:

    Bus 001 Device 009: ID 2001:3315 D-Link Corp.
    dmesg gives me:

    [79621.881815] usb 1-1.3: Product: D-Link Wireless Adapter
    [79621.881817] usb 1-1.3: Manufacturer: Realtek
    [79621.881819] usb 1-1.3: SerialNumber: 123456
    [81846.418960] usb 1-1.4: new high-speed USB device number 10 using ehci-pci
    [81846.513753] usb 1-1.4: New USB device found, idVendor=04e8, idProduct=6860
    [81846.513758] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    I have downloaded the drivers from the D-link website and unzipped to folder with this name:
    "RTL8812AU_linux_v4.3.2_11100.20140411"

    There is an install.sh script in it that i have run. it successfully decompresses the tar ball, does a make clean then tries to run the make command, which results in this error:

    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.3.0-kali1-amd64/build M=/root/.local/share/Trash/files/RTL8812AU_linux_v4.3.2_11100.20140411/driver/rtl8812AU_linux_v4.3.2_11100.20140411 modules
    make[1]: *** /lib/modules/4.3.0-kali1-amd64/build: No such file or directory. Stop.
    Makefile:1350: recipe for target 'modules' failed
    make: *** [modules] Error 2
    ##################################################
    Compile make driver error: 2
    Please check error Mesg
    ##################################################
    I've also tried extracting and the make install manually instead of the script but it gives me the same error.

    So I went to /lib/modules and there are 5 folders all with names like "3.19.0-30-generic".

    Im guessing there should be another directory here called "4.3.0-kali1-amd64", but not sure.

    Any help would be appreciated!

    Thanks
    Last edited by Helixir; 2016-02-09 at 10:14.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •