Results 1 to 7 of 7

Thread: teamviewer cannot autostart

  1. #1
    Join Date
    2016-Feb
    Posts
    4

    Unhappy teamviewer cannot autostart

    * Introduction:
    I want to use teamviewer 11 to remotely control my PC, even after rebooting.
    However, if I reboot computer, teamviewer cannot autostart before/after logging in (root).

    * Necessary details:
    Kali version: Rolling edition 2016.01, x86_64
    Kali installation: HDD
    Teamviewer 11

    Solutions tried and their result
    1.
    I set "Start TeamViewer with system" in teamviewer GUI.
    => doesn't work

    1+2.
    cp /opt/teamviewer/tv_bin/script/teamviewerd.sysv /etc/init.d
    chmod 755 /etc/init.d/teamviewerd.sysv
    update-rc.d teamviewerd.sysv defaults => no any output
    => above all doesn't work

    1+2+3.
    add "/opt/teamviewer/tv_bin/script/teamviewer &" into /etc/rc.local before "exit 0"
    => doesn't work

    1+2+3+4.
    add "teamviewer enabled" to the end of /usr/sbin/update-rc.d within the whitelist
    => doesn't work


    Please help me, your idea will be greatly appreciated

  2. #2
    Join Date
    2015-Jul
    Location
    /home/duxim
    Posts
    408
    if you are using xfce (light version of Kali) go to
    application-->setting-->session & startup
    open tab Application start up, click Add and fill fields
    Repetitio est mater studiorum

  3. #3
    Join Date
    2016-Feb
    Posts
    4
    Sorry, I am not using the light version.

  4. #4
    Join Date
    2016-Jan
    Location
    Ukraine
    Posts
    11
    try this:

    Applications menu -> System Tools -> Preferences -> Startup Applications and then click the add button and write in command area such as service ssh start
    Alis volat propriis = she flies with her own wings.

  5. #5
    Join Date
    2016-Feb
    Posts
    4
    Thanks, but I can find neither system tools nor preference, even after searching ....

  6. #6
    Join Date
    2016-Feb
    Posts
    1
    I ran into this issue with guake. Here's what I did:
    open terminal
    which guake (copied path)
    cd /etc/init.d (the system runs scripts in this directory on boot)
    touch guake.sh
    opened with vi and added the following:
    #! /bin/sh
    /usr/bin/guake&
    saved and closed the file
    chmod 755 guake.sh
    update-rc.d /etc/init.d/guake.sh defaults

    Keep in mind Kali is based on Debian, so you can usually find solutions for Debian that will work on Kali.

  7. #7
    Join Date
    2016-Feb
    Posts
    4
    sounds like the same as my try

    1+2.
    cp /opt/teamviewer/tv_bin/script/teamviewerd.sysv /etc/init.d
    chmod 755 /etc/init.d/teamviewerd.sysv
    update-rc.d teamviewerd.sysv defaults => no any output
    => above all doesn't work

Similar Threads

  1. Kali Rolling - pulseaudio (sound) does not autostart
    By canadianbacon22 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-03-12, 14:42
  2. Autostart application on GDM
    By iThinkDev in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-07-26, 15:54

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •