Results 1 to 4 of 4

Thread: Subterfuge errors after installing on Kali Rolling Release 2016.1

  1. #1
    Join Date

    Exclamation Subterfuge errors after installing on Kali Rolling Release 2016.1

    I downloaded the .deb file for subterfuge and ran the appropriate dpkg -i thisfile.deb.
    Then had to do an apt-get install -f to fix dependencies.
    Now its installed but when i go to run in i get this:

    ryu@zen:~$ subterfuge
    Traceback (most recent call last):
    File "/bin/subterfuge", line 25, in <module>
    from main.models import *
    File "/usr/share/subterfuge/main/", line 3, in <module>
    class credentials(models.Model):
    File "/usr/lib/python2.7/dist-packages/django/db/models/", line 94, in __new__
    app_config = apps.get_containing_app_config(module)
    File "/usr/lib/python2.7/dist-packages/django/apps/", line 239, in get_containing_app_config
    File "/usr/lib/python2.7/dist-packages/django/apps/", line 124, in check_apps_ready
    raise AppRegistryNotReady("Apps aren't loaded yet.")
    django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.

    Same result if ran as root or sudo user. Anyone seen this before? I'm not turning up much info myself and Im stumped.
    Last edited by jfranco; 2016-02-13 at 13:41.

  2. #2
    Join Date
    So for anyone else running into this issue. The problem, as it usually is, was somewhat easy to figure out with a little more digging. I noticed in the errors that subterfuge makes use of django 1.5, the kali distros come with a much more updated version that doesnt cooperate with subterfuge so here's the code:

    sudo pip install django=="1.5"
    reboot now

    Enjoy subterfuge again

    In addition, I have read that you may also have to remove the newer django files as well if you still experience issues however, I have not experienced any such issues as of yet, will keep everyone posted if I do. Currently running AMD A6 processor with Radeon 7500 gpu and 8Gb DDR3
    Last edited by jfranco; 2016-02-16 at 04:50. Reason: added additional info

  3. #3
    Join Date
    Thanks for the help

  4. #4
    Join Date
    on board my sailboat
    hi guy....thanks for the help with this problem....i had it happen to me with the new install of kali linux 2016.1....your fix worked to get subterfuge running...but i still dont seen to be able to get any results ......but i do see an error on the terminal screen when i start the capture on the web page...the error i see is this...

    [24/Feb/2016 09:26:14] "GET / HTTP/1.1" 200 2613
    Traceback (most recent call last):
    File "/usr/share/subterfuge/", line 14, in <module>
    AttributeError: 'module' object has no attribute 'setup'
    [24/Feb/2016 09:26:17] "GET / HTTP/1.1" 200 2613

    can anyone help me with this...

Similar Threads

  1. Need help installing WUSB6300 on Kali Rolling 2016.1
    By Blasta44 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-02-18, 12:44
  2. Replies: 0
    Last Post: 2016-09-22, 15:33
  3. KDE Desktop with 2016.1 Rolling and apt-get 404 errors
    By dskzz in forum General Archive
    Replies: 1
    Last Post: 2016-07-27, 11:30
  4. Kali 2016 Rolling Release how to fetch only security updates
    By gerlinde in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-02-11, 19:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts