Results 1 to 45 of 45

Thread: Can't get WN722N to work on OPO

  1. #1
    Join Date
    2016-Feb
    Location
    UK
    Posts
    20

    [solved] Can't get WN722N to work on OPO

    EDIT: Solved, I was using the wrong kernel, you need nethunter kernel in order to put your devices in monitor mode.



    Hey guys, I've been digging around all over the web but I couldnt find anything useful.

    I am connecting a TL-WN722N with Y cable plugged into the wall to my One Plus One running NetHunter 3.0.5 on CM12.1.
    The system runs in multiRom as a secondary rom. The primary rom is a stock CM12.1

    The problem:

    1. lsusb shows the device (Bus 001 Device 002)
    Code:
    root@kali:~# lsusb
    libudev: udev_has_devtmpfs: name_to_handle_at on /dev: Function not implemented
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    2. wifite or any other software won't show the device wlan1 (wlan0 is the integrated one)
    Code:
    root@kali:~# wifite
    
      .;'                     `;,    
     .;'  ,;'             `;,  `;,   WiFite v2 (r87)
    .;'  ,;'  ,;'     `;,  `;,  `;,  
    ::   ::   :   ( )   :   ::   ::  automated wireless auditor
    ':.  ':.  ':. /_\ ,:'  ,:'  ,:'  
     ':.  ':.    /___\    ,:'  ,:'   designed for Linux
      ':.       /_____\      ,:'     
               /       \             
    
    
     [!] the program cowpatty is not required, but is recommended
    
     [+] scanning for wireless devices...
     [+] available wireless devices:
      1. p2p0		??????		Not pci, usb, or sdio
      2. wlan0		??????		Not pci, usb, or sdio
     [+] select number of device to put into monitor mode (1-2):

    Things I've tried:
    1.
    Code:
    Open custom command - Add command - 
    label: 
    Monitor mode
    command:
    ifconfig wlan1 up && airmon-ng start wlan1
    send to : Kali
    Exec mode : Background
    Leave 
    Run at boot - 
    Then tap on Update.
    When start run custom command and Monitor mode - tap RUN
    2.
    Code:
    root@kali:~# ifconfig wlan1 up
    wlan1: ERROR while getting interface flags: No such device
    both operations gave me negative results (no such device)

    3. Plugged an USB stick to the otg y cable and it works

    4. Tried the TL-WN722N Adapter on a Kali machine and works perfectly plug-n-play

    5. Run apt-get update && apt-get install firmware-atheros - says firmware-atheros is already the newest version






    I don't know what to do, I've been trying to make this working for a week now and it doesnt seem to be anything useful on google.

    Any hints please?

    Thank you very much.
    Last edited by pLx; 2016-02-22 at 10:25. Reason: when I plug the adapter in, the led on the adapter doesnt light on

  2. #2
    Join Date
    2016-Feb
    Location
    UK
    Posts
    20
    SOLVED - It was a kernel issue.

    Thanks a lot at the chaps on freenode who helped me out.
    Last edited by pLx; 2016-02-22 at 10:23. Reason: solved

  3. #3
    Join Date
    2016-Feb
    Posts
    116
    Glad to see my kernel works for you.

  4. #4
    Join Date
    2016-Feb
    Location
    UK
    Posts
    20
    I've been a ***** for not mentioning you and jc here on the forums! I'd like to thank both you and JC for helping me out, the kernel works like a charm on CM13 as well as JC's chroot! Very stable indeed.

    I'll see you on irc mate

  5. #5
    Join Date
    2015-Nov
    Posts
    4
    Can you detail for us how to get it to work? I am using NetHunter 3.0 on a Nexus 7. A little bit of a Linux newbie so any help would be appreciated.

  6. #6
    Join Date
    2016-Feb
    Location
    UK
    Posts
    20
    Well I own a OPO so I wouldnt know how to help with a Nexus, but the problem was that I flashed a stock kernel after installing Nethunter.
    The OPO network interface won't work in monitor mode so I did need an external one. In order to use any external adapter you need the nethunter kernel which contains the mac80211 injection patch. Without this patch you cant get any external adapter to work.

    I dont know if this is the case with your phone but you might need to check you are using the patched kernel. If you have ever flashed a different kernel after installing nethunter I suggest you to wipe and reflash rom+nethunter from scratch.

    If you run the command "lsusb" in terminal, do you see the wifi device in the list?
    Be the change you wish to see in the world.

  7. #7
    Join Date
    2016-Mar
    Posts
    29
    Can you share the link of the kernel?
    Last edited by haken29a; 2016-03-09 at 01:40. Reason: spelling

  8. #8
    Join Date
    2016-Feb
    Posts
    116
    Quote Originally Posted by root1234 View Post
    Can you share the link of the kernel?
    He's using my kernel. You can get it from:

    Code:
    https://www.androidfilehost.com/?w=files&flid=50945
    Make sure to get the right kernel for your android version. It is structured by folders so it shouldn't be a problem for you to determine which is the right one.

  9. #9
    Join Date
    2013-Mar
    Posts
    24
    Your kernel is good for atheros ar9271 and ralink rt2870/3070.
    is a patch possible for ralink rt 3572?

  10. #10
    Join Date
    2016-Feb
    Posts
    116
    Does this adapter require additional power in order to work?

    Edit: I just checked. It should work, unless this specific adapters requires addition power (otg-y host & charge). In that case, it couldn't be done, for now.

    I will release a new version later today / tomorrow and you will have to test that out for me as I don't have that adapter.
    Last edited by Phreya; 2016-03-10 at 16:00.

  11. #11
    Join Date
    2013-Mar
    Posts
    24
    Last edited by rnk; 2016-03-10 at 17:06.

  12. #12
    Join Date
    2016-Feb
    Posts
    116
    It should work then... the device is checked via defconfig.

  13. #13
    Join Date
    2013-Mar
    Posts
    24
    In normal kali linux (notebook) it works fine.
    When i try "lsusb" it shows like
    3572 Ralink technology corp. wireless adaptor
    Also when i run wifite it shows adaptor as
    3.wlan1 ...
    when i select 3 to put in monitor mode,it doesnt work.

  14. #14
    Join Date
    2013-Mar
    Posts
    24
    i tried kernel-nethunter-bacon-marshmallow-20160312.zip
    but no success for rt3572

  15. #15
    Join Date
    2016-Feb
    Posts
    116
    This release wasn't related to that... just CyanogenMod sync...

    Edit:

    I have introduced a y-cable otg host + charging patch. You can try your adapter now. Make sure you connect it via y-cable and give it more power.
    Last edited by Phreya; 2016-03-13 at 07:18.

  16. #16
    Join Date
    2013-Mar
    Posts
    24
    i plugged 52nh's short cablo to notebook and wifite worked.wlan1mon works.
    But "besside-ng wlan1 " doesnt work.i use it alot.
    is it possile to use it without notebook in future?

  17. #17
    Join Date
    2016-Feb
    Posts
    116
    Have you tried my new kernel? I've released it today.

    Also note that besside-ng isn't kernel-related. If wifite/mon/injection works, of course.

  18. #18
    Join Date
    2013-Mar
    Posts
    42
    @Phreya
    I saw your repository on androidfiles for the OPO.

    There is a Kernel for CM13 and a update-nethunter-bacon-marshmallow file. Does it mean i can use the current CM13 Version on my OPO to run Nethunter with your Kernel and the Update ? I ask, because the offical Version of Nethunter is still for CM 12.1

    If so, do i install nethunter on a clean CM13, flash the your Kernel and the flash your update file ?

    Thanks!

  19. #19
    Join Date
    2016-Feb
    Posts
    116
    @BeNe you can use whatever you like. I have 3 version of my kernel for OnePlus One; CM12.1, CM13 and OxygenOS:

    Code:
    https://www.androidfilehost.com/?w=files&flid=50945
    All you have to do is flash my "update" (or "kernel" if you already have nethunter installer) and chroot:

    Code:
    https://idlekernel.com/nethunter/nightly/3.0.5-20160309-2206/chroot-full/
    Make sure you wipe cache after flashing chroot, as otherwise a bootloop may occur.
    Last edited by Phreya; 2016-03-13 at 14:26.

  20. #20
    Join Date
    2013-Mar
    Posts
    24
    ok.i installed last kernel. 3.13
    rt3572 works fine if short cable plugged in notebook.(monitor mode works fine with wifite)
    if i dont plugin in short cable to notebook,when i run wifite it shows 3.ralink rt3572..
    but when i select it to put in monitor mode,it disappers and doesnt work.

  21. #21
    Join Date
    2016-Feb
    Posts
    116
    That's because this specific adapter needs y-cable charging. I don't think it will be possible to do it otherwise.

  22. #22
    Join Date
    2016-Mar
    Posts
    29
    The link for me didn't open and I have the version of me original kernel 3.10.49
    On the nexus 6 .this. is the problem I get.
    root@kali:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up postgresql-9.4 (9.4.6-0+deb8u1) ...
    [....] Starting PostgreSQL 9.4 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2016-03-13 23:32:24 UTC [16143-1] FATAL: could not create shared memory segment: Function not implemented 2016-03-13 23:32:24 UTC [16143-2] DETAI[FAILiled system call was shmget(key=5432001, size=40, 03600). ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing package postgresql-9.4 (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    postgresql-9.4
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~#

    The wifite problem


    root@kali:~# airmon-ng

    Found phy0 with no interfaces assigned, would you like to assign one to it? [y/n] y


    ERROR adding monitor mode interface: command failed: Operation not supported (-95)

    PHY Interface Driver Chipset

    phy0 wlan0 ?????? non-mac80211 device? (report this!)

    root@kali:~#

    Some help please.

  23. #23
    Join Date
    2016-Feb
    Posts
    116
    First problem, refer to this thread:

    Code:
    https://forums.kali.org/showthread.php?1950-postgresql-9-1-errors-after-installing-a-package
    Second problem:
    You have to select a Mac80211 device (an external adapter!), you're selecting the one adapter that comes with your phone and it doesn't have monitor mode. You need to buy an adapter.

    Also, you just hijacked a thread.

  24. #24
    Join Date
    2016-Mar
    Posts
    29
    I have a tp-linkeTL-Wn722N

  25. #25
    Join Date
    2016-Mar
    Posts
    29
    More details please so I can get it right because I flashed my phone more then 5 times.
    Last edited by root1234; 2016-03-14 at 09:23.

  26. #26
    Join Date
    2016-Feb
    Posts
    116
    Yes, but for this adapter you need to use y-cable with a charging patch mode in your kernel. You said you have Nexus 6, I don't even think there's a y-cable charging mode patch in your kernel, but I might be wrong on this one. Anyway - on Wifite you SHOULD see it as wlan0/wlan1, not phy0. So I guess that's the case indeed. But even then, you still need to buy a cable like this to get it working:

    Code:
    http://www.amazon.com/Micro-Cable-Power-Samsung-AtomicMarket/dp/B009YPYORM/
    Last edited by Phreya; 2016-03-14 at 09:39.

  27. #27
    Join Date
    2016-Mar
    Posts
    29
    And sorry for that

  28. #28
    Join Date
    2016-Mar
    Posts
    29
    I have the y-cable

    root@kali:~# lsusb
    libudev: udev_has_devtmpfs: name_to_handle_at on /dev: Function not implemented
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 05c6:90a4 Qualcomm, Inc.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@kali:~# iwconfig
    r_rmnet_data7 no wireless extensions.

    r_rmnet_data4 no wireless extensions.

    wlan0 no wireless extensions.

    r_rmnet_data1 no wireless extensions.

    sit0 no wireless extensions.

    dummy0 no wireless extensions.

    r_rmnet_data6 no wireless extensions.

    r_rmnet_data3 no wireless extensions.

    lo no wireless extensions.

    rmnet_usb0 no wireless extensions.

    rmnet_data7 no wireless extensions.

    rmnet_data6 no wireless extensions.

    rmnet_data5 no wireless extensions.

    rmnet_data4 no wireless extensions.

    rmnet_data3 no wireless extensions.

    rmnet_data2 no wireless extensions.

    rmnet_data1 no wireless extensions.

    rmnet_data0 no wireless extensions.

    r_rmnet_data8 no wireless extensions.

    r_rmnet_data0 no wireless extensions.

    r_rmnet_data5 no wireless extensions.

    usb0 no wireless extensions.

    r_rmnet_data2 no wireless extensions.

    root@kali:~#

  29. #29
    Join Date
    2016-Mar
    Posts
    29
    But there is no wlan1 only wlan0

  30. #30
    Join Date
    2016-Feb
    Posts
    116
    Did you connect it to power? Anyway, you should get into the IRC and ask if Nexus 6 maintainer is there and see if he could help. There's a chance that Nexus 6 doesn't have y-cable charging + hosting mode ability, so it won't work for you anyway.

  31. #31
    Join Date
    2016-Mar
    Posts
    29
    OK thanks for your help .

  32. #32
    Join Date
    2016-Mar
    Posts
    29

  33. #33
    Join Date
    2016-Mar
    Posts
    29
    Is not the right one for the adapter

  34. #34
    Join Date
    2016-Feb
    Posts
    116
    Of course it won't work for you. Your cable doesn't have power to connect to. Wow, just wow.. you're wasting your time, dude. Please see again the link I've sent you. You need one that has an ability to connect it to electricity.

  35. #35
    Join Date
    2016-Mar
    Posts
    29
    Thanks dude I will .
    Last edited by root1234; 2016-03-14 at 10:40.

  36. #36
    Join Date
    2016-Feb
    Posts
    116
    You can't. It's not an issue. phy0 is a internal adapter built-in your phone. It's not a Mac80211 chipset. This is exactly why you need an external adapter... if you didn't understand this.

  37. #37
    Join Date
    2016-Mar
    Posts
    29
    OK now I understand thanks

  38. #38
    Join Date
    2016-May
    Posts
    8
    Quote Originally Posted by pLx View Post
    SOLVED - It was a kernel issue.

    Thanks a lot at the chaps on freenode who helped me out.
    Did you try to test it without y cable and otg only or it needs the external power?

  39. #39
    Join Date
    2016-Mar
    Posts
    29
    Yeah it works with just a USB cabl for me.so I think it would work for u .and I get to flash the nethunter on the Samsung s3 every thing works on it .armitag.the wifite. The hid attacks .everything. I will post the details later.

  40. #40
    Join Date
    2016-May
    Posts
    8
    Quote Originally Posted by root1234 View Post
    Yeah it works with just a USB cabl for me.so I think it would work for u .and I get to flash the nethunter on the Samsung s3 every thing works on it .armitag.the wifite. The hid attacks .everything. I will post the details later.
    Can confirm the same for my op2 too. It was the kernel issue, now everything is fine. Thanks. What version of nethunter u flashed on ur s3? I'd like to try that too.

  41. #41
    Join Date
    2015-Nov
    Posts
    1
    Hi Phreya, I wanted to use your kernel but i cant do it work in my nexus 6 i installed nethuner hammerhead marshmallow so i have the same problem, here an image https://gyazo.com/09b4861356095a8de7609725a1bc0b5c when i try to install your kernel, you should know im not the best and im learning yet, what can i do? and what kernel version can i install here? https://idlekernel.com/nethunter/nightly/

    here the kernel version Linux kali 3.10.40-g27906c4 #1 SMP PREEMPT Tue Aug 9 18:53:52 UTC 2016 armv7l GNU/Linux

  42. #42
    Join Date
    2016-Oct
    Location
    Algeria
    Posts
    3
    had the same issue before , glad you found the solution

  43. #43
    Join Date
    2014-Nov
    Posts
    9
    Hi any nethunter kernel for Samsung tab S , SM-T705?

  44. #44
    Join Date
    2017-Sep
    Posts
    1
    Hi Phreya.

    I tried using your kernel 20170828.

    uname -a
    Linux kali 3.4.113-lineageos-g2c0e9edc #1 SMP PREEMPT Mon Aug 28 23:06:21 IDT 2017 armv7l GNU/Linux

    Running kali nethunter 3 on tuga power.

    I have Ralink Technology, Corp. MT7601U Wireless Adapter as external wifi adapter.

    Lsusb command does show card being connected but ifconfig / iwconfig don't show wlan1.
    Any suggestions for way out....

  45. #45
    Join Date
    2013-Mar
    Posts
    9
    Quote Originally Posted by jeret View Post
    Hi any nethunter kernel for Samsung tab S , SM-T705?
    did you ever find a kernel for sm-705t?? i have been searching all over for one.

Similar Threads

  1. Replies: 1
    Last Post: 2017-09-23, 08:46
  2. I'm just about to buy a WN722N
    By sircolin in forum General Archive
    Replies: 4
    Last Post: 2015-09-16, 17:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •