Results 1 to 2 of 2

Thread: Broken Gnome Install

  1. #1
    Join Date
    2016-Feb
    Posts
    2

    Unhappy Broken Gnome Install

    Hello again kali linux users, as you may know from my other post i had some problems with my bluetooth connection, after i managed to fix it i wanted to roll back from KDE to Gnome since the GUI it's a little more comfortable, i tried to run the command
    Code:
    apt-get install gnome-core kali-defaults kali-root-login desktop-base
    but i get the following error
    Code:
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     gnome-core : Depends: adwaita-icon-theme (>= 3.14) but it is not going to be installed
                  Depends: baobab (>= 3.14) but it is not going to be installed
                  Depends: caribou (>= 0.4.15) but it is not going to be installed
                  Depends: caribou-antler (>= 0.4.15) but it is not going to be installed
                  Depends: libcaribou-gtk-module (>= 0.4.15) but it is not going to be installed
                  Depends: libcaribou-gtk3-module (>= 0.4.15) but it is not going to be installed
                  Depends: empathy (>= 3.12) but it is not going to be installed
                  Depends: eog (>= 3.14) but it is not going to be installed
                  Depends: evince (>= 3.14) but it is not going to be installed
                  Depends: evolution-data-server (>= 3.12) but it is not going to be installed
                  Depends: gdm3 (>= 3.14) but it is not going to be installed
                  Depends: glib-networking (>= 2.42) but it is not going to be installed
                  Depends: gnome-bluetooth (>= 3.14) but it is not going to be installed
                  Depends: gnome-calculator (>= 3.14) but it is not going to be installed
                  Depends: gnome-contacts (>= 3.14) but it is not going to be installed
                  Depends: gnome-control-center (>= 1:3.14) but it is not going to be installed
                  Depends: gnome-dictionary (>= 3.14) but it is not going to be installed
                  Depends: gnome-disk-utility (>= 3.12) but it is not going to be installed
                  Depends: gnome-font-viewer (>= 3.14) but it is not going to be installed
                  Depends: gnome-keyring (>= 3.14) but it is not going to be installed
                  Depends: gnome-online-accounts (>= 3.14) but it is not going to be installed
                  Depends: gnome-online-miners (>= 3.14) but it is not going to be installed
                  Depends: gnome-packagekit (>= 3.14) but it is not going to be installed
                  Depends: gnome-screenshot (>= 3.14) but it is not going to be installed
                  Depends: gnome-session (>= 3.14) but it is not going to be installed
                  Depends: gnome-settings-daemon (>= 3.14) but it is not going to be installed
                  Depends: gnome-shell (>= 3.14) but it is not going to be installed              
                  Depends: gnome-shell-extensions (>= 3.14) but it is not going to be installed   
                  Depends: gnome-system-log (>= 3.9.90) but it is not going to be installed       
                  Depends: gnome-system-monitor (>= 3.14) but it is not going to be installed     
                  Depends: gnome-terminal (>= 3.14)                                               
                  Depends: gnome-themes-standard (>= 3.14) but it is not going to be installed    
                  Depends: gnome-user-guide (>= 3.14) but it is not going to be installed         
                  Depends: gnome-user-share (>= 3.14) but it is not going to be installed
                  Depends: gstreamer1.0-plugins-good (>= 0.10.31) but it is not going to be installed
                  Depends: libgtk-3-common (>= 3.14) but it is not going to be installed
                  Depends: gtk2-engines (>= 2.20.2) but it is not going to be installed
                  Depends: gucharmap (>= 1:3.14) but it is not going to be installed
                  Depends: gvfs-backends (>= 1.22)
                  Depends: iceweasel (>= 30) but it is not going to be installed
                  Depends: gkbd-capplet (>= 3.6) but it is not going to be installed
                  Depends: metacity (>= 1:2.34) but it is not going to be installed
                  Depends: mousetweaks (>= 3.12) but it is not going to be installed
                  Depends: nautilus (>= 3.14) but it is not going to be installed
                  Depends: policykit-1-gnome (>= 0.105)
                  Depends: gnome-sushi (>= 3.12) but it is not going to be installed
                  Depends: totem (>= 3.14) but it is not going to be installed
                  Depends: tracker-gui but it is not going to be installed
                  Depends: vino (>= 3.14) but it is not going to be installed
                  Depends: yelp (>= 3.14) but it is not going to be installed
                  Depends: zenity (>= 3.14)
                  Recommends: network-manager-gnome but it is not going to be installed
     gnome-icon-theme : Depends: libgtk-3-bin
     libgpgme11 : Depends: gnupg2 (> 2.0.4)
     libgtk-3-0 : Depends: libgtk-3-common (>= 3.14.5-1+deb8u1) but it is not going to be installed
                  Depends: librest-0.7-0 (>= 0.7) but it is not going to be installed
                  Depends: libsoup2.4-1 (>= 2.4.0) but it is not going to be installed
                  Recommends: libgtk-3-bin
     libnepomuk4 : Depends: libsoprano4 (>= 2.7.56) but it is not going to be installed
     libnepomukutils4 : Depends: libnepomukquery4a (= 4:4.14.14-1+b1) but it is not going to be installed
                        Depends: libsoprano4 (>= 2.7.56) but it is not going to be installed
     wine : Depends: wine64 (>= 1.6.2-20) but it is not going to be installed or
                     wine32 (>= 1.6.2-20)
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    i tried with apt-get autoremove & apt-get autoclean but seems like there are some gnome packages that i don't seem to find, also tried the synaptic pkg manager and if i remove gnome packets it asks me if i want to remove kali distros & my KDE desktop, is there any way to fix this?

  2. #2
    Join Date
    2016-Feb
    Location
    California
    Posts
    112
    Here is a probable Fix
    Hope it works

    http://www.webupd8.org/2014/01/how-t...tu-system.html
    ------------------Contact: Skype : Gh0sT.sh ( 0 -->Zero )-------------------
    |
    /vvvvvvvvvvvv \-------------------------------------------------------------------------,,
    |^^^^^^^^ /===================================--""
    ################################################
    ----------The quieter you become,The more you will able to hear-----------
    ################################################

Similar Threads

  1. Gnome gui NETWORK broken
    By Chris845 in forum TroubleShooting Archive
    Replies: 8
    Last Post: 2017-04-03, 17:52
  2. Can't install gnome-tweak tool on fresh kali install
    By Dave46 in forum General Archive
    Replies: 0
    Last Post: 2016-08-20, 19:57
  3. Custom gnome install necessary for gnome-shell?
    By karni64 in forum Building Archive
    Replies: 7
    Last Post: 2013-04-15, 00:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •