Results 1 to 2 of 2

Thread: Raspberry PI Kali Wifi Issues...

  1. #1

    Raspberry PI Kali Wifi Issues...

    Hi All,

    Firstly hope this is the correct place to post, if not let me know. Ok, so to begin I've flashed SD withKali*2.1 .img, and setup Wifi dongle to load on startup. So internet will not connect on boot, this only happens after I log into GUI (forced to login on boot) After login I see below:

    enx74da3826a5f7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.1.11 netmask 255.255.255.0 broadcast 192.168.1.255
    inet6 fe80::76da:38ff:fe26:a5f7 prefixlen 64 scopeid 0x20<link>
    ether 74:da:38:26:a5:f7 txqueuelen 1000 (Ethernet)
    RX packets 9415 bytes 1029732 (1005.5 KiB)
    RX errors 0 dropped 51 overruns 0 frame 0
    TX packets 13338 bytes 13640299 (13.0 MiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    It seems despite setting wlan0 in /etc/network/interfaces, its getting renamed on boot (by kernel):

    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet manual
    ssid TALKTALK-XXXXFE
    psk XXXXXXXXX
    key_mgmt WPA-PSK

    What I'm really after is a headless pi running*Kali, that is connectable with out having to login. Preference is really not to launch GUI @ all, but that's another story*. Let me know if you need any other information, but I'm @ my wits end with this one**!

    Cheers,

    RaspberryPIMani100X

  2. #2
    Join Date
    2016-Mar
    Posts
    1
    Hey, I have the same problem as you.
    Did yoyu solve the problem yet ?

    It seems that my raspberry pi 2 has to install the driver for ew7811un.

    Quote Originally Posted by RaspberryPIMani100X View Post
    Hi All,

    Firstly hope this is the correct place to post, if not let me know. Ok, so to begin I've flashed SD withKali*2.1 .img, and setup Wifi dongle to load on startup. So internet will not connect on boot, this only happens after I log into GUI (forced to login on boot) After login I see below:

    enx74da3826a5f7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.1.11 netmask 255.255.255.0 broadcast 192.168.1.255
    inet6 fe80::76da:38ff:fe26:a5f7 prefixlen 64 scopeid 0x20<link>
    ether 74:da:38:26:a5:f7 txqueuelen 1000 (Ethernet)
    RX packets 9415 bytes 1029732 (1005.5 KiB)
    RX errors 0 dropped 51 overruns 0 frame 0
    TX packets 13338 bytes 13640299 (13.0 MiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    It seems despite setting wlan0 in /etc/network/interfaces, its getting renamed on boot (by kernel):

    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet manual
    ssid TALKTALK-XXXXFE
    psk XXXXXXXXX
    key_mgmt WPA-PSK

    What I'm really after is a headless pi running*Kali, that is connectable with out having to login. Preference is really not to launch GUI @ all, but that's another story*. Let me know if you need any other information, but I'm @ my wits end with this one**!

    Cheers,

    RaspberryPIMani100X

Similar Threads

  1. Raspberry 3 + Latest Kali - Airodump-ng issues
    By e0xbr in forum ARM Archive
    Replies: 17
    Last Post: 2017-10-25, 16:57
  2. Issues with Kali 2.1 and Raspberry PI2
    By the2ndson in forum ARM Archive
    Replies: 0
    Last Post: 2016-03-08, 18:57
  3. Issues with VPN on Raspberry
    By Fuffu in forum ARM Archive
    Replies: 2
    Last Post: 2015-09-05, 13:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •