Results 1 to 4 of 4

Thread: Installed the Kali NVIDIA Driver but pyrit doesn't list my GPU

  1. #1
    Join Date
    Jackson MS.

    Installed the Kali NVIDIA Driver but pyrit doesn't list my GPU

    New install of Kali rolling and I followed the the kali documentation on installing the nvidia drivers. Everything is up and running but when I do a pyrit list_cores all I get is 8 cores, no listing on my GPU.

    I have a ASUS Laptop running i7 and Nvidia GeForce GTX460M CUDA with 1 GB RAM

    apt-get update
    apt-get dist-upgrade
    apt-get install -y linux-headers-$(uname -r) **However I did have to get this working before I could continue as it wouldn't find any header files.
    apt-get install nvidia-kernel-dkms

    No problems with this step either

    sed 's/quiet/quiet nouveau.modeset=0/g' -i /etc/default/grub

    I get this output

    root@kali:~# glxinfo | grep -i "direct rendering"
    direct rendering: Yes

    Then I checked to see if pyrit could see my GPU like other posts show

    root@kali:~# pyrit benchmark

    Pyrit 0.4.0 (C) 2008-2011 Lukas Lueg
    This code is distributed under the GNU General Public License v3+

    Running benchmark (2989.9 PMKs/s)... |

    Computed 2989.92 PMKs/s total.
    #1: 'CPU-Core (SSE2)': 385.8 PMKs/s (RTT 3.2)
    #2: 'CPU-Core (SSE2)': 384.2 PMKs/s (RTT 3.1)
    #3: 'CPU-Core (SSE2)': 385.1 PMKs/s (RTT 3.2)
    #4: 'CPU-Core (SSE2)': 383.7 PMKs/s (RTT 3.1)
    #5: 'CPU-Core (SSE2)': 383.4 PMKs/s (RTT 3.2)
    #6: 'CPU-Core (SSE2)': 386.3 PMKs/s (RTT 3.1)
    #7: 'CPU-Core (SSE2)': 386.0 PMKs/s (RTT 3.2)
    #8: 'CPU-Core (SSE2)': 386.0 PMKs/s (RTT 3.1)

    if this the correct output? Or should I be seeing my GPU listed?
    I was thinking my GPU should be putting out much better PMK's than whats listed so I'm just wondering if I did something incorrect. I read a few posts about installing the proprietary NVIDIA driver and even downloaded it but I wanted a second opinion before I did.

    Thank you

  2. #2
    Join Date
    Jackson MS.
    After 3 days I got the Geforce GTX 460 Cuda drivers loaded. I don't know what I was doing wrong but I could not get the debain nvidia drivers to unload. I obviously tried everything but the correct way. So if you can get the old drivers uninstalled then your half way there.

    Laptop ASUS Model G73S

    NEW Install of Kali 2016.1

    apt-get update && apt-get upgrade && apt-get dist-upgrade

    while that was being installed I downloaded the drivers for my card. Mine was ""


    apt-get install -y linux-headers-$(uname -r)


    sed 's/quiet/quiet/ nouveau.modeset=0/g' -i /etc/default/grub

    if gnu loads or doesn't load I ctrl +alt+f1
    logged in as root

    init 3

    relogged in

    checked run level with "runlevel"

    went to my driver location and chmod +u ./

    then I typed


    this is the first time it actually got past 56% and finished the install.

    rebooted, crossed fingers, held my head to the left with my tongue held to the roof of my mouth.

    it loaded then I tried to test it

    pyrit still didn't show CPU 1 as a GPU so I got cudahashcat

    went to and downloaded oclHashcat binaries for NVidia

    i then entered 7z x cudaHashcat-2.01.7z

    went to and got a hash to test.

    once done i used this to test my card, which by the way worked but hit my overheat warning so thats another issue I have to figure out.

    ./cudaHashcat64.bin -m 100 -a 3 -n 32 --custom-charset1=?l?d /root/cudaHashcat-2.01/sh1testhash.txt -o /root/cudaHashcat-2.01/output.txt

    seems to be working, just need to figure out my overheat problem.

  3. #3
    Join Date
    Jackson MS.
    I've searched and can not find an answer to my problem. Am I asking the wrong questions or asking the question incorrectly? I still show no GPU in pyrit so is this something for my laptop? or common now? Anyone?

  4. #4
    Join Date
    The Netherlands
    First you need to download, install, and compile Cuda-Pyrit. Then you can see the GPU with "pyrit list_cores"

Similar Threads

  1. Nvidia Driver installed, Skype not works anymore.
    By zaid1337b0x in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-02-08, 16:19
  2. Nvidia driver installed but gdm3 service doesn't work
    By Leonida12 in forum General Archive
    Replies: 2
    Last Post: 2013-12-11, 22:17
  3. Nvidia Driver, Cuda Pyrit
    By wojtask12 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-10-18, 15:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts