Results 1 to 1 of 1

Thread: Touchpad not working on Kali Linux [Can't be detected] ★

  1. #1
    Join Date

    Exclamation Touchpad not working on Kali Linux [Can't be detected] ★

    Hey guys,

    I've just installed Kali Linux 2.0 on my HHD beside my SSD Windows 10. I had to reinstalled it multiple times due to GPU driver issues.
    and every time i boot my linux it cannot detect my touch-pad driver! It's not working. I'v tried so many solutions but non of them worked.
    I tried installing Gpointing with apt-get install gsynaptics and still the touchpad is not detected. even during the installation of linux i couldn't
    use the touchpad so i had to use the mouse.

    here is my output of lshw:

    and here is my output of: xinput
    root@kali:~# xinput
    ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
    ⎜   ↳ ASUS Laser GAMING MOUSE                     id=11    [slave  pointer  (2)]
    ⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
        ↳ Power Button                                id=6    [slave  keyboard (3)]
        ↳ Video Bus                                   id=7    [slave  keyboard (3)]
        ↳ Video Bus                                   id=8    [slave  keyboard (3)]
        ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    I went to Windows 10 -> Device manager -> pointing devices -> and i saw that the driver is : ASUS Touchpad driver
    maybe this is the problem, does it support linux or no ? or how should i install it to get it wokring.

    p.s: I'v contacted Asus support and they told me that they don't have drivers for Linux! What should i do? This can't be not working forever :/ I'm sure there is solution.

    I also tried all these steps and non of them worked for me:

    Thanks in advance!
    Last edited by M0HX; 2016-03-06 at 09:31.

Similar Threads

  1. Kali Rolling - Touchpad not working (after hang on shutdown?)
    By madcatter in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-09-25, 23:55
  2. Touchpad not detected
    By WavyCEO in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-07-27, 21:52
  3. Acer C720: touchpad not working under Kali 1.0.6
    By neverflw in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-05-08, 00:47
  4. Kali touchpad not working eeepc 1005
    By Battleship in forum Installing Archive
    Replies: 0
    Last Post: 2013-10-11, 19:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts