Results 1 to 16 of 16

Thread: linux-headers -> 4.3.0-kali1-686-pae

  1. #1
    Join Date
    2016-Mar
    Posts
    4

    linux-headers -> 4.3.0-kali1-686-pae

    Hello everybody.

    I am a beginner of LinuxKali. I have a below problem:

    root@KaliLinx:/home/tom# apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-4.3.0-kali1-686-pae
    E: Couldn't find any package by glob 'linux-headers-4.3.0-kali1-686-pae'
    E: Couldn't find any package by regex 'linux-headers-4.3.0-kali1-686-pae'

    root@KaliLinx:/home/tom# uname -r
    4.3.0-kali1-686-pae

    The settings for /etc/apt/sources.list

    deb http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security/ sana/updates main contrib non-free

    deb-src http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

    I tried to modification the settings in sources.list but the result is poor.

    Could you please give me some advice/suggestion?

  2. #2
    Join Date
    2016-Jan
    Posts
    99
    wrong repository. take a look here, c/p them and the save before update. http://docs.kali.org/general-use/kal...t-repositories

  3. #3
    Join Date
    2016-Mar
    Posts
    4
    Hi

    There are a repository on my /etc/apt/sources.lis

    deb http://http.kali.org/kali sana main non-free contrib
    deb http://security.kali.org/kali-security sana/updates main contrib non-free
    #deb-src http://security.kali.org/kali-security/ sana/updates main contrib non-free

    deb-src http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    deb-src http://http.kali.org/kali kali-rolling main contrib non-free

    What is wrong?

  4. #4
    Join Date
    2015-Apr
    Posts
    29
    All other entries in your sources.list are false.

    Only this entry.

    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    deb-src http://http.kali.org/kali kali-rolling main contrib non-free
    Last edited by Laserman75; 2016-03-07 at 11:26.

  5. #5
    Join Date
    2016-Mar
    Posts
    4
    Hi

    I changed sources.list and reboot system. Unfortunately I have still a problem.

    root@KaliLinx:/home/tom# date
    Mon Mar 7 13:07:54 GMT 2016
    root@KaliLinx:/home/tom# sudo apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-4.3.0-kali1-686-pae
    E: Couldn't find any package by glob 'linux-headers-4.3.0-kali1-686-pae'
    E: Couldn't find any package by regex 'linux-headers-4.3.0-kali1-686-pae'

    other advice?

  6. #6
    Join Date
    2016-Mar
    Location
    Pensacola, FL
    Posts
    2
    I just updated to "Rolling" which is 4.4.0 (is was painful but needed to be done due to the other repos being shutdown in april 2016) (2 laptops on slow wireless and 8hrs later I'm done TFG)

    First do a search: apt-cache search linux-headers (apt-cache search linux-headers-4.4)

    Then install: apt-get install linux-headers-4.4.0-kali1-all-amd64

  7. #7
    Join Date
    2016-Mar
    Posts
    4
    Hi

    I checked again my kernel for Linux Kali.
    root@KaliLinx:/home/tom# uname -r
    4.3.0-kali1-686-pae

    and I checked linux-headers
    root@KaliLinx:/home/tom# apt-cache search linux-headers
    linux-headers-4.4.0-kali1-686 - Header files for Linux 4.4.0-kali1-686
    linux-headers-4.4.0-kali1-686-pae - Header files for Linux 4.4.0-kali1-686-pae
    linux-headers-4.4.0-kali1-all - All header files for Linux 4.4 (meta-package)
    linux-headers-4.4.0-kali1-all-i386 - All header files for Linux 4.4 (meta-package)
    linux-headers-4.4.0-kali1-common - Common header files for Linux 4.4.0-kali1
    linux-headers-586 - Header files for Linux 586 configuration (dummy package)
    linux-headers-686 - Header files for Linux 686 configuration (meta-package)
    linux-headers-686-pae - Header files for Linux 686-pae configuration (meta-package)
    linux-libc-dev-alpha-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-arm64-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-armel-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-armhf-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-hppa-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-m68k-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mips-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mips64-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mips64el-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mipsel-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-powerpc-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-ppc64-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-ppc64el-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-s390x-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-sh4-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-sparc64-cross - Linux Kernel Headers for development (for cross-compiling)

    I tried to install linux-headers-4.4.0-kali1-686-pae
    root@KaliLinx:/home/tom# apt-get install linux-headers-4.4.0-kali1-686-pae
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    linux-headers-4.4.0-kali1-686-pae : Depends: linux-headers-4.4.0-kali1-common (= 4.4.2-3kali1) but it is not going to be installed
    Depends: linux-kbuild-4.4 but it is not going to be installed
    Depends: linux-compiler-gcc-5-x86 but it is not going to be installed
    open-vm-tools-desktop : Depends: libatkmm-1.6-1 (>= 2.22.1) but it is not installable
    Depends: libglibmm-2.4-1c2a (>= 2.36.2) but it is not installable
    Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
    Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
    Depends: open-vm-tools (= 2:9.4.0-1280544-5ubuntu6.2) but 2:9.10.2-2822639-1~bpo8+1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    What is wrong?

  8. #8
    Quote Originally Posted by alpork View Post
    Hi

    I checked again my kernel for Linux Kali.
    root@KaliLinx:/home/tom# uname -r
    4.3.0-kali1-686-pae

    and I checked linux-headers
    root@KaliLinx:/home/tom# apt-cache search linux-headers
    linux-headers-4.4.0-kali1-686 - Header files for Linux 4.4.0-kali1-686
    linux-headers-4.4.0-kali1-686-pae - Header files for Linux 4.4.0-kali1-686-pae
    linux-headers-4.4.0-kali1-all - All header files for Linux 4.4 (meta-package)
    linux-headers-4.4.0-kali1-all-i386 - All header files for Linux 4.4 (meta-package)
    linux-headers-4.4.0-kali1-common - Common header files for Linux 4.4.0-kali1
    linux-headers-586 - Header files for Linux 586 configuration (dummy package)
    linux-headers-686 - Header files for Linux 686 configuration (meta-package)
    linux-headers-686-pae - Header files for Linux 686-pae configuration (meta-package)
    linux-libc-dev-alpha-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-arm64-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-armel-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-armhf-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-hppa-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-m68k-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mips-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mips64-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mips64el-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-mipsel-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-powerpc-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-ppc64-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-ppc64el-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-s390x-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-sh4-cross - Linux Kernel Headers for development (for cross-compiling)
    linux-libc-dev-sparc64-cross - Linux Kernel Headers for development (for cross-compiling)

    I tried to install linux-headers-4.4.0-kali1-686-pae
    root@KaliLinx:/home/tom# apt-get install linux-headers-4.4.0-kali1-686-pae
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    linux-headers-4.4.0-kali1-686-pae : Depends: linux-headers-4.4.0-kali1-common (= 4.4.2-3kali1) but it is not going to be installed
    Depends: linux-kbuild-4.4 but it is not going to be installed
    Depends: linux-compiler-gcc-5-x86 but it is not going to be installed
    open-vm-tools-desktop : Depends: libatkmm-1.6-1 (>= 2.22.1) but it is not installable
    Depends: libglibmm-2.4-1c2a (>= 2.36.2) but it is not installable
    Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
    Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
    Depends: open-vm-tools (= 2:9.4.0-1280544-5ubuntu6.2) but 2:9.10.2-2822639-1~bpo8+1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    What is wrong?
    I had the same issue when trying to install VirtualBox. What eventually worked for me was to use “apt” in stead of “apt-get.” (I’m not sure whether this is an ideal solution though. I am a complete neophyte—not only to Kali but to Linux in general—so, this is just what eventually worked for me after throwing what ever I could think of at the problem. If anyone more knowledgeable could explain why this works and apt-get doesn’t, and whether it might end up being a Pyrrhic victory—all the talk of broken and uninstallable packages along the way gave me pause—I would love to hear it.)

    Code:
    apt update
    apt upgrade
    apt --upgradable list # to see the packages that for whatever reason were not upgraded. In my case 9, including the kali-linux-full
    apt install kali-linux-full* # I got some error about uninstallable dependencies when trying without the asterisk
    apt dist-upgrade
    reboot

  9. #9
    Join Date
    2016-Mar
    Posts
    11
    Quote Originally Posted by root@Laniakea View Post
    I had the same issue when trying to install VirtualBox. What eventually worked for me was to use “apt” in stead of “apt-get.” (I’m not sure whether this is an ideal solution though. I am a complete neophyte—not only to Kali but to Linux in general—so, this is just what eventually worked for me after throwing what ever I could think of at the problem. If anyone more knowledgeable could explain why this works and apt-get doesn’t, and whether it might end up being a Pyrrhic victory—all the talk of broken and uninstallable packages along the way gave me pause—I would love to hear it.)

    Code:
    apt update
    apt upgrade
    apt --upgradable list # to see the packages that for whatever reason were not upgraded. In my case 9, including the kali-linux-full
    apt install kali-linux-full* # I got some error about uninstallable dependencies when trying without the asterisk
    apt dist-upgrade
    reboot
    Hi, i get this mesage '''' unable to locate package linux-headers-4.0.3-kali1-686-pae''' i try your metod but i still get this mesage again and again
    what can do ?????
    Last edited by Gladiator; 2016-04-04 at 17:54.

  10. #10
    Join Date
    2016-Jan
    Posts
    99
    put this into your repositories list: deb http://http.kali.org/kali kali-dev-only main non-free contrib . update and delete it

  11. #11
    Join Date
    2016-Mar
    Posts
    11
    Quote Originally Posted by bob79 View Post
    put this into your repositories list: deb http://http.kali.org/kali kali-dev-only main non-free contrib . update and delete it

    I do this but when i do to install VBguest Aditions i get this





    and the log is here


    Last edited by Gladiator; 2016-04-04 at 19:46.

  12. #12
    Join Date
    2016-Apr
    Posts
    32
    I currently have the exact same issue...I have tried everything to upgrade my headers but nothing works!!!! There must be an expert here to help us?!

  13. #13
    Join Date
    2016-Apr
    Posts
    32
    I HAVE SOLVED THE ISSUE my friend!!!!!


    Add this repository to your sources.list

    Code:
    deb http://httpredir.debian.org/debian/ jessie main contrib non-free
    Enter this command

    Code:
    apt-get update
    And the whole of this command

    Code:
    apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
    When the installation has complete just restart your pc or laptop and enjoy
    Last edited by Cryptic-F; 2016-04-05 at 00:21.

  14. #14
    Quote Originally Posted by Gladiator View Post
    Hi, i get this mesage '''' unable to locate package linux-headers-4.0.3-kali1-686-pae''' i try your metod but i still get this mesage again and again
    what can do ?????
    Sorry to hear that. I notice you are running on a 32bit PAE system . Could that make a difference? Recently, I upgraded to 4.4.0 on two installs with this method: first I installed it on a kali host machine to install VirtualBox on it. Then I installed it in the same way on the guest kali machine I installed on that VirtualBox. Unfortunately, the 5 or so year old build I installed all this, and more, on just crashed—while I was running windows 10 of course (I was running about 4 linux systems and 1 windows in dual boot). After I saw your reply today, I tried to do the update again on the kali I am running on VirtualBox on my laptop. I’ll post the commands I used, and the response I got, below—as I suspected, installing kali-linux-full before the dist upgrade was redundant, at least on my current setup.

    (After I had removed all but the two rolling repositories from my sources.list file, and performed apt-get update and upgrade.)

    Input:

    Code:
    apt update
    Output:

    Code:
    Hit:1 http://ftp.halifax.rwth-aachen.de/kali kali-rolling InRelease
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    151 packages can be upgraded. Run 'apt list --upgradable' to see them.
    Input:

    Code:
    apt upgrade
    Output:

    Really long. So I will share any part with you if necessary.

    Input:

    Code:
    apt list --upgradable
    Output:

    Code:
    Listing... Done
    ghostscript/kali-rolling 9.19~dfsg-1 amd64 [upgradable from: 9.16~dfsg-2]
    kali-linux-full/kali-rolling 2016.2.3 amd64 [upgradable from: 2016.1.0]
    libgs9/kali-rolling 9.19~dfsg-1 amd64 [upgradable from: 9.16~dfsg-2]
    libgs9-common/kali-rolling,kali-rolling 9.19~dfsg-1 all [upgradable from: 9.16~dfsg-2]
    libjavascriptcoregtk-1.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    libjavascriptcoregtk-3.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    libwebkitgtk-1.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    libwebkitgtk-3.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    Input:

    Code:
    apt dist-upgrade
    Output:

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
      gtk2-engines inguma libasn1-8-heimdal libbasicusageenvironment0
      libgroupsock1 libgssapi3-heimdal libhcrypto4-heimdal libhdb9-heimdal
      libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libilmbase6v5
      libkdc2-heimdal libkrb5-26-heimdal liblivemedia23 libntdb1 libopenexr6v5
      libpgm-5.1-0 libpth20 libpython3.4-minimal libpython3.4-stdlib libqmi-glib1
      libquvi-scripts libquvi7 libregfi0 libroken18-heimdal libsodium13 libtrio2
      libusageenvironment1 libusbmuxd2 libwind0-heimdal libx265-68 libzip2 libzmq3
      python-bluez python-characteristic python-geoip python-ntdb python3.4
      python3.4-minimal ruby2.2-dev
    Use 'apt autoremove' to remove them.
    The following packages will be REMOVED:
      fonts-droid libwebkitgtk-1.0-common libwebkitgtk-3.0-common maltego
    The following NEW packages will be installed:
      fonts-droid-fallback fonts-noto-mono maltegoce
    The following packages will be upgraded:
      ghostscript kali-linux-full libgs9 libgs9-common libjavascriptcoregtk-1.0-0
      libjavascriptcoregtk-3.0-0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0
    8 upgraded, 3 newly installed, 4 to remove and 0 not upgraded.
    Need to get 111 MB of archives.
    After this operation, 7,378 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    Get:1 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libwebkitgtk-1.0-0 amd64 2.4.10-1 [8,042 kB]
    Get:2 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libjavascriptcoregtk-1.0-0 amd64 2.4.10-1 [1,969 kB]
    Get:3 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libwebkitgtk-3.0-0 amd64 2.4.10-1 [8,040 kB]
    Get:4 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libjavascriptcoregtk-3.0-0 amd64 2.4.10-1 [1,968 kB]
    Get:5 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 kali-linux-full amd64 2016.2.3 [7,620 B]
    Get:6 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/non-free amd64 maltegoce all 3.6.1.7809-0kali3 [84.0 MB]
    Get:7 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 fonts-droid-fallback all 1:6.0.1r16-1 [1,806 kB]
    Get:8 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 fonts-noto-mono all 20160116-1 [76.1 kB]
    Get:9 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 ghostscript amd64 9.19~dfsg-1 [94.9 kB]
    Get:10 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libgs9 amd64 9.19~dfsg-1 [2,065 kB]
    Get:11 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libgs9-common all 9.19~dfsg-1 [3,032 kB]
    Fetched 111 MB in 51s (2,148 kB/s)                                             
    Reading changelogs... Done
    (Reading database ... 320811 files and directories currently installed.)
    Removing fonts-droid (1:4.4.4r2-7) ...
    dpkg: libwebkitgtk-1.0-common: dependency problems, but removing anyway as you requested:
     libwebkitgtk-1.0-0:amd64 depends on libwebkitgtk-1.0-common (>= 2.4.9).
    
    Removing libwebkitgtk-1.0-common (2.4.9-3) ...
    Processing triggers for fontconfig (2.11.0-6.4) ...
    (Reading database ... 320716 files and directories currently installed.)
    Preparing to unpack .../libwebkitgtk-1.0-0_2.4.10-1_amd64.deb ...
    Unpacking libwebkitgtk-1.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Preparing to unpack .../libjavascriptcoregtk-1.0-0_2.4.10-1_amd64.deb ...
    Unpacking libjavascriptcoregtk-1.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Processing triggers for libc-bin (2.22-5) ...
    dpkg: libwebkitgtk-3.0-common: dependency problems, but removing anyway as you requested:
     libwebkitgtk-3.0-0:amd64 depends on libwebkitgtk-3.0-common (>= 2.4.9).
    
    (Reading database ... 320775 files and directories currently installed.)
    Removing libwebkitgtk-3.0-common (2.4.9-3) ...
    (Reading database ... 320714 files and directories currently installed.)
    Preparing to unpack .../libwebkitgtk-3.0-0_2.4.10-1_amd64.deb ...
    Unpacking libwebkitgtk-3.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Preparing to unpack .../libjavascriptcoregtk-3.0-0_2.4.10-1_amd64.deb ...
    Unpacking libjavascriptcoregtk-3.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Preparing to unpack .../kali-linux-full_2016.2.3_amd64.deb ...
    Unpacking kali-linux-full (2016.2.3) over (2016.1.0) ...
    Processing triggers for libc-bin (2.22-5) ...
    dpkg: maltego: dependency problems, but removing anyway as you requested:
     maltego-teeth depends on maltego.
    
    (Reading database ... 320773 files and directories currently installed.)
    Removing maltego (3.6.1.7809-0kali2) ...
    Selecting previously unselected package maltegoce.
    (Reading database ... 319701 files and directories currently installed.)
    Preparing to unpack .../maltegoce_3.6.1.7809-0kali3_all.deb ...
    Unpacking maltegoce (3.6.1.7809-0kali3) ...
    Selecting previously unselected package fonts-droid-fallback.
    Preparing to unpack .../fonts-droid-fallback_1%3a6.0.1r16-1_all.deb ...
    Unpacking fonts-droid-fallback (1:6.0.1r16-1) ...
    Selecting previously unselected package fonts-noto-mono.
    Preparing to unpack .../fonts-noto-mono_20160116-1_all.deb ...
    Unpacking fonts-noto-mono (20160116-1) ...
    Preparing to unpack .../ghostscript_9.19~dfsg-1_amd64.deb ...
    Unpacking ghostscript (9.19~dfsg-1) over (9.16~dfsg-2) ...
    Preparing to unpack .../libgs9_9.19~dfsg-1_amd64.deb ...
    Unpacking libgs9 (9.19~dfsg-1) over (9.16~dfsg-2) ...
    Preparing to unpack .../libgs9-common_9.19~dfsg-1_all.deb ...
    Unpacking libgs9-common (9.19~dfsg-1) over (9.16~dfsg-2) ...
    Processing triggers for fontconfig (2.11.0-6.4) ...
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for libc-bin (2.22-5) ...
    Setting up libjavascriptcoregtk-1.0-0:amd64 (2.4.10-1) ...
    Setting up libwebkitgtk-1.0-0:amd64 (2.4.10-1) ...
    Setting up libjavascriptcoregtk-3.0-0:amd64 (2.4.10-1) ...
    Setting up libwebkitgtk-3.0-0:amd64 (2.4.10-1) ...
    Setting up maltegoce (3.6.1.7809-0kali3) ...
    Setting up kali-linux-full (2016.2.3) ...
    Setting up fonts-droid-fallback (1:6.0.1r16-1) ...
    Setting up fonts-noto-mono (20160116-1) ...
    Setting up libgs9-common (9.19~dfsg-1) ...
    Setting up libgs9 (9.19~dfsg-1) ...
    Setting up ghostscript (9.19~dfsg-1) ...
    Processing triggers for libc-bin (2.22-5) ...
    Input:

    Code:
    apt list --upgradable
    Output:

    Code:
    Listing... Done
    Input:

    Code:
    uname -r
    Output:

    Code:
    4.3.0-kali1-amd64
    Input:

    Code:
    reboot
    (After reboot)

    Input:

    Code:
    uname -r
    Output:

    Code:
    4.4.0-kali1-amd64
    So, this procedure has now worked for me on three separate installs pretty much the same way. But, my machines have all been 64 bit. I am not sure whether that could make any difference, but maybe that is worth looking into.

  15. #15
    Join Date
    2016-Apr
    Posts
    7

    Can't get this to work with Kali 2016.1 persistent installation amd64

    thanks so much for this detailed explanation. unfortunately I can't get this (or any other guide) to work for me. I'm running a persistent Live installation of Kali 2016.1 on a 64bit system. After following your guide the final output is still "4.3.0-kali1-amd64". What I am really trying to accomplish here is installing NVIDIA drivers on the system so I can get a faster results while brute-forcing keys (or using a wordlist). The guide that took me down this rabbit hole is this one: http://docs.kali.org/general-use/ins...-on-kali-linux

    Is it even possible to do this with a persistent Live installation of kali? If not, how can perform a full installation of Kali 2016.1 onto a USB flash drive (I've tried about 4 ways to do this and none worked)?

    Any and all help will be greatly appreciated.

    Quote Originally Posted by root@Laniakea View Post
    Sorry to hear that. I notice you are running on a 32bit PAE system . Could that make a difference? Recently, I upgraded to 4.4.0 on two installs with this method: first I installed it on a kali host machine to install VirtualBox on it. Then I installed it in the same way on the guest kali machine I installed on that VirtualBox. Unfortunately, the 5 or so year old build I installed all this, and more, on just crashed—while I was running windows 10 of course (I was running about 4 linux systems and 1 windows in dual boot). After I saw your reply today, I tried to do the update again on the kali I am running on VirtualBox on my laptop. I’ll post the commands I used, and the response I got, below—as I suspected, installing kali-linux-full before the dist upgrade was redundant, at least on my current setup.

    (After I had removed all but the two rolling repositories from my sources.list file, and performed apt-get update and upgrade.)

    Input:

    Code:
    apt update
    Output:

    Code:
    Hit:1 http://ftp.halifax.rwth-aachen.de/kali kali-rolling InRelease
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    151 packages can be upgraded. Run 'apt list --upgradable' to see them.
    Input:

    Code:
    apt upgrade
    Output:

    Really long. So I will share any part with you if necessary.

    Input:

    Code:
    apt list --upgradable
    Output:

    Code:
    Listing... Done
    ghostscript/kali-rolling 9.19~dfsg-1 amd64 [upgradable from: 9.16~dfsg-2]
    kali-linux-full/kali-rolling 2016.2.3 amd64 [upgradable from: 2016.1.0]
    libgs9/kali-rolling 9.19~dfsg-1 amd64 [upgradable from: 9.16~dfsg-2]
    libgs9-common/kali-rolling,kali-rolling 9.19~dfsg-1 all [upgradable from: 9.16~dfsg-2]
    libjavascriptcoregtk-1.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    libjavascriptcoregtk-3.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    libwebkitgtk-1.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    libwebkitgtk-3.0-0/kali-rolling 2.4.10-1 amd64 [upgradable from: 2.4.9-3]
    Input:

    Code:
    apt dist-upgrade
    Output:

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
      gtk2-engines inguma libasn1-8-heimdal libbasicusageenvironment0
      libgroupsock1 libgssapi3-heimdal libhcrypto4-heimdal libhdb9-heimdal
      libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libilmbase6v5
      libkdc2-heimdal libkrb5-26-heimdal liblivemedia23 libntdb1 libopenexr6v5
      libpgm-5.1-0 libpth20 libpython3.4-minimal libpython3.4-stdlib libqmi-glib1
      libquvi-scripts libquvi7 libregfi0 libroken18-heimdal libsodium13 libtrio2
      libusageenvironment1 libusbmuxd2 libwind0-heimdal libx265-68 libzip2 libzmq3
      python-bluez python-characteristic python-geoip python-ntdb python3.4
      python3.4-minimal ruby2.2-dev
    Use 'apt autoremove' to remove them.
    The following packages will be REMOVED:
      fonts-droid libwebkitgtk-1.0-common libwebkitgtk-3.0-common maltego
    The following NEW packages will be installed:
      fonts-droid-fallback fonts-noto-mono maltegoce
    The following packages will be upgraded:
      ghostscript kali-linux-full libgs9 libgs9-common libjavascriptcoregtk-1.0-0
      libjavascriptcoregtk-3.0-0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0
    8 upgraded, 3 newly installed, 4 to remove and 0 not upgraded.
    Need to get 111 MB of archives.
    After this operation, 7,378 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    Get:1 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libwebkitgtk-1.0-0 amd64 2.4.10-1 [8,042 kB]
    Get:2 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libjavascriptcoregtk-1.0-0 amd64 2.4.10-1 [1,969 kB]
    Get:3 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libwebkitgtk-3.0-0 amd64 2.4.10-1 [8,040 kB]
    Get:4 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libjavascriptcoregtk-3.0-0 amd64 2.4.10-1 [1,968 kB]
    Get:5 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 kali-linux-full amd64 2016.2.3 [7,620 B]
    Get:6 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/non-free amd64 maltegoce all 3.6.1.7809-0kali3 [84.0 MB]
    Get:7 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 fonts-droid-fallback all 1:6.0.1r16-1 [1,806 kB]
    Get:8 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 fonts-noto-mono all 20160116-1 [76.1 kB]
    Get:9 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 ghostscript amd64 9.19~dfsg-1 [94.9 kB]
    Get:10 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libgs9 amd64 9.19~dfsg-1 [2,065 kB]
    Get:11 http://ftp.halifax.rwth-aachen.de/kali kali-rolling/main amd64 libgs9-common all 9.19~dfsg-1 [3,032 kB]
    Fetched 111 MB in 51s (2,148 kB/s)                                             
    Reading changelogs... Done
    (Reading database ... 320811 files and directories currently installed.)
    Removing fonts-droid (1:4.4.4r2-7) ...
    dpkg: libwebkitgtk-1.0-common: dependency problems, but removing anyway as you requested:
     libwebkitgtk-1.0-0:amd64 depends on libwebkitgtk-1.0-common (>= 2.4.9).
    
    Removing libwebkitgtk-1.0-common (2.4.9-3) ...
    Processing triggers for fontconfig (2.11.0-6.4) ...
    (Reading database ... 320716 files and directories currently installed.)
    Preparing to unpack .../libwebkitgtk-1.0-0_2.4.10-1_amd64.deb ...
    Unpacking libwebkitgtk-1.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Preparing to unpack .../libjavascriptcoregtk-1.0-0_2.4.10-1_amd64.deb ...
    Unpacking libjavascriptcoregtk-1.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Processing triggers for libc-bin (2.22-5) ...
    dpkg: libwebkitgtk-3.0-common: dependency problems, but removing anyway as you requested:
     libwebkitgtk-3.0-0:amd64 depends on libwebkitgtk-3.0-common (>= 2.4.9).
    
    (Reading database ... 320775 files and directories currently installed.)
    Removing libwebkitgtk-3.0-common (2.4.9-3) ...
    (Reading database ... 320714 files and directories currently installed.)
    Preparing to unpack .../libwebkitgtk-3.0-0_2.4.10-1_amd64.deb ...
    Unpacking libwebkitgtk-3.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Preparing to unpack .../libjavascriptcoregtk-3.0-0_2.4.10-1_amd64.deb ...
    Unpacking libjavascriptcoregtk-3.0-0:amd64 (2.4.10-1) over (2.4.9-3) ...
    Preparing to unpack .../kali-linux-full_2016.2.3_amd64.deb ...
    Unpacking kali-linux-full (2016.2.3) over (2016.1.0) ...
    Processing triggers for libc-bin (2.22-5) ...
    dpkg: maltego: dependency problems, but removing anyway as you requested:
     maltego-teeth depends on maltego.
    
    (Reading database ... 320773 files and directories currently installed.)
    Removing maltego (3.6.1.7809-0kali2) ...
    Selecting previously unselected package maltegoce.
    (Reading database ... 319701 files and directories currently installed.)
    Preparing to unpack .../maltegoce_3.6.1.7809-0kali3_all.deb ...
    Unpacking maltegoce (3.6.1.7809-0kali3) ...
    Selecting previously unselected package fonts-droid-fallback.
    Preparing to unpack .../fonts-droid-fallback_1%3a6.0.1r16-1_all.deb ...
    Unpacking fonts-droid-fallback (1:6.0.1r16-1) ...
    Selecting previously unselected package fonts-noto-mono.
    Preparing to unpack .../fonts-noto-mono_20160116-1_all.deb ...
    Unpacking fonts-noto-mono (20160116-1) ...
    Preparing to unpack .../ghostscript_9.19~dfsg-1_amd64.deb ...
    Unpacking ghostscript (9.19~dfsg-1) over (9.16~dfsg-2) ...
    Preparing to unpack .../libgs9_9.19~dfsg-1_amd64.deb ...
    Unpacking libgs9 (9.19~dfsg-1) over (9.16~dfsg-2) ...
    Preparing to unpack .../libgs9-common_9.19~dfsg-1_all.deb ...
    Unpacking libgs9-common (9.19~dfsg-1) over (9.16~dfsg-2) ...
    Processing triggers for fontconfig (2.11.0-6.4) ...
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for libc-bin (2.22-5) ...
    Setting up libjavascriptcoregtk-1.0-0:amd64 (2.4.10-1) ...
    Setting up libwebkitgtk-1.0-0:amd64 (2.4.10-1) ...
    Setting up libjavascriptcoregtk-3.0-0:amd64 (2.4.10-1) ...
    Setting up libwebkitgtk-3.0-0:amd64 (2.4.10-1) ...
    Setting up maltegoce (3.6.1.7809-0kali3) ...
    Setting up kali-linux-full (2016.2.3) ...
    Setting up fonts-droid-fallback (1:6.0.1r16-1) ...
    Setting up fonts-noto-mono (20160116-1) ...
    Setting up libgs9-common (9.19~dfsg-1) ...
    Setting up libgs9 (9.19~dfsg-1) ...
    Setting up ghostscript (9.19~dfsg-1) ...
    Processing triggers for libc-bin (2.22-5) ...
    Input:

    Code:
    apt list --upgradable
    Output:

    Code:
    Listing... Done
    Input:

    Code:
    uname -r
    Output:

    Code:
    4.3.0-kali1-amd64
    Input:

    Code:
    reboot
    (After reboot)

    Input:

    Code:
    uname -r
    Output:

    Code:
    4.4.0-kali1-amd64
    So, this procedure has now worked for me on three separate installs pretty much the same way. But, my machines have all been 64 bit. I am not sure whether that could make any difference, but maybe that is worth looking into.

  16. #16
    Join Date
    2016-Aug
    Posts
    3
    try
    apt-cache search kernel|grep headers
    and select appropriate headers
    then do
    apt-get install linux-headers-4.9.0-kali1-all (in my case this was it) worked for me

Similar Threads

  1. Cannot find linux-headers 4.3.0-kali1-amd64
    By conan82 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-04-17, 03:10
  2. unable to locate package Linux-Headers-4.3.0-Kali1-686-pae
    By Gladiator in forum TroubleShooting Archive
    Replies: 7
    Last Post: 2016-04-09, 14:59
  3. Nvidia Driver and linux-headers-3.14-kali1-amd64 Issue
    By lillypad in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2015-03-06, 00:54

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •