Results 1 to 12 of 12

Thread: Installing Teamviewer 11 on Kali rolling x64

  1. #1
    Join Date
    2013-Feb
    Posts
    5

    Installing Teamviewer 11 on Kali rolling x64

    First some background info.

    This issue came up in the irc channel. I found it to be a strange problem as it has previously not been a problem to install on any of the versions I have used in the past.

    Firstly I am using VMware Workstation 12.0.0 build-2985596
    I am using kali-linux-2016.1-amd64.iso

    This is installed in the normal way and I have tried this both with and without VMware tools installed following http://docs.kali.org/general-use/ins...ols-kali-guest

    I have tried this method several times without any issues, but I still consider it to be a fugly method.

    With all that out of the way, please follow at your own risk. It works for me but I cannot guarantee differences in installs will not cause issues.



    Download teamviewer_11.0.53191_i386.deb

    From

    Code:
    From http://www.teamviewer.com/en/download/linux/
    Then move it to your home dir to make it easier to find.

    Then enter the following commands

    Code:
    root@KALI:~# apt-get update
    Code:
    root@KALI:~# apt-get upgrade
    Code:
    root@KALI:~# dpkg --add-architecture i386
    Code:
    root@KALI:~# apt-get update
    Now we are setup to start the real install process

    Code:
    root@KALI:~# apt-get install libc6:i386 libgcc1:i386 libasound2:i386 libfreetype6:i386 zlib1g:i386 libsm6:i386 libxdamage1:i386 libxext6:i386 libxfixes3:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386 libxinerama1:i386 graphicsmagick adwaita-icon-theme libgtk-3-0 libjpeg62-turbo libdbus-1-3 libexpat1 libfontconfig1 libjpeg62
    You WILL get a message saying:

    Code:
    The following packages have unmet dependencies:
     libjpeg62-turbo : Conflicts: libjpeg62
    E: Unable to correct problems, you have held broken packages.
    Just ignore that message

    Code:
    root@KALI:~# apt-get -f install
    Now from here is where I think it gets fugly, you will see why but I didn't see any way around it.

    Code:
    root@KALI:~# dpkg -i teamviewer_11.0.53191_i386.deb
    You will get a message saying:

    Code:
    Selecting previously unselected package teamviewer:i386.
    (Reading database ... 311652 files and directories currently installed.)
    Preparing to unpack teamviewer_11.0.53191_i386.deb ...
    Unpacking teamviewer:i386 (11.0.53191) ...
    dpkg: dependency problems prevent configuration of teamviewer:i386:
     teamviewer:i386 depends on libc6 (>= 2.4).
     teamviewer:i386 depends on libgcc1.
     teamviewer:i386 depends on libasound2.
     teamviewer:i386 depends on libdbus-1-3.
     teamviewer:i386 depends on libexpat1.
     teamviewer:i386 depends on libfontconfig1.
     teamviewer:i386 depends on libfreetype6.
     teamviewer:i386 depends on libjpeg62.
     teamviewer:i386 depends on libpng12-0.
     teamviewer:i386 depends on libsm6.
     teamviewer:i386 depends on libxdamage1.
     teamviewer:i386 depends on libxext6.
     teamviewer:i386 depends on libxfixes3.
     teamviewer:i386 depends on libxinerama1.
     teamviewer:i386 depends on libxrandr2.
     teamviewer:i386 depends on libxrender1.
     teamviewer:i386 depends on libxtst6.
     teamviewer:i386 depends on zlib1g.
    
    dpkg: error processing package teamviewer:i386 (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     teamviewer:i386
    You will notice that they are deps that should have already been installed..... but hey... lets carry on.

    Code:
    root@KALI:~# apt-get -f install
    And that's it.

    Teamviewer 11 should now be installed and can be started like this:

    From the menu Applications > Usual Applications > Internet > Teamviewer

    or from terminal by typing

    Code:
    root@KALI:~# teamviewer
    You should see output like this before the actual GUI starts if starting from the terminal

    Code:
    Init...
    XRandRWait: No value set. Using default.
    XRandRWait: Started by user.
    Checking setup...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...

    As I said, this has worked exactly as shown here several times.

    I hope it works for you too.

  2. #2
    Join Date
    2016-Apr
    Posts
    15
    Thanks for the excellent post. For those after running the instructions posted and getting "Teamviewer daemon not running" error message. Then enter teamviewer --daemon enable

  3. #3
    Join Date
    2016-Jul
    Posts
    1
    Hi
    Even after I sudo apt-get -f install, I get following error:
    Preparing to unpack teamviewer_11.0.57095_i386.deb ...
    Unpacking teamviewer:i386 (11.0.57095) ...
    dpkg: dependency problems prevent configuration of teamviewer:i386:
    teamviewer:i386 depends on libpng12-0.
    ..... looks like package libpng12-0. is nt getting installed.
    Why could this be?
    THanks
    Sharath

  4. #4
    Join Date
    2016-Mar
    Posts
    13
    i am having trouble installing as well however i was able to before i did a fresh install.. followed same instructions so i really dont know wht can be wrong



    edit: UPDATED 7/26. using my previous method will not allow you to use apt-get.


    before using apt-get -f install, open up /var/lib/dpkg/status in a texit editor ( recommend backing up before editing) . find teamviewer then find the list of dependencies. delete libpng12-0 from the list and save. now run your apt-get -f install. and continue down the rest of my list of commands if you still get a messege when starting up about no daemon running. teamviewer is now working for me and i can update computer with apt-get as well


    i think i found a fix...


    after the last apt-get -f install, instead of hitting y for yes type for no, then type in terminal ( you may have to hit y, i am not sure since i have been trying over and over to get this working and dont remember what it looked like the first time i did it, at this point for me apt-get -f install was trying to REMOVE teamviewer so i hit n fo no)
    Code:
    teamviewer --daemon enable
    Code:
    systemctl enable teamviewerd.service
    Code:
    systemctl start teamviewerd.service
    Code:
    teamviewer
    this allowed me to open up the program... i am not sure if these lines need to be used every restart and i have not tried connecting to or from the computer. this simply allowed me to open up the program
    Last edited by bmanc42; 2016-07-27 at 01:33. Reason: update

  5. #5
    Join Date
    2016-Aug
    Posts
    1
    I followed @balding_parrot instructions exactly as mentioned above and they didn't work.
    I'm running Kali 2016.1.
    When you do apt-get -f install the second time it removes Teamviewer altogether. And I chose Y and let the Teamviewer get removed.
    after that i ran installed Teamviewer again using following command
    Code:
    dpkg -i teamviewer_11.0.53191_i386.deb
    and then
    Code:
    teamviewer --daemon enable
    You can run it by running /opt/teamviewer/tv_bin/desktop/teamviewer-teamviewer11.desktop
    or from command line as simply
    Code:
    teamviewer

  6. #6
    Join Date
    2016-Aug
    Posts
    2
    hi md1hunox,
    I do it according to your approach.
    But gui does not look normal.
    Attached Images Attached Images

  7. #7
    Join Date
    2016-Sep
    Posts
    2
    download the missing packages manually
    example
    libxrandr2 for i386 and new version dowload here :
    https://packages.debian.org/stretch/...andr2/download
    and install
    run
    apt-get upgrade check packages
    install all missing packages
    and reinstall teamviewer
    sorry , my English is bad

  8. #8
    Join Date
    2016-Oct
    Posts
    2
    I have the same problem, have you solved it?

  9. #9
    Quote Originally Posted by kukudi View Post
    I have the same problem, have you solved it?
    Try using the following.

    dpkg --force-depends -i teamviewer.deb


    You will have to change teamviewer.deb to whatever the actual file name is. This is what worked for me. Hope it helps you.

  10. #10
    Join Date
    2016-Oct
    Posts
    2
    thank you, bro, it's worked

  11. #11
    Join Date
    2016-Nov
    Posts
    1
    I had to add 'deb http://ftp.de.debian.org/debian jessie main' (with no quotes) to my sources.list in order to get the libpng12-0 to install. After that, everything has been running properly with the graphical interface and everything.

  12. #12
    Join Date
    2017-Mar
    Posts
    1

    Working on vmware - Not working on MAC

    I've been following this tutorial and having the same configuration Vmware Workstation 12.0.0 build-2985596 + kali-linux-2016.2-amd64.iso I've succesfully installed teamviewer.

    However, following the exact steps on a pretty old mac having kali installed as the main and only OS with 8GB Ram and having the following configuration:

    Code:
    Architecture: x86_64
    CPU op-mode(s): 32-bit, 64-bit
    Byte Order: Little Endian
    CPU(s): 2
    On-line CPU(s) list: 0,1
    Thread(s) per core: 1
    Core(s) per socket: 2
    Socket(s): 1
    NUMA node(s): 1
    Vendor ID: GenuineIntel
    CPU family: 6
    Model: 23
    Model name: Intel(R) Core(TM)2 Duo CPU E8135 @ 2.66GHz
    Stepping: 10
    CPU MHz: 2660.000
    CPU max MHz: 2660.0000
    CPU min MHz: 1596.0000
    BogoMIPS: 5306.57
    Virtualization: VT-x
    L1d cache: 32K
    L1i cache: 32K
    L2 cache: 6144K
    NUMA node0 CPU(s): 0,1
    Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf eagerfpu pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm tpr_shadow vnmi flexpriority dtherm
    with

    Code:
    Linux version 4.6.0-kali1-amd64 (devel@kali.org) (gcc version 5.4.0 20160609 (Debian 5.4.0-6) ) #1 SMP Debian 4.6.4-1kali1 (2016-07-21)
    I get the following error when trying to start teamviewer:

    Code:
    Init...
    CheckCPU: SSE2 support: yes
    XRandRWait: No value set. Using default.
    XRandRWait: Started by user.
    Checking setup...
    /opt/teamviewer/tv_bin/script/tvw_exec_legacy: line 9: /opt/teamviewer/tv_bin/wine/bin/wineserver: No such file or directory
    /opt/teamviewer/tv_bin/script/tvw_profile_legacy: line 127: /opt/teamviewer/tv_bin/wine/bin/wine: No such file or directory
    Also tried to enable disable teamviewer daemon and using --force-depends in my installation cmd

    What I am doing wrong here?
    Last edited by astonkali; 2017-04-01 at 08:50. Reason: update

Similar Threads

  1. Need help installing WUSB6300 on Kali Rolling 2016.1
    By Blasta44 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-02-18, 12:44
  2. Issue installing OpenVPN in Kali Rolling 2.0
    By mallock in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-09-24, 20:22
  3. teamviewer dependency errors [latest kali]
    By newblet in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2015-12-23, 09:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •