Results 1 to 3 of 3

Thread: Updating Kali - "activate the APT::Force-LoopBreak option"

  1. #1
    Join Date
    2013-Jul
    Posts
    41

    Updating Kali - "activate the APT::Force-LoopBreak option"

    I'm running kali 2.0.

    I've been waiting to get around a decent network connection to update / upgrade, its been 5 months easy.

    So I do the usual ,

    Code:
    apt-get update && apt-get dist-upgrade
    which I have done hundreds of times over the years.

    Although, I've ran into an issue that googling hasn't turned up too much on this specific error .

    Code:
    E: This installation run will require temporarily removing the essential package sysvinit-utils:amd64 due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
    E: Internal Error, Could not early remove sysvinit-utils:amd64 (2)
    Once I received that error , I attempted

    Code:
    apt-get -u -o APT::Force-LoopBreak=1 dist-upgrade
    That command seemed to do absolutely nothing, It had returned

    Code:
    2895 upgraded, 596 newly installed, 169 to remove and 0 not upgraded.
    Need to get 0 B/3,640 MB of archives.
    After this operation, 1,838 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Reading changelogs... Done
    But , It did not finish the upgrade....

    any suggestions ? Since it cannot remove " sysvinit-utils:amd64 " , Should I blacklist it some how?

  2. #2
    Join Date
    2016-Mar
    Posts
    1
    Same issue here trying to go from sana to rolling. After a bit of googling I found that it looks like a new bug even for the debian team (see Debian bug 817780, Debian bug 817857 and the first report : Debian bug 817371
    In this one it is claimed that they " believe that the bug you reported is fixed in the latest version of
    util-linux, which is due to be installed in the Debian FTP archive."
    So I guess we have to wait for the kali team to add this to the rolling repo.

  3. #3
    Join Date
    2015-Oct
    Location
    Switzerland
    Posts
    33
    Hi there

    This should fix the problem:
    apt-get update && apt-get dist-upgrade -o APT::Force-LoopBreak=1
    regards, reidamaxia

    ---------------------------------------------------
    <<The quieter you become, the more you are able to hear.>>
    On Github: https://github.com/reidamaxia
    ---------------------------------------------------

Similar Threads

  1. Replies: 7
    Last Post: 2016-07-29, 15:31
  2. Kali LIVE USB: Default to "persistence" menu option?
    By nigelmercier in forum General Archive
    Replies: 1
    Last Post: 2015-01-09, 10:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •