Thank you for the help, however these steps wasn't enough for my, for some reason. It didn't appear in the media directory after configuring the share, as described in some manuals online.
I'm using 2017.3 with vbox 5.2.2.

Here're the extra steps (mounting the shared folder in the guest OS):
  1. create a folder, with whichever name you want wherever you want - this is the mountpoint
  2. mount -t vboxsf [-o OPTIONS] sharename mountpoint
  3. In order to persist the change, you need to modify /etc/fstab and add the following line: sharename /media/vbox_shared_folder vboxsf defaults 0 0


NOTE: the sharename is what you configured when you defined the folder.

See some details and different answers here.
Detailed manual from VirtualBox here.

Hope it helps anyone.