Results 1 to 1 of 1

Thread: Installing Kali Rolling on a fakeRAID0 environment. Problem with initramfs?

  1. #1
    Join Date
    2015-Oct
    Location
    Norway
    Posts
    2

    Smile Installing Kali Rolling on a fakeRAID0 environment. Problem with initramfs?

    Hi there fellow pentesters and security-auditors.
    I'm having a few issues getting Kali Rolling up-and-working on my hardware RAID-0 disks (fakeraid).
    I already have Windows 10 installed btw. And it's a GPT partition-scheme (EFI).

    When i boot the Kali Rolling distro in UEFI mode as normal, it's unable to find my RAID-setup, unless i supply the following boot-argument to Grub:
    Code:
    dmraid=true
    If i supply that argument, the whole installation procedure completes without any issue at all.

    Grub loads as normal, and it only shows my Linux-distro. (This happens often, and usually just needs a quick fix after loading linux and re-installing Grub.)
    The real problem is loading the installed Kali Rolling distro.

    When i select Kali linux from the Grub menu, the problem happens almost immediately.
    The first error message is:
    Code:
    lvmetad is not active yet using direct activation during sysinit.
    And the second is something like:
    Code:
    Unable to locate /dev/mapper/SSD_ROOT5
    After a while of looping this, it eventually hangs at BusyBox.
    Code:
    (initramfs): uname -a
    This verifies that it's the initramfs running. I can then assume Grub is working, and that it loads the initramfs-kernel correctly from my RAID-stripe.
    And that the core of the issue lies with initramfs not mounting the RAID-0 root environment correctly.

    If i try:
    Code:
    ls -l /dev/mapper/
    in the initramfs BusyBox, it just show "control". It should list my RAID-stripe aswell.

    I have also tried supplying the same argument to Grub as i did to the bootloader during the installation (dmraid=true), but it helps nothing.
    I've also tried searching for answers to this. But i'm not quite sure what to make of the whole thing.
    I cannot find out if the initramfs needs to load a raid-module (modprobe), or if raid-support needs to be built into the kernel itself.
    I figured the best thing was to just ask the community for help or pointers.

    Any takers?

    Notes:
    - fakeRAID-0
    - GPT partition-scheme/EFI.
    - Not using crypto.
    - Not using LVM.
    - Intel Raid Controller. (Z97 Gaming 6 motherboard & Intel Core i7 4790k)
    Last edited by adde88; 2016-03-12 at 11:39. Reason: spellcheck

Similar Threads

  1. Replies: 2
    Last Post: 2017-10-13, 01:09

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •