Results 1 to 7 of 7

Thread: Xplico shows no network interfaces - kali rolling 2016.1

  1. #1
    Junior Member
    Join Date
    Aug 2015
    Posts
    15

    Xplico shows no network interfaces - kali rolling 2016.1

    Hi all,

    I hope someone can help me. I googled for days with no success.
    I installed Xplico on kali rolling but when I start a live session no NICs are listed and therefore I cannot start the session.
    I tried an Ubuntu fresh install in Virtualbox and everything works as expected without having to do anything extra.
    Does anyone else have this problem? Can anyone please help me out here?

    Thank you all in advance,

    Dinos

  2. #2
    Junior Member
    Join Date
    Aug 2015
    Posts
    15
    Hi all,

    I just realized that the problem is xplico doesn't create new cases or sessions.
    I found several posts on the xplico forum suggesting to use netsniff-ng using the following procedure:

    1). /opt/xplico/script/session_mng.pyc -n testcase testsession
    and then
    2). netsniff-ng --in eth0 --out /opt/xplico/pol_1/sol_1/new --silent --jumbo-support --interval 300s

    But... the problem is that the first command gives me:

    /opt/xplico/script/session_mng.pyc -n testcase testsession
    Traceback (most recent call last):
    File "session_mng.py", line 17, in <module>
    File "/usr/lib/python3/dist-packages/psycopg2/__init__.py", line 50, in <module>
    from psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID
    ImportError: No module named 'psycopg2._psycopg'


    So I followed all the posts referring to problems with psycopg2 and I still get :

    /opt/xplico/script/session_mng.pyc
    Traceback (most recent call last):
    File "session_mng.py", line 17, in <module>
    File "/usr/lib/python3/dist-packages/psycopg2/__init__.py", line 50, in <module>
    from psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID
    ImportError: No module named 'psycopg2._psycopg'


    Does anyone else have similar problems with xplico on kali rolling?

  3. #3
    Junior Member
    Join Date
    Aug 2015
    Posts
    15
    Hi all again,

    I have spent the last few days trying to find a solution and this is what I found out.
    According to this:
    http://forum.xplico.org/viewtopic.php?f=3&t=558
    one needs "session_mng.pyc" compiled with the same version of python3 that one has on his system.
    So, I registered myself at "forum.xplico.org" in order to be able to download the file mentioned in the above post, but I still didn't get an activation e-mail from the admin of the forum.
    I find it very disappointing that xplico developers do not update such essential parts of their software when they bring out new versions ;-(
    Also, I am surprised that no one else on this forum mentions the same issue. Does no one else use Xplico here?
    Did Kali maintainers not test Xplico before putting it in the repositories?
    It is not like one can not do this job in other ways. It is just that I would like to see a great debian based distro like Kali to get even better.
    We are not supposed to put other repo's on our system in order to keep it stable and clean, but then one would expect that everything that comes in the Kali repo's works out of the box with no essentials issues. (minor bugs are of course always expected).

    Does anyone of you have the correct file for Kali rolling? I am asking because I do not know when I will get the activation e-mail from xplico so that I could download it myself.
    Feedback on this issue would be appreciated. Cheers to all of you.
    Last edited by DinoS; 2016-03-15 at 11:13 AM.

  4. #4
    Junior Member
    Join Date
    Jul 2016
    Posts
    1
    Hello everyone,

    I had problems too and am waiting for a clear solution.

    I'm slope, thank you very much .

  5. #5
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    550
    I noticed yesterday there was a new push of xplico to the Kali repos. Have you tried updating & seeing if xplico is fixed?

  6. #6
    Junior Member
    Join Date
    Sep 2016
    Posts
    1
    I would like to talk with anyone about Xplico with Kali 2.0 (2016-2) full updated to 18 May 2016.

    Xplico is not working at all in this environment

    thomas DOT tschoepke AT gmail DOT com

  7. #7
    Junior Member
    Join Date
    Dec 2014
    Posts
    13
    I would really like this to be looked at or removed. When I try to install the version from Xplico's site, it gives me dependency errors that are breaking other packages.

    Thanks for looking into this.

    This package seems like the only real time traffic analysis that puts the traffic together (I'll always love wireshark but different uses).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •