Results 1 to 5 of 5

Thread: Msfconsole error: Could not find i18n-0.7.0 in any of the sources

  1. #1
    Junior Member
    Join Date
    Mar 2016
    Posts
    3

    Msfconsole error: Could not find i18n-0.7.0 in any of the sources

    First of all, thanks to all for the hard work of developing Kali Linux Distro, Metasploit framework, other tools and scripts and maintaining this site. You guys did a good job. Keep it up.

    I have a problem with Metasploit after updating it via msfupdate just now.
    I’ve been googling around and trying the following steps as suggested but none of them work.
    Here is the information of my Kali Linux which is installed in VirtualBox and steps taken to resolve this issue. Unfortunately, it’s not working. Please let me know if I missed anything else here or if you need more info to resolve this.

    Code:
    fw@testbox:~$ uname -a
    Linux testbox 4.3.0-kali1-amd64 #1 SMP Debian 4.3.3-5kali4 (2016-01-13) x86_64 GNU/Linux
    fw@testbox:~$
    fw@testbox:~$ msfconsole
    Could not find i18n-0.7.0 in any of the sources
    Run `bundle install` to install missing gems.
    fw@testbox:~$
    fw@testbox:~$ sudo bundle install
    [sudo] password for fw:
    Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root users on this
    machine.
    Could not locate Gemfile or .bundle/ directory
    fw@testbox:~$
    fw@testbox:~$ # TEST SOLUTION FROM http://stackoverflow.com/questions/20599920/how-to-solve-could-not-find-i18n-0-6-5-in-any-of-the-sources-bundlergemnotfo 
    fw@testbox:~$ # How to solve “Could not find i18n-0.6.5 in any of the sources (Bundler::GemNotFound)” AWS deploy
    fw@testbox:~$
    fw@testbox:~$ bundle pack
    Could not locate Gemfile or .bundle/ directory
    fw@testbox:~$ bundle install --path vendor/cache
    Could not locate Gemfile or .bundle/ directory
    fw@testbox:~$
    fw@testbox:~$ sudo bundle pack
    Could not locate Gemfile
    fw@testbox:~$ sudo bundle install --path vendor/cache
    Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root users on this
    machine.
    Could not locate Gemfile
    fw@testbox:~$
    fw@testbox:~$ bundle update i18n
    Could not locate Gemfile
    fw@testbox:~$
    fw@testbox:~$ sudo find / -name Gemfile.lock
    find: ‘/run/user/1000/gvfs’: Permission denied
    /usr/lib/dradis/Gemfile.lock
    /usr/lib/dradis/vendor/bundle/ruby/2.3.0/gems/rack-test-0.6.3/Gemfile.lock
    /usr/lib/dradis/vendor/bundle/ruby/2.3.0/gems/rails-4.1.9/guides/code/getting_started/Gemfile.lock
    /usr/lib/dradis/vendor/bundle/ruby/2.3.0/gems/resque-status-0.4.3/Gemfile.lock
    /usr/lib/dradis/vendor/bundle/ruby/2.3.0/gems/sass-3.2.19/test/Gemfile.lock
    /usr/lib/dradis/vendor/bundle/ruby/2.3.0/gems/bcrypt-3.1.9/Gemfile.lock
    /usr/share/beef-xss/Gemfile.lock
    /usr/share/metasploit-framework/Gemfile.lock
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rack-test-0.6.3/Gemfile.lock
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/network_interface-0.0.1/Gemfile.lock
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/bcrypt-3.1.11/Gemfile.lock
    fw@testbox:~$
    fw@testbox:~$ cat -n /usr/lib/dradis/Gemfile.lock | grep i18n
       110        i18n (~> 0.6, >= 0.6.9)
       160      i18n (0.7.0)
    fw@testbox:~$

  2. #2
    Junior Member
    Join Date
    Mar 2016
    Posts
    1
    I tried to make bundle install by hands, installed some packets using apt-get and this helped me.
    Just do:
    Code:
    apt-get install postgresql-server-dev-all libpq-dev libpcap-dev libsqlite3-dev
    cd /usr/share/metasploit-framework/
    bundle install

  3. #3
    Junior Member
    Join Date
    Mar 2016
    Posts
    1
    I had the same problem, and after I verified my only repository source is the kali-rolling repo, I've upgraded with:
    Code:
    apt-get dist-upgrade
    After that, typing:
    Code:
    msfdb init
    successfully created the database. Then I was able to run msfconsole.

  4. #4
    Junior Member
    Join Date
    Apr 2016
    Posts
    1
    apt-get install ruby

  5. #5

    Awesome that worked!

    Quote Originally Posted by sephiroth_ View Post
    apt-get install ruby
    Reinstalling Ruby worked for me... None of the other stuff did.

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •