Results 1 to 5 of 5

Thread: Nexus 6 | MMB92S | After Updating To 3.0.5-20160321-2229, NetHunter App Gone

  1. #1

    Nexus 6 | MMB92S | After Updating To 3.0.5-20160321-2229, NetHunter App Gone

    Hi All,

    First off, apologies if I am not well versed in the following.

    After updating from nightly version 3.0.5-20160302-1926 to 3.0.5-20160321-2229, the NetHunter app no longer exists. I've spent a few hours troubleshooting and I am out of leads to chase.

    I am using the following device:
    Nexus 6 | Android 6.0.1 | Build MMB92S | shamu
    Kernel Version 3.10.40-gfaff1dd-dirty

    As suggested in other threads, I boot into TWPR and flash the device specific zip and wipe the dalvik/cache. I then confirm that the phone can still boot, then flash the generic build. The installation of the generic build completes with no errors and the phone boots as expected. When I navigate to the /data/data folder from the root directory, I see "com.offsec.nhterm" and "com.offsec.nhvnc", however I am not seeing "com.offsec.nethunter", which I am assuming is the data for the actual NetHunter app.

    Furthermore, when I attempt to run the NetHunter Terminal and select the Kali shell, the terminal instantly crashes.

    This is the first issue I've encountered updating NetHunter via the nightly releases located here: ... I highly doubt that this is an issue with anything NetHunter related, so I am thinking it might be the phone build, although I have not updated anything on the phone and I am using a stock rom. This is not a daily driver, so literally the only things installed are the NetHunter related items and whatever came with the stock ROM.

    Any help would be greatly appreciated.

    Please let me know if I can provide any additional information to assist and I'll be happy to do so.


  2. #2
    Join Date
    Flash MMB29K stock ROM . using Nexus- root- toolkit (flash + unroot)
    Note : When reboot into system - phone set up- skip all steps ,do not restore back-up from your google account. If you don't want get errors later.
    Then root the phone + flash TWPR
    Copy kali-nethunter v.3 into sdcard .
    Boot into recovery mode - install - navigate to file then flash .
    when done you can sign-in with your google and up date and install apps as your choice or up date kali-net hunter lastest app inside nethunter menu
    Hope this help.
    use MMB29K stock ROM + kali-nethunter v.3 without anyproblems
    Last edited by Duane; 2016-03-27 at 05:04. Reason: Add links

  3. #3
    Hi Duane,

    Thanks for your response. I followed the steps you provided and the Nethunter app is still not installed on the device. All of the other Nethunter apps are installed (such as cSploit, etc).

    Here is what I did:
    1) Flashed the MMB29K stock ROM
    2) Rooted the device and TWPR
    3) Flashed Nethunter v3 from SDcard

    The installation completed successfully with no errors and the device can boot normally without any issues.

    Is there anything else I can do here?


  4. #4
    Join Date
    Sorry to hear that. Make sure download kali-nethunter from here:
    And download Nexus 6 image
    Let me know then
    Do you see superSU app installed? And check if the phone root correctly ?
    Last edited by Duane; 2016-03-28 at 00:48. Reason: More info.

  5. #5
    Hi Duane,

    I performed the steps you provided again and still no app was on the device. HOWEVER, going through this process made me find a link to the Nethunter APK! I went to and grabbed the standalone Nethunter app, installed it, and the chroot was found as expected! So I'm happy to report that everything is resolved!

    Moving forward, if the app doesn't show up I'll just grab the standalone apk from the wiki.

    Thanks again!

Similar Threads

  1. Error (31) when updating NetHunter (Redmi note 4 mtk)
    By Haylenfoks in forum NetHunter General Questions
    Replies: 0
    Last Post: 2021-02-08, 10:13
  2. Nethunter 1.21 Nexus 4 and Nexus 7 2012 not complete
    By Boeli in forum NetHunter Development
    Replies: 8
    Last Post: 2020-12-31, 00:11
  3. nethunter on Nexus 6P and Nexus 5x?
    By zitstif in forum NetHunter General Questions
    Replies: 14
    Last Post: 2017-03-03, 01:20
  4. NetHunter install guide needs updating
    By hatchetaxesaw in forum Installing NetHunter
    Replies: 0
    Last Post: 2015-08-26, 16:25
  5. Replies: 4
    Last Post: 2015-01-23, 20:50

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts