Results 1 to 5 of 5

Thread: Network Interface issue with "ISO of Doom"

  1. #1
    Join Date
    2013-Mar
    Posts
    4

    Network Interface issue with "ISO of Doom"

    Has anyone run into an issue with the network interfaces not starting properly on a rolling ISO? Followed the documentation on creating the "Doom" image and it worked fine for the most part. However when I moved the ISO to a test machine to install (either fusion or workstation) eth0 doesn't come up at boot (nor does dhclient grab an IP). I have to log in, bring up eth0, then manually start ssh/openvpn. I'd like the image to be a "run it and forget it" install for the sake of customers, but I can't figure out why:

    A. eth0 isn't brought up at boot
    B. OpenVPN/SSH aren't run (though that are correctly configured in common/hooks before the ISO is created)

  2. #2
    Join Date
    2013-Mar
    Posts
    4
    I've *somewhat* fixed the issue with a quick script to echo the eth0 interface into /etc/network/interfaces and run update-rc.d on ssh and openvpn. However it still requires clients to login and run the script. Also doesn't really answer the question of WHY the eth0 interface is missing in the first place. Especially since the ISO has no issue grabbing DHCP during install.

  3. #3
    Join Date
    2016-Apr
    Posts
    3
    I'm having the same problem. I was able to get everything to work via openvpn, however using the rolling iso it creates with Vmfusion / workstation does not bring up eth0. I can log in after the fact and bring it up and use ssh/openvpn, but the point of the ISO is for a fire and forget. Did you ever solve this problem?

  4. #4
    Join Date
    2016-Apr
    Posts
    3
    After talking with steev in the #kali-linux IRC channel, he was able to track down what the issue was. Debian has a different naming scheme for interfaces with the latest release. If you checked your /etc/network/interfaces logs, you should see a differently named interface with hotswap and dhcp turned on (Mine was ens32).

    I'm assuming this is an artifact from this special naming scheme during install. You can turn this off by editing the install.cfg file (./build/kali-config/common/includes.binary/isolinux/install.cfg) on the last line, just add the following:

    net.ifnames=0

    Rebuild your iso and you should get eth0 up after the install.

  5. #5
    Join Date
    2016-Apr
    Posts
    3
    Figured out the issue regarding the services not starting up at boot (ssh and openvpn). In the instructions, you create your own chroot hook under build/kali-config/common/hooks/, however I always got an error: "File or directory could not be found".

    I noticed that the kali-hacks were executing properly, so I just tagged on the bottom of the script:

    "update-rc.d openvpn enable
    update-rc.d ssh enable"

    That seemed to work when I rebuilt the ISO. Not sure why the regular scripts weren't working, but this solved the issue for me.

Similar Threads

  1. Need advice on "Live" versus "Installed" custom builds
    By malakaldayook in forum Building Archive
    Replies: 3
    Last Post: 2017-10-03, 08:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •