I'm following this set of instructions: https://citruspi.io/kali-on-chromebook/ which has worked for quite a few people based on the research I've done but I keep getting this error in the shell when I run sudo cgpt show /dev/sda:
WARNING: Primary GPT header is invalid
WARNING: Secondary GPT header is invalid

I am in Developer Mode.

I read another thread in the forums where someone had a similar problem, they claimed to solve it and then didn't explain what they did and haven't replied to a recent inquiry on what they did as well, so I hoping a new thread will illicit some help. I'm new to Linux so please forgive any obvious errors- I've been combing forums all over the web for several days now to try and figure this out for myself but I've just not had any luck.

I'm on a Chromebook Flip with 4G ram. I'm trying to boot Kali via usb on a Kingston 8G usb drive (formatted FAT32). I used Win32DiskImager to write the file downloaded from the Kali website: kali-2.1.2-veron.img.xz onto my Windows 7 pc. According to Win32DiskImager the write was successful. I've tried 2 separate new usb drives at this point to double check the drives weren't bad.
When I run lsblk | grep disk the computer can see the usb drive but before it lists my drives (correctly) these 2 lines precede the list:
lsblk: dm-0: failed to get device path
lsblk: dm-0: failed to get device path

and my zram0 line ends with [SWAP]. I don't know if that's an issue but I'm including it just in case.

I can't find any information on what is causing the GPT header errors and no command I've found to try and run to diagnose further can seem to get past the above error. I've tried running sudo cgpt repair /dev/sda and I get the same header error.

Just to try it, I've enabled usb boot with sudo crossystem dev_boot_usb=1 and when I try to boot into the usb at the Developer Mode startup "scary" window using Ctrl + U I just get one loud beep and nothing else happens. I tried Ctrl + L as well and I get 2 loud beeps and nothing else happens.

I have not tried downloading the Kali file directly to my Chromebook and mirroring the file to the usb via the dd command as outlined in the Kali documentation. Could there be an issue writing the file using Win32DiskImager? I have to think it's the mirror- something's wrong on the usb but I'm at a loss as to what I did wrong. It's probably something incredibly simple (hopefully) but I'm so green I'm overlooking it. Any advice to this newbie would be much appreciated! Thank you in advance.