Results 1 to 6 of 6

Thread: Unable to locate package linux-headers-4.3.0-kalil-686-pae

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date

    Unable to locate package linux-headers-4.3.0-kalil-686-pae


    I'm trying to install the linux headers for my system and I'm unable to locate the specific package. I read that if I input the following command:
    apt-get install linux-headers-$(uname -r)
    then the headers should be installed correctly. However, it seems it's unable to find the package associated with my system:

    E: Unable to locate package by 'linux-headers-4.3.0-kalil-686-pae'
    E: Couldn't find any package by glob 'linux-headers-4.3.0-kalil-686-pae'
    E: Couldn't find any package by regex 'linux-headers-4.3.0-kalil-686-pae'
    I am running a 32-bit Kali OS from a live usb with persistence. I have fully upgraded by system (then restarted it) by running:
    apt-get update && apt-get full-upgrade
    I have verified that their are no available packages left by running
    apt list --upgradeable
    which returns "Listing... Done".

    I have not modified my source list either, here's the sources.list:

    deb kali-rolling main contrib non-free
    deb-src kali-rolling main contrib non-free
    I have tried looking out other threads on the forum about this issue, see this and this, yet the suggestions haven't worked.

    Any suggestions or comments on how to fix this are greatly appreciated, thank you!
    Last edited by Farenheit451; 2016-04-18 at 02:49.

Similar Threads

  1. Unable to locate package linux-headers-3.4.67
    By goaismine in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-03-13, 08:37
  2. Replies: 2
    Last Post: 2015-07-09, 20:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts