Results 1 to 44 of 44

Thread: No sound, how to start pulseaudio on startup ?

  1. #1
    Join Date
    2013-Apr
    Posts
    9

    No sound, how to start pulseaudio on startup ?

    Hey,

    After updating to the rolling distribution there is no sound.

    I can get sound if I run pulseaudio in terminal.

    How can you start it automatically on startup ?

  2. #2
    Join Date
    2016-Jan
    Posts
    17
    1. Turn on Kali Linux, open terminal and type in sudo killall pulseaudio and hit enter. Now type next.

    sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol

    and again hit enter.
    2. Continue typing and now type rm ~/ .pulse-cookie , after that type rm -r ~/ .pulse and after this type next.

    sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0

    and at last type apt-get install kmix and hit enter.
    3. And now restart machine.
    4. OK now again open terminal and start typing on terminal and type next apt-get install pulseaudio and hit enter and and last type apt-get install gnome-core and again hit enter.
    5. Restart machine.
    Now you can see the result, all works great, problem solved

  3. #3
    Join Date
    2015-Sep
    Posts
    1
    Hello all,

    I have same problem as kvadrat and I had followed the steps given by deanMKD1 (thank you!)

    However I got this problem in the last step:

    apt-get install gnome-core

    The following packages have unmet dependencies:
    gnome-core : Depends: firefox-esr (>= 30) but it is not going to be installed or
    firefox (>= 30)
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



    When I do apt-get -f install I got the following error:

    root@msi:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following additional packages will be installed:
    firefox-esr
    Suggested packages:
    fonts-stix | otf-stix mozplugger libgnomeui-0
    The following NEW packages will be installed:
    firefox-esr
    0 upgraded, 1 newly installed, 0 to remove and 59 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/41.6 MB of archives.
    After this operation, 93.6 MB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    (Reading database ... 408830 files and directories currently installed.)
    Preparing to unpack .../firefox-esr_45.0.2esr-1_amd64.deb ...
    dpkg-divert: error: 'diversion of /usr/bin/firefox to /usr/bin/firefox.real by firefox-esr' clashes with 'diversion of /usr/bin/firefox to /usr/bin/firefox.ubuntu by firefox-mozilla-build'
    dpkg: error processing archive /var/cache/apt/archives/firefox-esr_45.0.2esr-1_amd64.deb (--unpack):
    subprocess new pre-installation script returned error exit status 2
    Errors were encountered while processing:
    /var/cache/apt/archives/firefox-esr_45.0.2esr-1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    I cannot install firefox-esr and it seems I need to do so. Conclusion is that I still have to run pulseaudio from command line everytime I need sound.


    Help or any suggestion would be much apreciated

    Thanks in advance

  4. #4
    Join Date
    2016-Jan
    Posts
    17
    Paste this is Terminal:

    Code:
    apt-get install alsa-utils -y
    reboot, and coustomize Pulse Audio to your preferences. Now PulseAudio will start with every start on Kali.

  5. #5
    Join Date
    2013-Apr
    Posts
    9
    Hey,

    Did this

    Quote Originally Posted by deanMKD1 View Post
    1. Turn on Kali Linux, open terminal and type in sudo killall pulseaudio and hit enter. Now type next.

    sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol

    and again hit enter.
    2. Continue typing and now type rm ~/ .pulse-cookie , after that type rm -r ~/ .pulse and after this type next.

    sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0

    and at last type apt-get install kmix and hit enter.
    3. And now restart machine.
    4. OK now again open terminal and start typing on terminal and type next apt-get install pulseaudio and hit enter and and last type apt-get install gnome-core and again hit enter.
    5. Restart machine.
    Now you can see the result, all works great, problem solved
    Now sound seems to be working (thanks),
    but it deleted my settings like keyboard shortcuts and the only file I had on my desktop and in my Home folder (10/10, would do again),
    it might have been step 2 that did that.

  6. #6
    Join Date
    2013-Mar
    Location
    Kernel
    Posts
    1
    didn't the the @deanMKD1's solution as purging pulseaudio was deleting desktop and other packages as well.
    Instead, i did a little hack to bypass this problem, i just added a small snippet to my .bashrc file as terminal is the first thing i usually open after the boot.
    You can just add:
    Code:
    pulseaudio -D
    at the end of .bashrc, and it should work. I just went slightly overboard and did this, works fine:
    Code:
    #Pulseaudio with terminal startup
    until [[ `ps aux | grep "pulseaudio -D" | grep -v grep | wc -l` -eq 1 ]]
    do
    	pulseaudio -D >/dev/null 2>&1
    	if [[ `ps aux | grep "pulseaudio -D" | grep -v grep | wc -l` -gt 1 ]]
    	then
    		kill -9 `pidof pulseaudio`
    		pulseaudio -D
    	fi
    done
    "The quieter you become,
    the more you are able to hear..."

  7. #7
    Join Date
    2013-Jun
    Posts
    3
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    Last edited by null; 2016-09-15 at 17:30.

  8. #8
    Join Date
    2016-Sep
    Posts
    1
    Quote Originally Posted by null View Post
    run this command in your terminal: curl -s https://raw.githubusercontent.com/nu.../pulseaudio.sh | bash
    Have fun and Best Regards
    Thanks for this solution!!

    Quote Originally Posted by deanMKD1 View Post
    1. Turn on Kali Linux, open terminal and type in sudo killall pulseaudio and hit enter. Now type next.

    sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol

    and again hit enter.
    2. Continue typing and now type rm ~/ .pulse-cookie , after that type rm -r ~/ .pulse and after this type next.

    sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0

    and at last type apt-get install kmix and hit enter.
    3. And now restart machine.
    4. OK now again open terminal and start typing on terminal and type next apt-get install pulseaudio and hit enter and and last type apt-get install gnome-core and again hit enter.
    5. Restart machine.
    Now you can see the result, all works great, problem solved

    Don't do that!!
    it'll delete important things from Kali Linux, it screwed my terminal up, removed some packages, and I had to reinstall the system.
    Last edited by maiki; 2016-09-15 at 08:17. Reason: Merge posts

  9. #9
    Join Date
    2016-Sep
    Posts
    2
    I solved paste this in terminal:

    systemctl --user enable pulseaudio && systemctl --user start pulseaudio

  10. #10
    Join Date
    2013-Jun
    Posts
    3
    Quote Originally Posted by hanucann View Post
    I solved paste this in terminal:

    systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    Did you know how to read?
    Job for pulseaudio.service failed because the control process exited with error code.
    See "systemctl status pulseaudio.service" and "journalctl -xe" for details.

  11. #11
    Join Date
    2016-Jul
    Posts
    3

    Cool

    This works fine!
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.

  12. #12
    Join Date
    2016-Aug
    Posts
    2
    Quote Originally Posted by hanucann View Post
    I solved paste this in terminal:

    systemctl --user enable pulseaudio && systemctl --user start pulseaudio
    well done, its works by my, just simple thing to use it

  13. #13
    Join Date
    2016-Sep
    Posts
    1
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    Works fine, many thanks.

    X.

  14. #14
    Join Date
    2016-Sep
    Posts
    2
    Quote Originally Posted by Xeno View Post
    Works fine, many thanks.

    X.
    :~# curl -s https://raw.githubusercontent.com/nu.../pulseaudio.sh | bash

    yes it work , just before do it run :~# apt-get install curl

  15. #15
    Join Date
    2016-Sep
    Posts
    2
    So for me worked : sudo apt-get install libasound2 alsa-utils alsa-oss .... after install > alsamixer

    Than put Speaker and Main on 100

  16. #16
    Join Date
    2015-Aug
    Posts
    19
    Quote Originally Posted by gtfovinny View Post
    Thanks for this solution!!




    Don't do that!!
    it'll delete important things from Kali Linux, it screwed my terminal up, removed some packages, and I had to reinstall the system.
    Yes It actually will remove the kali system and will have problem in our Graphical Interface. I want to know why is that?

  17. #17
    Join Date
    2013-May
    Posts
    20
    I've tried most of the stuff suggested here. Audio is still not working. I don't Debian people will ever get their $*&t together on audio.
    1 sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol
    2 rm -r ~/ .pulse
    3 sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0
    4 restart now
    5 shutdown -r now
    6 apt-get udpate
    7 apt-get update
    8 apt-get install -y pulseaudio gnome-core
    9 cd bin
    10 cd /bin
    11 rm pulse
    12 rm ./pulse
    13 shutdown -r now
    14 apt-get install -y alsa-utils
    15 alsamixer
    16 pulseaudio -D
    17 systemctl --user enable pulseaudio && systemctl --user start pulseaudio

  18. #18
    Join Date
    2016-Mar
    Location
    Berlin
    Posts
    2
    Quote Originally Posted by Sudo_Root View Post
    well done, its works by my, just simple thing to use it
    It work for me too!

  19. #19
    Join Date
    2016-Oct
    Posts
    1
    Thanks problem solved be blessed null

  20. #20
    Hi Kali Linux,

    this worked for me thanks,

    MajorLinuxNoob

  21. #21
    Join Date
    2016-Nov
    Posts
    1
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    It worked for me...Thank you very much

  22. #22
    Join Date
    2016-Nov
    Posts
    1
    to fix the problems :
    apt-get install pulseaudio
    pulseaudio --start

  23. #23
    Join Date
    2016-Dec
    Posts
    1

    Red face i love you

    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    thank you very much!! it solved the problem!!

  24. #24
    Join Date
    2016-Dec
    Posts
    1
    Quote Originally Posted by kvadrat View Post
    Hey,

    Did this



    Now sound seems to be working (thanks),
    but it deleted my settings like keyboard shortcuts and the only file I had on my desktop and in my Home folder (10/10, would do again),
    it might have been step 2 that did that.
    Did you sble to fix the deleted setting if its yes help me please i did the same all my files got deleted

  25. #25
    Join Date
    2016-Dec
    Posts
    1
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    Thanks for this solution!

  26. #26
    Join Date
    2015-Apr
    Posts
    18
    ORIGINAL POST =)


    run this command in your terminal:

    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash

    NOTE: This program is using only with "root" user!
    Have fun and Best Regards.

  27. #27
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by caos420 View Post
    thank you very much!! it solved the problem!!
    welcome, my friend =)
    -----------------------------------
    I hope to help on those who want.
    Last edited by nu11secur1ty; 2016-12-10 at 12:37.

  28. #28
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by star5rick View Post
    Thanks problem solved be blessed null
    Thank you, buddy. =)

  29. #29
    Join Date
    2016-Dec
    Posts
    1
    Thank you so much!!

  30. #30
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by ankur View Post
    Thank you so much!!
    You welcome, my friend.

  31. #31
    Join Date
    2015-Jul
    Posts
    13
    Thanks guys, I skipped over that really long thing deanMKD1 put because of the deleting of important things. I one of the other things you guys put, and now my sound works! I love the xfce Kali 2016.2, but my sound wasn't working. With the original Kali install I have never had any issues with wifi, sound or blue-tooth. But I went to try LXDE my wifi kept dropping out randomly, then I started trying xfce which I absolutely love, but my sound wouldn't work. Now it does, thanks all!

  32. #32
    Join Date
    2016-Dec
    Location
    Medan - Indonesia
    Posts
    1
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    i love you man

  33. #33
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by DarkMuerte View Post
    i love you man
    You welcome, my friend

  34. #34
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by sgtkeebler View Post
    Thanks guys, I skipped over that really long thing deanMKD1 put because of the deleting of important things. I one of the other things you guys put, and now my sound works! I love the xfce Kali 2016.2, but my sound wasn't working. With the original Kali install I have never had any issues with wifi, sound or blue-tooth. But I went to try LXDE my wifi kept dropping out randomly, then I started trying xfce which I absolutely love, but my sound wouldn't work. Now it does, thanks all!

    Dear, This is not a Windows ok! You have to read a lot about Linux, to understand what actually is important on some distro, and what is not!
    Last edited by nu11secur1ty; 2017-01-20 at 16:21.

  35. #35
    Join Date
    2017-Jan
    Posts
    5
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    wonderful!

  36. #36
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by caos420 View Post
    thank you very much!! it solved the problem!!
    You welcome

    Quote Originally Posted by DarkMuerte View Post
    i love you man
    You welcome
    Last edited by maiki; 2017-03-02 at 12:32. Reason: Merge posts

  37. #37
    Join Date
    2017-May
    Posts
    1
    Quote Originally Posted by null View Post
    run this command in your terminal:
    Code:
    curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash
    Have fun and Best Regards.
    the best, he works for me. thanks

  38. #38
    Join Date
    2017-Jun
    Posts
    1
    Quote Originally Posted by deanMKD1 View Post
    1. Turn on Kali Linux, open terminal and type in sudo killall pulseaudio and hit enter. Now type next.

    sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol

    and again hit enter.
    2. Continue typing and now type rm ~/ .pulse-cookie , after that type rm -r ~/ .pulse and after this type next.

    sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0

    and at last type apt-get install kmix and hit enter.
    3. And now restart machine.
    4. OK now again open terminal and start typing on terminal and type next apt-get install pulseaudio and hit enter and and last type apt-get install gnome-core and again hit enter.
    5. Restart machine.
    Now you can see the result, all works great, problem solved
    hey everyone, don't do what this user said. it will send your linux to stone age and delete your personal files. i am not sure why his post is still there. like a bait waiting for users to click it.

  39. #39
    Join Date
    2017-Jun
    Posts
    1
    Thanks. After doing some other stuff, I issued your terminal command and it worked!

    My history:
    >I installed Kali Linux 2017.1 on a bootable USB 3.0 flash drive.
    >Kali had no sound and no network manager.
    >Later at a library, Kali recognized my Ethernet connection.
    >Using apt-get, I installed Synaptic.
    >Using Synaptic, I installed Wicd network manager and Mousepad text editor.
    >A huge update using Synaptic ended abruptly (probably my error, a "control C").
    >At the next session I was advised there were broken packages, I followed the instructions:

    >MESSAGE FROM SYNAPTIC:
    "E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    After running dpkg, I continued the Synaptic update: I used "Edit/Fix Broken Packages", and "Settings/Filters/Broken".
    The update successfully morphed my system up to Kali Linux 2017.2.

    >Next, over a few short sessions I did more updates and also installed:
    Konsole, PcManFm, Dolphin, Gedit, and Chromium.
    Need to install Sublime Text 3.

    >I mistakenly thought that Pulse Audio was installed. It wasn't.
    There did exist a folder called "/etc/pulse/" which contained the single file called "client.conf"

    >TO CURE NO SOUND CONTROL IN PANEL AND NO SOUND:
    ->two lines in etc/pulse/client.conf:
    ; auto-connect-localhost = no
    ; auto-connect-display = no
    changed the lines to
    auto-connect-localhost = yes
    auto-connect-display = yes

    >PER advice at: https://ubuntu-mate.community/t/volu...ol-gone/2363/2
    I installed
    ->PAMAN package (Pulse Audio Manager)
    ->PASYSTRAY (Pulse Audio)

    >Still no sound

    >Finally, I used Synaptic to search for PulseAudio. Synaptic advised that PulseAudio was _NOT_ installed.
    Using Synaptic, I installed PulseAudio.

    >Still no sound.

    >I applied your terminal command as follows:
    ==ENTERED TERMINAL COMMAND FOUND AT KALI LINUX FORUM:
    root@kali:~# systemctl --user enable pulseaudio && systemctl --user start pulseaudio

    ==RESULT:
    Created symlink /root/.config/systemd/user/default.target.wants/pulseaudio.service -> /usr/lib/systemd/user/pulseaudio.se

    Created symlink /root/.config/systemd/user/sockets.target.wants/pulseaudio.socket -> /usr/lib/systemd/user/pulseaudio.soc

    >Finally, there is sound. Now I can take the Kali online tutorials.

  40. #40
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by coder25 View Post
    Thanks. After doing some other stuff, I issued your terminal command and it worked!

    My history:
    >I installed Kali Linux 2017.1 on a bootable USB 3.0 flash drive.
    >Kali had no sound and no network manager.
    >Later at a library, Kali recognized my Ethernet connection.
    >Using apt-get, I installed Synaptic.
    >Using Synaptic, I installed Wicd network manager and Mousepad text editor.
    >A huge update using Synaptic ended abruptly (probably my error, a "control C").
    >At the next session I was advised there were broken packages, I followed the instructions:

    >MESSAGE FROM SYNAPTIC:
    "E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    After running dpkg, I continued the Synaptic update: I used "Edit/Fix Broken Packages", and "Settings/Filters/Broken".
    The update successfully morphed my system up to Kali Linux 2017.2.

    >Next, over a few short sessions I did more updates and also installed:
    Konsole, PcManFm, Dolphin, Gedit, and Chromium.
    Need to install Sublime Text 3.

    >I mistakenly thought that Pulse Audio was installed. It wasn't.
    There did exist a folder called "/etc/pulse/" which contained the single file called "client.conf"

    >TO CURE NO SOUND CONTROL IN PANEL AND NO SOUND:
    ->two lines in etc/pulse/client.conf:
    ; auto-connect-localhost = no
    ; auto-connect-display = no
    changed the lines to
    auto-connect-localhost = yes
    auto-connect-display = yes

    >PER advice at: https://ubuntu-mate.community/t/volu...ol-gone/2363/2
    I installed
    ->PAMAN package (Pulse Audio Manager)
    ->PASYSTRAY (Pulse Audio)

    >Still no sound

    >Finally, I used Synaptic to search for PulseAudio. Synaptic advised that PulseAudio was _NOT_ installed.
    Using Synaptic, I installed PulseAudio.

    >Still no sound.

    >I applied your terminal command as follows:
    ==ENTERED TERMINAL COMMAND FOUND AT KALI LINUX FORUM:
    root@kali:~# systemctl --user enable pulseaudio && systemctl --user start pulseaudio

    ==RESULT:
    Created symlink /root/.config/systemd/user/default.target.wants/pulseaudio.service -> /usr/lib/systemd/user/pulseaudio.se

    Created symlink /root/.config/systemd/user/sockets.target.wants/pulseaudio.socket -> /usr/lib/systemd/user/pulseaudio.soc

    >Finally, there is sound. Now I can take the Kali online tutorials.
    You welcome buddy.
    This is the rule of the "systemD" and actually, you don't need from, sound - especially on this OS.
    I take decision to write this script because somehow someone wants to listen to little music sometime

  41. #41
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by star5rick View Post
    Thanks problem solved be blessed null
    You, welcome =)

  42. #42
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by frank082 View Post
    wonderful!
    You, welcome =)

  43. #43
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by xtreeme View Post
    the best, he works for me. thanks
    You, welcome =)

  44. #44
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by FrancisKym View Post
    This works fine!
    You, welcome =)

Similar Threads

  1. Problem with Pulseaudio
    By BlueNote in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-03-20, 18:04
  2. Kali Rolling - pulseaudio (sound) does not autostart
    By canadianbacon22 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-03-12, 14:42
  3. Help Fixing pulseaudio install
    By Reality-Labs in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-09-28, 04:04
  4. Sound Problem - PulseAudio + vlc distortion, skype microphone.
    By DarkSoftDarkova in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-03-23, 00:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •