Results 1 to 6 of 6

Thread: Resolution change fails on ESXi 6.0 VM

  1. #1
    Join Date

    Resolution change fails on ESXi 6.0 VM

    I just installed a fresh VM using the 2016.1 ISO on my ESXi 6.0 server.
    I've installed open-vm-tools, but any time I try to change my resolution to anything in a 4:3 ratio it stalls for a minute then drops back to 800x600. If I try to change to any other ratios I lose my video and have to reset the VM. I'm seeing similar posts for others for VirtualBox, I've come up with nothing for ESXi.

    I have a Kali 2.0 box that's running on the same server at 1360x768, with no issues.

    Any help would be appreciated.

  2. #2
    Join Date
    Just in case anyone else has an issue with this. The fix was to increase the amount of video RAM available to the VM. It defaults to 4MB, I expanded to 32MB and was able to use whatever resolution I choose.

  3. #3
    Join Date
    Screen resizeing stooped working for me after a "apt-get update && apt-get dist-upgrade && apt autoremove && apt-get autoclean", these are the updated packages:
    Start-Date: 2017-08-17  11:32:10
    Commandline: apt-get dist-upgrade
    Upgrade: gnome-session:amd64 (3.22.3-1, 3.24.1-2), libout123-0:amd64 (1.25.4-1, 1.25.6-1), gnome-session-common:amd64 (3.22.3-1, 3.24.1-2), osinfo-db:amd64 (0.20170707-2, 0.20170811-1), libgxps2:amd64 (0.2.5-1, 0.3.0-1), libaprutil1:amd64 (1.6.0-1, 1.6.0-2), libpsl5:amd64 (0.17.0-5, 0.18.0-2), libaprutil1-dbd-sqlite3:amd64 (1.6.0-1, 1.6.0-2), gnome-settings-daemon:amd64 (3.22.2-5, 3.24.3-1), gdm3:amd64 (3.22.3-4, 3.24.2-3), gir1.2-gdm-1.0:amd64 (3.22.3-4, 3.24.2-3), libgdm1:amd64 (3.22.3-4, 3.24.2-3), libaprutil1-ldap:amd64 (1.6.0-1, 1.6.0-2), libmpg123-0:amd64 (1.25.4-1, 1.25.6-1), libcupsfilters1:amd64 (1.16.0-2, 1.16.1-1), gnome-shell-extensions:amd64 (3.22.2-1kali1, 3.22.2-2kali1), gnome-session-bin:amd64 (3.22.3-1, 3.24.1-2), ruby-nokogiri:amd64 (, 1.8.0-1), mpg123:amd64 (1.25.4-1, 1.25.6-1), sensible-utils:amd64 (0.0.9+nmu1, 0.0.10)
    End-Date: 2017-08-17  11:32:21
    This is the output of "ps -aux | grep vm"
    root        465  0.0  0.2 209636 10832 ?        Ssl  11:56   0:02 /usr/bin/vmtoolsd
    root       1367  0.1  0.6 258348 27200 tty2     S+   11:56   0:02 /usr/bin/vmtoolsd -n vmusr
    root       6418  0.0  0.0  12724   964 pts/0    S+   12:33   0:00 grep vm
    and the output of "lsof -p 1367 | grep libresolution"
    vmtoolsd 1367 root  mem       REG                8,1    27408 3286757 /usr/lib/open-vm-tools/plugins/vmusr/
    I originally installed open-vm-tools with: "apt-get install fuse open-vm-tools-desktop" and coping and pasting still work. Any ideas?

  4. #4
    Join Date
    I've posted this as a bug for now, see:

    You can change the resolution with the 'Displays' application to at least get a usable desktop for now.

  5. #5
    Join Date
    I found a solution in a comment by radualexandrupopescu for a duplicate bug:

    set WaylandEnable=false under [daemon] section of /etc/gdm3/daemon.conf

  6. #6
    Join Date
    I did an apt full-upgrade yesterday after open-vm-tools-desktop-2:10.1.10-1kali1 came out and still had the issue.

    Today did another full-upgrade which updated some kernel stuff and now I have the resolution issue and now when I type there is a delay. It seems like sometimes I have to move the mouse in order for it to catch up. Also, now if I try to change the resolution manually, it appears to crash and reload the login screen.

    I tried the WaylandEnable=false workaround but when I set that I'm unable to login at all; the desktop starts to load then it goes back to the login screen.

    Also, I've tried creating a bug tracker account with two different emails (different email providers) but I didn't get the activation email in either case so I'm unable to contribute to the existing bugs.

    Running VMware Workstation 12 Pro 12.5.7 build-5813279. The VM is setup like it has always been: accelerate 3D graphics enabled, use host setting for monitors, 32 MB of graphics memory.

    Current packages installed:
    open-vm-tools/kali-rolling,now 2:10.1.10-1kali1 amd64 [installed]
    open-vm-tools-desktop/kali-rolling,now 2:10.1.10-1kali1 amd64 [installed]
    linux-base/kali-rolling,now 4.5 all [installed,automatic]
    linux-headers-4.12.0-kali1-amd64/kali-rolling,now 4.12.6-1kali1 amd64 [installed]
    linux-headers-4.12.0-kali1-common/kali-rolling,now 4.12.6-1kali1 all [installed,automatic]
    linux-image-4.11.0-kali1-amd64/now 4.11.6-1kali1 amd64 [installed,local]
    linux-image-4.12.0-kali1-amd64/kali-rolling,now 4.12.6-1kali1 amd64 [installed,automatic]
    linux-image-amd64/kali-rolling,now 4.12+84+kali1 amd64 [installed]
    linux-kbuild-4.12/kali-rolling,now 4.12.6-1kali1 amd64 [installed,automatic]
    linux-libc-dev/kali-rolling,now 4.12.6-1kali1 amd64 [installed,automatic]
    gnome-core/kali-rolling,now 1:3.22+3 amd64 [installed,automatic]
    gdm3/kali-rolling,now 3.24.2-3 amd64 [installed,automatic]
    xserver-common/kali-rolling,now 2:1.19.3-2 all [installed,automatic]
    xserver-xephyr/kali-rolling,now 2:1.19.3-2 amd64 [installed,automatic]
    xserver-xorg/kali-rolling,now 1:7.7+19 amd64 [installed,automatic]
    xserver-xorg-core/kali-rolling,now 2:1.19.3-2 amd64 [installed,automatic]
    xserver-xorg-input-all/kali-rolling,now 1:7.7+19 amd64 [installed,automatic]
    xserver-xorg-input-libinput/kali-rolling,now 0.23.0-2 amd64 [installed,automatic]
    xserver-xorg-input-wacom/kali-rolling,now amd64 [installed,automatic]
    xserver-xorg-legacy/kali-rolling,now 2:1.19.3-2 amd64 [installed,automatic]
    xserver-xorg-video-all/kali-rolling,now 1:7.7+19 amd64 [installed,automatic]
    xserver-xorg-video-amdgpu/kali-rolling,now 1.3.0-1 amd64 [installed,automatic]
    xserver-xorg-video-ati/kali-rolling,now 1:7.9.0-1 amd64 [installed,automatic]
    xserver-xorg-video-fbdev/kali-rolling,now 1:0.4.4-1+b5 amd64 [installed,automatic]
    xserver-xorg-video-intel/kali-rolling,now 2:2.99.917+git20161206-1 amd64 [installed,automatic]
    xserver-xorg-video-nouveau/kali-rolling,now 1:1.0.15-2 amd64 [installed,automatic]
    xserver-xorg-video-qxl/kali-rolling,now 0.1.5-2 amd64 [installed,automatic]
    xserver-xorg-video-radeon/kali-rolling,now 1:7.9.0-1 amd64 [installed,automatic]
    xserver-xorg-video-vesa/kali-rolling,now 1:2.3.4-1+b2 amd64 [installed,automatic]
    xserver-xorg-video-vmware/kali-rolling,now 1:13.2.1-1+b1 amd64 [installed,automatic]
    xwayland/kali-rolling,now 2:1.19.3-2 amd64 [installed,automatic]

Similar Threads

  1. Cannot change resolution
    By Contal in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-06-11, 18:14
  2. Can't change resolution on Odroid-C1
    By ChangesCome in forum ARM Archive
    Replies: 0
    Last Post: 2015-12-05, 00:10
  3. Replies: 1
    Last Post: 2015-08-28, 06:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts