Results 1 to 4 of 4

Thread: 2016.1 Shutdown freezing/hangs

  1. #1
    Join Date

    2016.1 Shutdown freezing/hangs

    Hey Guys,
    I've browsed through loads of forum posts (on Kali, Ubuntu and Debian) It seems this issue is spread across multiple linux distros not just Kali.
    I'm using Kali 2016.1 Rolling x64 on a HP Envy m6 (8GB Ram, 300GB HDD, AMD A10-5750M APU with Radeon HD Graphics)

    Each time I press the GUI restart or power off buttons whilst logged in, it just hangs, the mouse disappears, applications are left open (tried closing them first too) and all that is left to do is hold the power switch and force it off (not good) There is a work around I am using the in mean time, which is to LOG off then power off. This works but sometimes I forget to do this and then facepalm myself lol

    Rather than posting onto other peoples threads I've decided to make my own as my machine does not have an nVidea graphics card (whereas most other people's do by the looks of it)

    I have tried with no luck:
    • Run these separately: Apt-get update, apt-get upgrade, apt-get dist-upgrade
    • GRUB_CMDLINE_LINUX_DEFAULT="quiet" to "reboot=bios quiet" in grub and 10linux file (followed by "update-grub")
    • Different reboot kernel parameters (bios, pci, acpi)
    • "Halt -p" from terminal
    • "Shutdown -h 0" from terminal
    • Added nomodset in grub
    • Added "blacklist snd-hda-intel" to modprobe.d/intel-microcode-blacklist.conf
    • Added "blacklist snd_hda_codec_hdmi" to modprobe.d/intel-microcode-blacklist.conf
    • Added "options snd-hda-intel model=auto" to a new file modprobe.d/alsa-base.conf
    • Added "blacklist nouveau" to modprobe.d/nouveau-blacklist.conf
    • Run "apt-get install libcuda1 libnvidia-ml1 --no-install-recommends -y" after Blacklist nouveau

    Like I mentioned, It's an AMD graphics card so I've not tried any fixes that change nVidea drivers (bit pointless)

    I'm only a beginner and I'm getting a little fed up with it, so this is my disheartened plea for help. HEEEELP PLEASE OH GREAT KALI WIZARDS.

    OR, can anyone point me to a previous Kali Distro I can download? I've given up searching the internet.

  2. #2
    Join Date
    I add myself to this, installed Kali on the latest Macbook with AMD card and the issue persists with every solution described above.
    Anyone got any idea on how to fix this?

  3. #3
    Join Date
    I had the same problem not just with Kali but with Ubuntu as well. In my case it was a bios setting that was causing the hang. I disabled xHCI controller and now it works perfectly.

  4. #4
    Join Date
    Hello everyone.

    I've been trying to fix that same problem for five days now. Reading every possible post I could find, I'm still nowhere near solution.
    The weird thing is, using different grub-configurations - as mentioned in the original post, I've managed to successfully reboot my machine a couple of times.
    However, after a second reboot, using the same configuration, the reboot once again failed and got me stuck with a black screen.
    I know you have to reboot twice to see if the grub-changes work, yet every configuration seemed to work only once.

    Sometimes stopping my bluetooth service let me reboot properly, sometimes logging off before shutting down/rebooting was the solution.
    I'm a Linux newbie, so I find it really hard to tell what could cause that problem and like I said, not a single suggestion on the internet would lead me to the right path it seems.
    This is getting so frustrating. If anyone reading this found a solution, PLEASE let us know. I really hate strangling my machine everytime just to shut it down or reboot.

    To my specs:
    I'm using a Lenovo B50-10 laptop with an Intel Pentium N3540 CPU, 8GB RAM and an Intel graphics card.
    Also I'm using dual boot with Windows 7 Pro x64 and Kali Linux 2016.1 x64
    What else could be of importance here?

    To the grub setting I've tried:
    GRUB_CMDLINE_LINUX_DEFAULT="reboot=bios quiet splash"
    GRUB_CMDLINE_LINUX_DEFAULT="reboot=acpi quiet splash"
    GRUB_CMDLINE_LINUX_DEFAULT="reboot=pci quiet splash"
    All of the "reboot="-setting using "nomodeset" instead of "quiet splash"
    Many more random combinations, adding things like: "acpi=force", "pci=force"
    "halt-p", "shutdown -h 0", "shutdown -h now", "init 0", "poweroff", "reboot"
    Loggin off and then rebooting/shutting down.
    Disabling some random services, like bluetooth, before rebooting/shutting down.

    Everything to no real success.. The results were so random that it felt impossible drawing any conclusions from them.
    Sometimes things worked (once or twice only), but then everything went back to normal.

    I have to admit I've tried many setting where I had no real idea of what they are exactly doing, like adding blacklisting entries.
    I basically tried EVERYTHING which seemed relative to that issue.

    Since logging off before rebooting/shutting down was the method I've had the most success with, I started experimenting with creating entries
    in the directories /etc/rc0.d/, /etc/rc1.d/, /etc/rc5.d/ and /etc/rc6.d/ to automatically log off whenever the system tries to shut down.
    There I've created symbolic links, which I've called "K00logout", pointing to a bash script. The script did the following: "gnome-session-quit --force"
    The numbers in /etc/rc(n).d/ refer to the different runlevels the system is running on and I've had the most success using the script for the runlevels 5, which my Kali booted on, and 0, which is the shutdown runlevel (iirc).

    Anyway, that was a temporary workaround to a workaround, which again, functioned only a couple of times, before all of a sudden, without a (atleast to me) apparent reason, it stopped working.

    At this point I think I'm giving up experimenting myself with different settings, reinstalling the OS, manually powering off my machine and all that stuff.
    I'll just check every day if people post new information about this issue. Hopefully soon this will all make sense to me and to everyone else experiencing this problem.

    Thanks for reading, any help is greatly appreciated!

    ps. I'm not natively speaking english, so please bear with me 8^D
    Last edited by 1Nfra; 2016-08-18 at 08:55. Reason: grammar

Similar Threads

  1. Kali Linux 2016.2 hangs on install?
    By Dexert in forum Installing Archive
    Replies: 1
    Last Post: 2016-10-07, 21:15
  2. Problems with the shutdown and restart. Kali rolling 2016.1
    By Lana in forum TroubleShooting Archive
    Replies: 11
    Last Post: 2016-08-13, 20:43
  3. Kali 2.0 Restart and Shutdown Hangs
    By nekromantik in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-09-29, 22:21

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts