This is my first time using Kali Linux. I have been trying to install Kali on Virtualbox and I am trying to get full screen mode working. So this is what I've done straight after the install:

I ran these commands:

apt-get update
apt-get upgrade
apt-get dist-upgrade

These commands went through but updated nothing. I then tried to update the headers:

apt-get install linux-headers-$(uname -r)

Which left the message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-4.3.0-kali1-686-pae
E: Couldn't find any package by glob 'linux-headers-4.3.0-kali1-686-pae'
E: Couldn't find any package by regex 'linux-headers-4.3.0-kali1-686-pae'

So I then went and done:

nano /etc/apt/sources.list

By default everything was commented out. I tried adding some repositories from some forum posts but it broke the installation after trying the updates. So I restarted the installation and used this repository "deb http://http.kali.org/kali kali-rolling main contrib non-free" (taken from the documentation) and ran the update/upgrade commands. It ran a lot of updates and when I tried to install the headers again I received the same error messages.

I'm not sure what to try next so any help is much appreciated, thanks!