Results 1 to 3 of 3

Thread: Fix for "Module w1 not found in directory" for USB Persistence Users

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Fix for "Module w1 not found in directory" for USB Persistence Users

    I finally installed my wifi correctly after a week of debugging.

    For some reason even after I "apt-update", "apt-upgrade", "apt dist-upgrade", and rebooted, my kernel was not updated. So, basically I downloaded the old 4.3.0 headers and installed them.

    Here is some basic information about my perstistence usb drive and how I installed it:
    • 500 GB Hard Drive (Seagate)
    • Installed using most recent (2016.1) kali iso from torrent
    • Drive is persistent
    • I'm running side by side with Mac OSX El Capitan
    • I'm using rEFind as my boot manager
    • I have BCM4360 driver

    1. Navigate to /etc/apt/list and copy and paste this:
      deb kali-rolling main contrib non-free
      deb-src kali-rolling main contrib non-free
      deb jessie main contrib non-free
      deb moto main non-free contrib
    2. run
      apt-get update
    3. Download from
      "linux-headers-4.3.0-kali1-amd64_4.3.3-5kali4_amd64.deb" and "linux-headers-4.3.0-kali1-common_4.3.3-5kali4_amd64.deb"
    4. Download from , "linux-kbuild-4.3_4.3.1-2kali1_amd64.deb"
    5. Download package gdebi package (both gui and main one) through the package manager
    6. Open up gdebi GUI
    7. Install each package listed above using gdebi GUI, starting with the "linux-kbuild" package, followed by the "linux_headers_common", then the "linux_headers"
    8. Ok, here's the important part: DO NOT RUN "apt-update" right after!!!
    9. Instead, run
      apt-get install broadcom-sta-dkms
    10. Run
      modprobe -r b44 b43 b43legacy ssb brcmsmac
    11. Then finally run
      modprobe wl
    12. Code:
    13. And boom! Your wifi should be working!

    If you want to see how I installed my live persistence usb, just look for my last post!

    Hopes this helps! I'm sure relieved that I finally figured it out .
    It took me more than 80 hours to figure it out after looking all over google, stackoverfow, reddit, and kali forums .

    Here's my rambling about my debugging problems if you are interested:
    The problem with kali's usb persistence is that the kernel seems to not be able to upgrade, even after "apt-update", "apt-upgrade", "apt dist-upgrade".(when I ran "uname -r" it returned 4.3.0 instead of 4.5.0). Still, when I ran "apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms" I got drivers for 4.5.0... weird...

    So, yeah I tried the debian broadcom "wl" tutorial and had no luck
    Last edited by juxtaposition1997; 2016-05-17 at 09:34.

Similar Threads

  1. Failed to load module "canberra-gtk-module"
    By kal in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-12-08, 13:28
  2. Replies: 4
    Last Post: 2013-05-27, 08:51
  3. Metasploit module "Java 7u17 Applet Reflection Type Confusion" not found
    By NightCrawler in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-05-03, 15:35

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts