Hello Guys, I am new here and I hope to learn and share knowledge with the members of this forum.

I am having an issue with my Kali Linux Rolling, I get this error when I try to install or upgrade on my kali, I figured out i removed (findutils) from my system and each time the system tried to put it back through (apt-get dist-upgrade) I get the following error:

sudo apt-get clean
sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 694 kB of archives.
After this operation, 1,436 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.debian.org/debian wheezy/main amd64 findutils amd64 4.4.2-4 [694 kB]
Fetched 694 kB in 2s (287 kB/s)
dpkg: warning: 'find' not found in PATH or not executable
dpkg: error: 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)

I get the same error when i try to install other packages ever since, I need help to resolve this, I am new to Kali but I love it... Any help will be greatly appreciated