Results 1 to 6 of 6

Thread: keyboard doubles all entries

  1. #1
    Join Date
    2016-Jun
    Posts
    3

    keyboard doubles all entries

    I just completed the installation of 4.3.0-kali1-amd64 without difficulty. However, upon rebooting the machine I find that any letter I type into the username or password fields is doubled, and I am not allowed to log in with the password I gave during setup. During setup there was no apparent keyboard problem, nor is there a problem if I boot single user to the command line. The mouse is also very uncooperative - slow and jumpy. I also notice that the keyboard echo is slow - and the second, repeated character comes about a tenth of a second later than the first.

    What to do? Is it possible to prevent the system from coming up in GUI mode? I don't see how to change anything if I can't log in. sshd is not active yet.

    Daniel Feenberg

  2. #2
    Join Date
    2016-Mar
    Posts
    10
    I've never had this sort of problem, so I'm going in blind. Maybe try logging in to single user mode and updating Kali to see if that will solve your problem.
    Do you have any spare external keyboards that you could try?

  3. #3
    Join Date
    2016-Jun
    Posts
    3

    Bypassing login gui

    Quote Originally Posted by Wintersprings View Post
    I've never had this sort of problem, so I'm going in blind. Maybe try logging in to single user mode and updating Kali to see if that will solve your problem.
    Do you have any spare external keyboards that you could try?
    I tried a different keyboard - no effect, then used cntl-alt-f2 to get a different login screen. No problem logging in there. I thought I would be clever and create a login that was all doubled letters. That login works on the non-gui login, but not the gui. I would like to start the gui after logging in, but can't find the command to do that. Do you know what it is?

    Also, the dragon picture obscures the GRUB menu - is there a way to eliminate the picture?

    daniel feenberg
    NBER

  4. #4
    Join Date
    2016-Mar
    Posts
    10
    To start the GUI from command line, type "service gdm3 start".

    To remove the splash screen from grub, you need to remove or rename the the grub picture file. I think it is stored in /usr/share/images/desktop-base/desktop-grub.png (either rename the file or delete it) then run "update-grub" without the quotes.

    After a bit of research It seems that you can disable key repeats by typing "xset r off"
    You can type "xset r" to restore default key repeats.

    Have a play around with some of these settings and see what you come up with.

    Good luck.

  5. #5
    Join Date
    2016-Apr
    Posts
    100
    I had this problem as well until I installed the nvidia drivers. OP what video chip or card you using?

    Code:
    lspci -vnn | grep VGA -A 12

  6. #6
    Join Date
    2016-Jun
    Posts
    3
    Quote Originally Posted by Wintersprings View Post
    To start the GUI from command line, type "service gdm3 start".
    I tried that - the prompt returned with no error message but the GUI did not display.

    Quote Originally Posted by Wintersprings View Post
    To remove the splash screen from grub, you need to remove or rename the the grub picture file. I think it is stored in /usr/share/images/desktop-base/desktop-grub.png (either rename the file or delete it) then run "update-grub" without the quotes.
    That worked - thanks.
    Quote Originally Posted by Wintersprings View Post
    After a bit of research It seems that you can disable key repeats by typing "xset r off"
    You can type "xset r" to restore default key repeats.
    There is a Catch-22 here - I would need to be logged in to issue that command, and the keyboard repeats prevent me from logging in at the GUI login screen. I would need to put the command somewhere in the code that puts up the login screen, and I haven't found where that code is. Using cntl-alt-f2 to get a text terminal is not enough - the xset command issued there doesn't affect the login screen. It would have to be edited into some script that executes pre-login.

    Quote Originally Posted by Wintersprings View Post
    Have a play around with some of these settings and see what you come up with.

    Good luck.
    Quote Originally Posted by P373 View Post
    I had this problem as well until I installed the nvidia drivers. OP what video chip or card you using?

    Code:
    lspci -vnn | grep VGA -A 12
    Apparently the chipset is ASPEED Grpahics family rev(30). It is a fairly new Supermicro box, had no trouble with Centos or Freebsd.

    Quote Originally Posted by Wintersprings View Post
    To start the GUI from command line, type "service gdm3 start".

    After a bit of research It seems that you can disable key repeats by typing "xset r off"

    Good luck.
    But where would that command go to have it execute before the login screen was displayed?
    I can use cntl-alt-f2 to login without the GUI and edit a script, if I knew which script to edit.
    According to the man page the effect of the command does not persist across logins.

    Daniel Feenberg
    Last edited by maiki; 2016-06-20 at 12:21. Reason: Merge posts

Similar Threads

  1. Replies: 2
    Last Post: 2016-05-05, 20:59
  2. ARP Ping bug? no entries in the table
    By matteboy in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-01-27, 14:46
  3. Partition table entries are not in disk order
    By Rocketballz in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-08-17, 09:37

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •