Results 1 to 5 of 5

Thread: ARM Image 2.1.2 for HP Chromebook Spring seems broken

  1. #1
    Join Date

    Exclamation ARM Image 2.1.2 for HP Chromebook Spring seems broken

    hi there,

    I got a SPRING HP 11" Chromebook with Exynos 5250 1.7GHz dual core processor and 2 GB of RAM and I try to install
    the ARM image Version 2.1.2, provided on the Kali downmload website @ Chromebooks - HP, Samsung & Acer.

    What I did is putting the book in developer mode and activate USB boot, which all seem to work fine.

    First thing I noticed was, generating the bootable USB stick via terminal "dd" aka diskdump results in an un-readable USB-Stick.
    I tried this directly on the book´s shell and also on a PM running ubuntu MATE 16.04. I did a "lsblk" to find out
    how the USB-stick was mounted. I did everything like it is advised over here :
    So i am confident, I did everything o.k.

    But everytime, I put this stick in and CTRL-U, the book just beeped at me...

    To get the data from the image copied "the right way", I went to my ubuntu install and just double-clicked the img.xz file
    in filemanager and choose "recover".

    Now the operation took much longer, than my "dd" atempts before - but got me something, that is at least bootable.
    (The stick has now partitions, ChromeOS kernel and a readable filesystem - yeah!)

    When I plug this into the book and CTRL-U, it starts to boot from the stick, no more beeps - but "panics" and Kali will not boot, see:

    So I tried with another (new) USB-stick (instead of the older, thrusty one), but got the same issue

    Now - is there an older, but working img for my chromebook?
    Can I do something, to fix this problem?
    Will I have to sell this book (just bought it yesterday, only to run Kali on it) and get an intel one?
    What did I wrong?


  2. #2
    Join Date
    So I got a hint, to unzip the img.xz before doing a "dd" or "restore to". this is unfortunatly not possible on my chromebook, because it does not know the file-type/Extension nor "unzip" command.
    Will have to do this on another Linux machine, then - but from what I´ve seen, it gets automatically unzipped, when double clicking in filemanager and select the device, to restore it to...

  3. #3
    Join Date
    Solution: the hint was right - I somehow overlooked, I had to uncompress the .xz image first *facepalm* Now it runs super smooth from my USB drive

    but one thing, maybe for another thread: I get no (boot) menu "live or install or forensic".. it just boots into USB-stick, but I can not choose to install or just run live...

    best regards

    Last edited by Onkelpoe; 2016-06-24 at 06:51.

  4. #4
    Join Date
    There is no live/install/forensics for the ARM images; they are all live installs, and you can use them as if they were installed already.

  5. #5
    Join Date
    yeah right - not too bad

Similar Threads

  1. Replies: 3
    Last Post: 2017-02-11, 11:29
  2. Samsung ARM Chromebook 1.0.6 image not booting
    By wetfeet2000 in forum ARM Archive
    Replies: 4
    Last Post: 2014-07-07, 19:57
  3. Replies: 1
    Last Post: 2014-03-07, 02:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts