Results 1 to 6 of 6

Thread: Nexus 9 - apt-get update causing android crash

  1. #1
    Join Date

    Nexus 9 - apt-get update causing android crash

    I updated my nethunter .apk to the newest version after my tablet crashed the first time. Every time i run this it causes the whole thing to crash. Should i make a new chroot?

    root@kali:~# apt-get update
    Ign  InRelease
    Hit sana/updates InRelease
    Hit sana InRelease
    Hit sana/updates/main armhf Packages
    Hit sana/main armhf Packages
    Hit sana/updates/contrib armhf Packages
    Hit sana/non-free armhf Packages
    Hit sana/updates/non-free armhf Packages
    Hit sana/contrib armhf Packages
    Ign sana/contrib Translation-en_US
    Ign sana/updates/contrib Translation-en_US
    Ign sana/contrib Translation-en
    Ign sana/updates/contrib Translation-en
    Ign sana/main Translation-en_US
    Ign sana/updates/main Translation-en_US
    Ign sana/main Translation-en
    Ign sana/updates/main Translation-en
    Ign sana/non-free Translation-en_US
    Ign sana/updates/non-free Translation-en_US
    Ign sana/non-free Translation-en
    Ign sana/updates/non-free Translation-en
    W: Failed to fetch  Hash Sum mismatch
    W: Failed to fetch  Hash Sum mismatch
    W: Failed to fetch  Hash Sum mismatch
    W: Failed to fetch  Hash Sum mismatch
    I do not understand what is going on here, everything was just fine a week ago..And now the device is bootlooping. Gets to "android is starting", runs for about 5-8 minutes barely getting past 66 apps and then "Reboots" and does the whole thing again... I have no idea what has happened to my NH install or my tablet, i might just reset and use a diff android build until NH is past 3.0, because this is getting..painful.

    ANY help would be appreciated, i dont want to lose whats on the tablet..

  2. #2
    Join Date
    I'm having the same issue - Nexus 9 reboots when the apt-get installs python-twisted-core. Were you able to resolve?

  3. #3
    Join Date
    Thats not a crash, is it? looks like its tried fetching packages from the Repo and it hasnt found the address (coz its wrong) im sure that


    should be something like...


    if so youll have to amend your sources.list

    i just use the "check for updates" update-kali-metapackages" "check app updates" tabs.

    check if thats the right repo anyway. in pretty sure that my previous kali-linux-desktop OS used the sana repo...
    if theres a problem with your repo that would explain the bootloops,


    apt autoclean
    apt autoremove

    clean it up a bit
    Last edited by Leon4911; 2016-10-19 at 11:15. Reason: details

  4. #4
    Join Date
    Thanks Leon,

    The N9 actually reboots not long after starting to install python-twisted-core. I have to reset dkpg to keep from resuming where it left off. Apt-get -f inevitably revisits the issue. Running fine on my Nexus 7.

    I've done some cleanup before to no avail - I can break out of the install but the python dependencies keep other critical libraries from loading.

    Will get a screenshot.


  5. #5
    Join Date

    any news here? I have the same problem on my Nexus 9
    after i edit der source.list from sana to kali-rolling i try apt-get update && apt-get dist-upgarde. It runs good. The installation of python-twisted-core failed with full system reboot. Next try the same. I check to dpkg --configure python-twisted-core manuell but its the same.

  6. #6
    Join Date
    hi sorry about the late reply but hope this helps...

    1-make sure all repos are correct and upto date in the sources.list then run...
    apt update
    (this will update the list of pkg's now listed within the new repo)
    apt-get install build-essential
    apt-get install libsqlite3-dev
    apt-get install sqlite3
    apt-get install bzip2 libbz2-dev
    2-boot into the vnc desktop enviroment
    3-install synaptic using root terminal from within the desktop vnc this will allow install/uninstall as well as individual install/uninstall of pkg's...
    4-open synaptic from the applications menu within the vnc.
    5-click reload
    6-click mark all upgrades
    7-click apply
    --it all goes through without any issues good, if not then...
    8-type python into the synaptic search tab
    9-look through all available/installed python pkg's and look for anything out of place.
    "check box color referances"
    green = installed
    red = broken (i think)
    grey exclimation mark = upgradable.
    7-if you cant identify any issues right click python pkg's and mark for reinstallation.

    synaptic is what i turn to when terminal input isnt sorting pkg issues.

    if for any reason you have problem using vnc or synaptic try the following from terminal app (not vnc).


    (file system consistancy check and repair command)

    nohup apt-get update

    (runs update that is immune to hangups and writes any issues encounterd in a text file called nohup.out which you can read using nano or vim etc)

    !!!!!! do this at your own risk !!!!!!
    apt-get purge python*

    (removes all pkg's installed related to python, after this is done reinstall python with apt-get install or use apt-cache search python to list all python pkg's and try installing it one pkg at at time starting with the most relivent)

    ***some times, installing a previous version of the available pkg your having issues with before installing the current version will help sort the issue****

    ***alternatively i think downloading said file from github or where ever its hosted and installing it from within your device and not relying on a internet connection is the best way to install it.***

    python-twisted-core is labeled as being a 'event-based framework for internet application' and the python scripts involved are anything from your network interface and right down to sockets so i suspect any issue with this pkg could cause update problems for any number of reasons.

    either way let me know what the outcome is and ill see if i can be of any further help...
    Last edited by Leon4911; 2017-02-12 at 03:44.

Similar Threads

  1. ALFA AWUSO36NH v2 causing computer to lock up and crash
    By Cosmo42 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-01-14, 01:18
  2. Nexus 7 (2013) + TL-WN722N Causing Kernel Panic
    By mire3212 in forum NetHunter General Questions
    Replies: 22
    Last Post: 2015-09-24, 04:41
  3. Settings causes my Nexus 7 (2013) to crash
    By piratestatic29 in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-02-02, 15:02
  4. Replies: 15
    Last Post: 2013-09-13, 18:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts