Results 1 to 9 of 9

Thread: Mouse scrolls wrong way in Terminal window

  1. #1
    Join Date
    2016-Jul
    Posts
    7

    Question Mouse scrolls wrong way in Terminal window

    Greetings, everyone,

    I am running Kali Linux 2016.1 rolling 32-bit (Debian 4.6.2-2kali2) as a VirtualBox VM (version 5.0.2 r102096). The host OS is Linux Mint 17.3 64-bit running on a Lenovo Thinkpad T430 laptop.

    The VirtualBox guest tools are installed (version 5.0.24-dfsg-2 from the Kali repository) and they work, including the seamless desktop, mouse integration, shared clipboard, and drag and drop back and forth. I'm also sharing a local folder through the Shared Folders tool.

    When I hold down the middle-mouse button and push the mouse cursor up, the terminal window instead goes down, like a dragging your finger up on a tablet. It seems to be tied to a feature called "Natural Scrolling" which I have disabled. It behaves the same way regardless of the setting. Screenshot of setting is attached.

    The browser does not have this strange issue; only the terminal window.

    I tried following the instructions here https://www.maketecheasier.com/rever...ion-in-ubuntu/ but the behavior was unchanged.
    I found the same suggestion on other sites.

    I'm not sure if these are relevant, but including them just the same.
    Code:
    root@unresponsive:~/incoming# lsusb
    Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Code:
    root@unresponsive:~/incoming# lspci
    00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
    00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
    00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
    00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
    00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
    00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
    00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
    00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
    00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
    00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)
    Any guidance would be appreciated.

    Thanks!
    AP
    Attached Images Attached Images

  2. #2
    Join Date
    2016-Jul
    Posts
    8
    Same here with Kali Rolling 64 Bit updated yesterday using Virtualbox 5.0.24 with manual installing VBox Additions via VBox Guest Image. But despite of only gnome-terminal various applications are affected, e.g. dconf-editor, firefox, wireshark. The "Natural Scrolling" setting as documented by AP above doesn't change anything even after re-login or reboot.

    Thanks,
    spoppi

  3. #3
    Join Date
    2016-Jul
    Posts
    7
    I also just rebuilt a Kali Linux 64-bit rolling system on VMware vSphere (version 5.5.0). Using the open-vm guest tools, mouse scrolling works consistently and correctly on this system.

  4. #4
    Join Date
    2016-Jul
    Posts
    8
    Anyone already found a solution? I've updated Kali x64 today on Virtualbox 5.0.26 but nothing changed the behavior back, it's getting really boring now.

    Thanks,
    spoppi

  5. #5
    Join Date
    2014-Oct
    Posts
    2
    I am having the same problem. I have the problem in KeepNote and Firefox as well.

    Did anyone find an answer?

  6. #6
    Join Date
    2016-Jul
    Posts
    8
    Not yet a solution but switching from Gnome to KDE restores the "correct" behavior in KDE. Looks like a setting in Gome changed the direction. Since I'm ok with KDE I won't dig into it deeper in Gnome.

    spoppi

  7. #7
    Join Date
    2014-Sep
    Posts
    2
    me also no any solution also on new version 2016.2

  8. #8
    Join Date
    2016-Sep
    Posts
    1
    I'm having the same problem but opposite. I have natural scrolling enabled on my mac host, and regardless of the setting in the virtual box Kali guest, it will only do non-natural scrolling. For me it is OS wide though. It is not restricted to the terminal window.

    It sounds to me like the kali guest is just inverting whatever is sent to it from the host and completely disregarding the setting in "Mouse and Touchpad" settings.

  9. #9
    Join Date
    2016-Jul
    Posts
    1
    I found a solution for the problem. You can see that VirtualBox has a tablet input device, not a mouse. The natural scrolling option in the system settings only apply to mice though. With a console command, you can disable natural scrolling for tablet input devices:

    In the new Gnome 3.20 currently on Tumbleweed there are actually TWO "natural scrolling" settings switches, one for the mouse and the other for the touchpad.
    Please be sure to switch off both, or at least the one applying to the pointer device you are actually using.

    If that fails, try one of the following:

    Code:
    gsettings get org.gnome.desktop.peripherals.mouse natural-scroll
    gsettings get org.gnome.desktop.peripherals.touchpad natural-scroll
    
    gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false
    gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false
    Found here: https://forums.opensuse.org/showthre...19#post2774919

    Edit: Alternatively you can change the input device type from USB Tablet to PS/2 Mouse in the settings of the VM.
    Last edited by Damarus; 2016-10-12 at 15:58.

Similar Threads

  1. Stuck in terminal window ._.
    By Grape54367 in forum General Archive
    Replies: 2
    Last Post: 2016-12-01, 01:43
  2. Mouse issue: Mouse gets caught under the active window
    By nekochanime in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-01-08, 21:22
  3. auto-raise mouse focus problems when closing last window
    By r0tati0n in forum General Archive
    Replies: 4
    Last Post: 2014-10-22, 17:48

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •