Results 1 to 2 of 2

Thread: Kali-rolling dist-upgrade failed

  1. #1
    Join Date
    2016-Jul
    Posts
    3

    Kali-rolling dist-upgrade failed

    Hi all:
    I'm already on kali-rolling (raspberry pi), but carrying out a normal dist-upgrade I get an error with texlive-base
    System:
    Code:
    root@kali:~# uname -a
    Linux kali 3.18.16-v7 #1 SMP PREEMPT Thu Jan 28 17:34:57 CST 2016 armv7l GNU/Linux
    
    root@kali:~# cat /etc/apt/sources.list
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    Result:
    Code:
    root@kali:~# apt-get clean
    root@kali:~# apt-get update
    Get:1 http://ftp.hands.com/kali kali-rolling InRelease [30.5 kB]
    Get:2 http://ftp.hands.com/kali kali-rolling/main armel Packages [13.5 MB]
    Fetched 13.6 MB in 31s (431 kB/s) 
    Reading package lists... Done
    
    root@kali:~# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree 
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
    ...
    (Long list)
    ...
    294 upgraded, 592 newly installed, 53 to remove and 1 not upgraded.
    Need to get 203 MB/1,329 MB of archives.
    After this operation, 1,982 MB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    Get:1 http://ftp.hands.com/kali kali-rolling/main armel 
    ...
    (Long list)
    ...
    Removing texlive-latex-base (2012.20120611-5) ...
    dpkg: texlive-binaries: dependency problems, but removing anyway as you requested:
    texlive-base depends on texlive-binaries (>= 2012.20120516).
    texlive-luatex depends on texlive-binaries (>= 2012-0).
    Removing texlive-binaries (2012.20120628-4) ...
    ...
    (Long list of other dependency problems)
    ...
    dpkg: error processing archive /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb (--unpack):
    trying to overwrite '/usr/share/doc/texlive-doc/texlive/texlive-en/Makefile', which is also in package texlive-doc-base 2012.20120611-1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Removing luatex (0.70.1.20120524-3) ...
    ...
    (Long list)
    ...
    Errors were encountered while processing:
    /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    trying dpkg --configure -a:
    Code:
    root@kali:~# dpkg --configure -a
    ...
    (Long list)
    ...
    Setting up ruby-nio4r (1.2.1-1) ...
    dpkg: dependency problems prevent configuration of texlive-latex-recommended:
    texlive-latex-recommended depends on texlive-base (>= 2016); however:
    Version of texlive-base on system is 2012.20120611-5.
    dpkg: error processing package texlive-latex-recommended (--configure):
    dependency problems - leaving unconfigured
    ...
    (Long list)
    ...
    Warning: Old configuration style found in /etc/texmf/fmt.d
    Warning: For now these files have been included, 
    Warning: but expect inconsistencies.
    Warning: These packages should be rebuild with tex-common.
    Warning: Please see /usr/share/doc/tex-common/NEWS.Debian.gz
    Warning: found file: /etc/texmf/fmt.d/10texlive-base.cnf
    update-language: texlive-base not installed and configured, doing nothing!
    Removing obsolete conffile /etc/texmf/fmt.d/00tex.cnf ...
    Removing obsolete conffile /etc/texmf/hyphen.d/00tex.cnf ...
    Setting up ruby-docile (1.1.5-1) ...
    Setting up ruby-unf-ext (0.0.7.2-1+b2) ...
    dpkg: dependency problems prevent configuration of texlive-latex-extra:
    texlive-latex-extra depends on texlive-latex-recommended (>= 2016); however:
    Package texlive-latex-recommended is not configured yet.
    texlive-latex-extra depends on texlive-base (>= 2016); however:
    Version of texlive-base on system is 2012.20120611-5.
    
    dpkg: error processing package texlive-latex-extra (--configure):
    dependency problems - leaving unconfigured
    ...
    (Long list)
    ...
    Regenerating '/var/lib/texmf/fmtutil.cnf-DEBIAN'... 
    
    Warning: Old configuration style found in /etc/texmf/fmt.d
    Warning: For now these files have been included, 
    Warning: but expect inconsistencies.
    Warning: These packages should be rebuild with tex-common.
    Warning: Please see /usr/share/doc/tex-common/NEWS.Debian.gz
    Warning: found file: /etc/texmf/fmt.d/10texlive-base.cnf
    
    done.
    Regenerating '/var/lib/texmf/fmtutil.cnf-TEXLIVEDIST'... done.
    update-fmtutil has updated the following file(s):
    /var/lib/texmf/fmtutil.cnf-DEBIAN
    /var/lib/texmf/fmtutil.cnf-TEXLIVEDIST
    If you want to activate the changes in the above file(s),
    you should run fmtutil-sys or fmtutil.
    ...
    (Long list)
    ...
    Setting up libgtk-3-bin (3.20.6-2) ...
    dpkg: dependency problems prevent configuration of texlive-luatex:
    texlive-luatex depends on texlive-base (>= 2016); however:
    Version of texlive-base on system is 2012.20120611-5.
    
    dpkg: error processing package texlive-luatex (--configure):
    dependency problems - leaving unconfigured
    ...
    (Long list)
    ...
    dpkg: dependency problems prevent configuration of texlive-base:
    texlive-base depends on luatex (>= 0.70.1); however:
    Package luatex is not installed.
    Version of luatex on system, provided by texlive-binaries:armel, is <none>.
    texlive-latex-base (2016.20160623-1) breaks texlive-base (<< 2016) and is unpacked but not configured.
    ...
    (Long list of other dependency 'breaks')
    ...
    dpkg: error processing package texlive-base (--configure):
    dependency problems - leaving unconfigured
    ...
    (Long list)
    ...
    Processing triggers for tex-common (6.05) ...
    update-language: texlive-base not installed and configured, doing nothing!
    
    Warning: Old configuration style found in /etc/texmf/fmt.d
    Warning: For now these files have been included, 
    Warning: but expect inconsistencies.
    Warning: These packages should be rebuild with tex-common.
    Warning: Please see /usr/share/doc/tex-common/NEWS.Debian.gz
    Warning: found file: /etc/texmf/fmt.d/10texlive-base.cnf
    
    texlive-base is not ready, skipping fmtutil --all call
    Errors were encountered while processing:
    texlive-latex-recommended
    texlive-latex-extra
    texlive-pictures
    texlive-luatex
    texlive-base
    greenbone-security-assistant
    texlive-latex-base
    texlive-latex-base-doc
    openvas
    ..and then apt-get -f install:
    Code:
    root@kali:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree 
    Reading state information... Done
    Correcting dependencies... Done
    The following additional packages will be installed:
    texlive-base
    Suggested packages:
    xpdf-reader | pdf-viewer
    The following packages will be upgraded:
    texlive-base
    1 upgraded, 0 newly installed, 0 to remove and 246 not upgraded.
    7 not fully installed or removed.
    Need to get 15.6 MB of archives.
    After this operation, 8,553 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://ftp.hands.com/kali kali-rolling/main armel texlive-base all 2016.20160623-1 [15.6 MB]
    Fetched 15.6 MB in 21s (713 kB/s) 
    Preconfiguring packages ...
    Selecting previously unselected package texlive-base.
    (Reading database ... 233806 files and directories currently installed.)
    Preparing to unpack .../texlive-base_2016.20160623-1_all.deb ...
    Unpacking texlive-base (2016.20160623-1) over (2012.20120611-5) ...
    dpkg: error processing archive /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb (--unpack):
    trying to overwrite '/usr/share/doc/texlive-doc/texlive/texlive-en/Makefile', which is also in package texlive-doc-base 2012.20120611-1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    ...
    (Long list)
    ...
    Errors were encountered while processing:
    /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ..and for good measure (especially after the 'update' only had one 'Hit'):

    Code:
    root@kali:~# apt-get clean
    root@kali:~# apt-get update
    Hit:1 http://ftp.hands.com/kali kali-rolling InRelease
    Reading package lists... Done
    root@kali:~# apt-get -f dist-upgrade
    Reading package lists... Done
    Building dependency tree 
    Reading state information... Done
    Correcting dependencies... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
    ...
    (Long list)
    ...
    After this operation, 913 MB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    Get:1 http://ftp.hands.com/kali kali-rolling/main armel gir1.2-coglpango-1.0 armel 1.22.0-2 [30.4 kB]
    ...
    (Long list)
    ...
    Fetched 509 MB in 11min 54s (712 kB/s) 
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 233806 files and directories currently installed.)
    Preparing to unpack .../texlive-base_2016.20160623-1_all.deb ...
    Unpacking texlive-base (2016.20160623-1) over (2012.20120611-5) ...
    dpkg: error processing archive /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb (--unpack):
    trying to overwrite '/usr/share/doc/texlive-doc/texlive/texlive-en/Makefile', which is also in package texlive-doc-base 2012.20120611-1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Reinstalling /etc/texmf/fmt.d/10texlive-base.cnf that was moved away
    Reinstalling /etc/texmf/xdvi/xdvi.cfg that was moved away
    Reinstalling /etc/texmf/dvipdfm/config/config that was moved away
    Processing triggers for mime-support (3.60) ...
    Processing triggers for desktop-file-utils (0.23-1) ...
    Errors were encountered while processing:
    /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I think I've tried the normal measures here - please help!

    Thanks.
    Last edited by junk-I; 2016-07-14 at 15:34. Reason: (WRONG THREAD)

  2. #2
    Join Date
    2016-Jul
    Posts
    3
    Ok guys, think I've fixed it...
    Installed offending package by allowing dpkg to force the overwrite:
    Code:
    root@kali2:~# dpkg -i --force-overwrite /var/cache/apt/archives/texlive-base_2016.20160623-1_all.deb
    root@kali2:~# apt-get -f install
    dpkg: dependency problems prevent configuration of greenbone-security-assistant:
     greenbone-security-assistant depends on texlive-latex-extra; however:
      Package texlive-latex-extra is not configured yet.
    Temporarily removed greenbone-security-assistant openvas:
    Code:
    root@kali2:~# apt-get remove greenbone-security-assistant openvas
    root@kali2:~# apt-get autoremove
    
    root@kali2:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libfreeradius-client2 libhiredis0.13 libjemalloc1 libmicrohttpd10 libopenvas8 libsnmp-base libsnmp30 openvas-cli openvas-manager
      openvas-scanner redis-server redis-tools xsltproc
    Use 'apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    4 not fully installed or removed.
    Found and reconfigured packages not yet installed:
    Code:
    root@kali2:~# dpkg -C
    The following packages have been unpacked but not yet configured.
    They must be configured using dpkg --configure or the configure
    menu option in dselect for them to work:
     texlive-latex-base   TeX Live: LaTeX fundamental packages
     texlive-latex-extra  TeX Live: LaTeX additional packages
     texlive-latex-recommended TeX Live: LaTeX recommended packages
     texlive-pictures     TeX Live: Graphics, pictures, diagrams
    
    root@kali2:~# dpkg --configure texlive-latex-base texlive-latex-extra texlive-latex-recommended texlive-pictures
    Setting up texlive-latex-base (2016.20160623-1) ...
    Removing obsolete conffile /etc/texmf/fmt.d/10texlive-latex-base.cnf ...
    Processing triggers for tex-common (6.05) ...
    Setting up texlive-latex-recommended (2016.20160623-1) ...
    Setting up texlive-pictures (2016.20160623-1) ...
    Processing triggers for tex-common (6.05) ...
    Setting up texlive-latex-extra (2016.20160623-1) ...
    Processing triggers for tex-common (6.05) ...
    Reinstalled greenbone-security-assistant openvas:
    Code:
    root@kali2:~# apt-get install greenbone-security-assistant openvas
    root@kali2:~# apt-get -f dist-upgrade
    And for good measure:
    Code:
    root@kali2:~# apt-get clean
    root@kali2:~# apt-get update && apt-get dist-upgrade
    Appears to have worked (well, reports one package 'kept back', but hey)

Similar Threads

  1. Replies: 16
    Last Post: 2017-01-25, 01:13
  2. Kali Rolling - gdm fails to start after dist-upgrade
    By wtf in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-09-25, 07:43
  3. apt-get dist-upgrade error on Kali Rolling
    By stevo4 in forum TroubleShooting Archive
    Replies: 20
    Last Post: 2016-04-25, 21:43
  4. Replies: 3
    Last Post: 2016-02-09, 00:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •