Results 1 to 4 of 4

Thread: Hibernate not working in Kali Rolling

  1. #1
    Join Date
    2016-Jul
    Posts
    1

    Hibernate not working in Kali Rolling

    I've been on the Kali Rolling repo for about two weeks now, and I noticed that the hibernate/suspend feature doesn't work at all, not in GNOME nor KDE. Whenever I try to do either, my computer reboots, and then, in the middle of that reboot before GDM pops up, it reboots AGAIN.

    I've narrowed down the problem to systemd, and confirmed that executing systemd's hibernate from the command line causes my computer to behave in exactly the same way. I've down a little research on this problem, but nobody seems to have the exact same problem. One of the closest was https://github.com/systemd/systemd/issues/3121, but the main suggestion was to ask the distro's maintainers.

    I looked at https://wiki.archlinux.org/index.php..._and_hibernate and tried adding a resume parameter with my swap partition UUID to my /etc/default/grub (and then update_grub), but that didn't work either, so I removed it. I remember the boot log mentioning something about that partition being invalid/inaccessible (or something like that).

    Anyways, for the life of me, I can't get this to work, so any suggestions would be appreciated.

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    805
    I'd get the output of dmesg, lsusb, lspci, and enter a ticket over at bugs.kali.org

  3. #3
    Join Date
    2013-May
    Posts
    11
    hi,
    did you get the solution of the problem "Hibernate not working in Kali Rolling" ?

  4. #4
    Join Date
    2013-May
    Posts
    11
    I got it working by installing Hibernate extension.

    Hibernate Status Button

    Download here: https://extensions.gnome.org/extensi...status-button/

    give permission to install.

Similar Threads

  1. apt-get update not working on my kali 2.0 rolling
    By linuxfree in forum General Archive
    Replies: 4
    Last Post: 2017-08-23, 21:55
  2. Replies: 2
    Last Post: 2016-06-23, 13:33
  3. Kali Rolling - DHCP stopped working?
    By thornez in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-05-31, 07:46
  4. Openvpn not working in Kali Linux Rolling
    By fonestar in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-05-20, 23:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •