Results 1 to 5 of 5

Thread: Persistence not working - Please help

  1. #1
    Join Date
    2016-Jul
    Posts
    2

    Persistence not working - Please help

    Hi Guys

    I'm hoping you can help me with my problem, it's my first time using Kali as I try to pursue an interest in security and penetration testing.

    I've created a live USB Kali 2016.1 USB drive using the instructions from the Kali website. I've also tried to configure it with persistence using instructions from the site but this failed to work. So I began using different instructions from around the web but still with no joy.

    When booting into Kali Live Persistence I see two USB icons on my desktop, Kali Live and Persistence (the name I gave the partition I created for persistence). Inside the Persistence icon there is the persistence.coif file that was create with / union inside.

    I've tried saving to the desktop, root and documents but they're never there after a reboot. However when I save to the persistence icon/drive it remains after a reboot.

    I've read several posts on here but none as helped me so far which is why I am posting, hopefully I've made a schoolboy error and you can point me in the right direction.

    The commands I used were:

    mkdir -p /mnt/my_usb
    mount /dev/sdb3 /mnt/my_usb
    echo "/ union" > /mnt/my_usb/persistence.conf
    umount /dev/sdb3

    Many thanks for taking the time to read and help in whatever way you can, Cheers

  2. #2
    Join Date
    2013-Feb
    Posts
    225
    I can confirm that persistence is working for me following the kali docs site instructions. Without more information, it's hard to know where you went wrong.

  3. #3
    Join Date
    2016-Jul
    Posts
    2
    I did the same as the Kali Linux instructions. The only thing different I did was use GParted to create the second partition for persistence and made it ext4 instead of ext3 like in the instructions.
    Is there any other info you would like to kno? Thanks

  4. #4
    Join Date
    2015-Mar
    Posts
    48
    Make sure that the persistence.conf file is owned by root, and that the partition is named persistence.

  5. #5
    Join Date
    2017-Feb
    Posts
    2
    I had this problem after making a Live USB not as root (though could have also been this time I made it as non-encrypted). For some reason it did everything fine other then save the persistence.conf file.
    I added it after and everything worked on next boot.
    echo "/ union" > /media/root/persistence/persistence.conf

Similar Threads

  1. Encrypted Persistence Not Working
    By Shnon in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-01-26, 03:18
  2. Live USB persistence not working...
    By mrtippage in forum Installing Archive
    Replies: 1
    Last Post: 2014-11-16, 23:23
  3. Persistence not working
    By Hitman_86 in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2013-04-18, 23:32

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •